JustNotBlue
Posts: 1
Joined: Sun Mar 08, 2020 1:02 pm

Imager says "error writing to storage (while flushing)"

Sun Mar 08, 2020 3:34 pm

When i use Raspberry Pi Imager, i format first, then write to my Samsung Evo + 32GB, after 99% i get the message "error writing to storage (while flushing)". I have tried Raspbian Recommended, Full, Lite, LibreELEC (Pi 2/Pi3) and tried several times. My Pi 3B wont boot, and if i use Pi Imager to format, then write, Windows explorer says Put a disk in sd card.
If i only format using Pi Imager, then Windows explorer says the card is empty. If i format using Pi Imager, then write Buster iso using Etcher, its a succes. But Pi wont boot, and win explorer says the card is on 4,84mb, and its full, containing a folder named efi.

Im using W7 Pro on a HP 4520s and the integrated card reader.

jk1103
Posts: 1
Joined: Sun Mar 08, 2020 9:55 pm

Re: Imager says "error writing to storage (while flushing)"

Sun Mar 08, 2020 10:04 pm

Having the same issue :oops:

supersix
Posts: 4
Joined: Mon Mar 09, 2020 1:33 pm

Re: Imager says "error writing to storage (while flushing)"

Mon Mar 09, 2020 1:34 pm

Count me in! Same here!

pcmanbob
Posts: 8996
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Imager says "error writing to storage (while flushing)"

Mon Mar 09, 2020 1:57 pm

I get the same error , SD card is not recognised by windows, re-flashing same SD card using good old windisk32 imager results in a successful write and a bootable image.

windows 7 pro 64 bit using internal SD card reader I have always used.

Edit...

when I attempted to uninstall this from my pc avast flagged the uninstaller as a virus !!!!
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 25997
Joined: Sat Jul 30, 2011 7:41 pm

Re: Imager says "error writing to storage (while flushing)"

Mon Mar 09, 2020 2:32 pm

First thing to note, you do NOT need to format first. Just select the OS, select the SSD card, then click write and it will do it all for you.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“My wife said to me `...you’re not even listening`.
I thought, that’s an odd way to start a conversation.."

supersix
Posts: 4
Joined: Mon Mar 09, 2020 1:33 pm

Re: Imager says "error writing to storage (while flushing)"

Mon Mar 09, 2020 4:35 pm

jamesh wrote:
Mon Mar 09, 2020 2:32 pm
First thing to note, you do NOT need to format first. Just select the OS, select the SSD card, then click write and it will do it all for you.
Did that. Still getting same error at the 100%.
Tried formatting. Same error at the 100%.
Tried downloading img file. Same error at the 100%.
Tried downloading and formatting. Same error at the 100%.

Basically, same error at the 100%. :D

digitalwalt
Posts: 2
Joined: Mon Mar 09, 2020 11:19 am

Re: Imager says "error writing to storage (while flushing)"

Mon Mar 09, 2020 11:07 pm

I'm having the same problem. I tried both an old 8 GB SanDisk card and a 64 GB PNY card. Same behavior either way. I'm running 64-bit Windows 7 Pro.

I went back to NOOBS and I'm having better luck.


Walt

incognitum
Posts: 464
Joined: Tue Oct 30, 2018 3:34 pm

Re: Imager says "error writing to storage (while flushing)"

Mon Mar 09, 2020 11:34 pm

Anyone having this issue on a more recent version than Windows 7?
Or with an SD card reader that is not internal in a laptop?

digitalwalt
Posts: 2
Joined: Mon Mar 09, 2020 11:19 am

Re: Imager says "error writing to storage (while flushing)"

Mon Mar 09, 2020 11:54 pm

My machine is a DELL XPS 8700 desktop with a built-in multi-format flash card interface on the front panel (likely USB inside). (As I already mentioned, I'm running 64-bit Windows 7 Pro. This is more motivation to dump Windows on this machine and go native Linux (instead of just a Linux virtual machine).)

Walt

Anegadian
Posts: 4
Joined: Tue Mar 10, 2020 12:31 am

Re: Imager says "error writing to storage (while flushing)"

Tue Mar 10, 2020 12:33 am

Same here.

have tried with two Samsung 32gb EVO SD cards.

aguther
Posts: 1
Joined: Mon Mar 09, 2020 10:43 am

Re: Imager says "error writing to storage (while flushing)"

Tue Mar 10, 2020 7:24 am

Also I get the same error, and I hope that soon developers will fix this app

pcmanbob
Posts: 8996
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Imager says "error writing to storage (while flushing)"

Tue Mar 10, 2020 9:00 am

incognitum wrote:
Mon Mar 09, 2020 11:34 pm
Anyone having this issue on a more recent version than Windows 7?
Or with an SD card reader that is not internal in a laptop?
My SD card reader although internal is actually USB2 its just mounted in a 3.5" bay on my desktop PC.

never had any problems writing to any SD card using both win32disk imager or etcher.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

igor4B
Posts: 2
Joined: Tue Mar 10, 2020 6:24 pm

Re: Imager says "error writing to storage (while flushing)"

Tue Mar 10, 2020 6:33 pm

Hi !
I have the same issue!
I tried to use the internal sd card reader of my toshiba L635 with a 64GB SDXC card.
On my computer's technical specs it seems my card reader is limited to 16GB

igor4B
Posts: 2
Joined: Tue Mar 10, 2020 6:24 pm

Re: Imager says "error writing to storage (while flushing)"

Tue Mar 10, 2020 11:32 pm

I tried again with my phone in mass storage mode plugged in usb port and it's the same issue.
It seems to be related to win7...

incognitum
Posts: 464
Joined: Tue Oct 30, 2018 3:34 pm

Re: Imager says "error writing to storage (while flushing)"

Thu Mar 12, 2020 2:19 pm

v1.2 no longer reports flush errors (on Windows), so should work better for those affected.

pcmanbob
Posts: 8996
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Imager says "error writing to storage (while flushing)"

Thu Mar 12, 2020 2:39 pm

incognitum wrote:
Thu Mar 12, 2020 2:19 pm
v1.2 no longer reports flush errors (on Windows), so should work better for those affected.
Just tested v1.2 on win7 pro 64bit , I can report it now works and produces a bootable SD card .

Thanks for all your hard work.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

AviatorNL
Posts: 2
Joined: Thu Mar 12, 2020 10:35 pm

Re: Imager says "error writing to storage (while flushing)"

Thu Mar 12, 2020 10:37 pm

Still have this problem with Windows 10 x64

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 25997
Joined: Sat Jul 30, 2011 7:41 pm

Re: Imager says "error writing to storage (while flushing)"

Fri Mar 13, 2020 7:50 am

AviatorNL wrote:
Thu Mar 12, 2020 10:37 pm
Still have this problem with Windows 10 x64
Are you sure you are running 1.2? The error message has been removed aiui, so it would be odd to still get it.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“My wife said to me `...you’re not even listening`.
I thought, that’s an odd way to start a conversation.."

User avatar
PeterO
Posts: 5726
Joined: Sun Jul 22, 2012 4:14 pm

Re: Imager says "error writing to storage (while flushing)"

Fri Mar 13, 2020 8:17 am

jamesh wrote:
Fri Mar 13, 2020 7:50 am
AviatorNL wrote:
Thu Mar 12, 2020 10:37 pm
Still have this problem with Windows 10 x64
Are you sure you are running 1.2? The error message has been removed aiui, so it would be odd to still get it.
Minor point, but having just reinstalled it there are now two indistinguishable entries in the pop-up menu. This is on Mint-19 running Mate, so a Ubuntu derivative.
PeterO
Discoverer of the PI2 XENON DEATH FLASH!
Interests: C,Python,PIC,Electronics,Ham Radio (G0DZB),1960s British Computers.
"The primary requirement (as we've always seen in your examples) is that the code is readable. " Dougie Lawson

incognitum
Posts: 464
Joined: Tue Oct 30, 2018 3:34 pm

Re: Imager says "error writing to storage (while flushing)"

Fri Mar 13, 2020 9:36 am

PeterO wrote:
Fri Mar 13, 2020 8:17 am
Minor point, but having just reinstalled it there are now two indistinguishable entries in the pop-up menu. This is on Mint-19 running Mate, so a Ubuntu derivative.
Old link in start menu should be overwritten on Windows.
On Linux this is not the case as the name changed from imagingutility to rpi-imager.
Try:

Code: Select all

sudo apt remove imagingutility

User avatar
PeterO
Posts: 5726
Joined: Sun Jul 22, 2012 4:14 pm

Re: Imager says "error writing to storage (while flushing)"

Fri Mar 13, 2020 9:38 am

incognitum wrote:
Fri Mar 13, 2020 9:36 am
PeterO wrote:
Fri Mar 13, 2020 8:17 am
Minor point, but having just reinstalled it there are now two indistinguishable entries in the pop-up menu. This is on Mint-19 running Mate, so a Ubuntu derivative.
Old link in start menu should be overwritten on Windows.
On Linux this is not the case as the name changed from imagingutility to rpi-imager.
Try:

Code: Select all

sudo apt remove imagingutility
Thanks, but it's another example of things being changed without considering the impacts ! :roll:
PeterO
Discoverer of the PI2 XENON DEATH FLASH!
Interests: C,Python,PIC,Electronics,Ham Radio (G0DZB),1960s British Computers.
"The primary requirement (as we've always seen in your examples) is that the code is readable. " Dougie Lawson

AviatorNL
Posts: 2
Joined: Thu Mar 12, 2020 10:35 pm

Re: Imager says "error writing to storage (while flushing)"

Fri Mar 13, 2020 6:19 pm

PeterO wrote:
Fri Mar 13, 2020 8:17 am
jamesh wrote:
Fri Mar 13, 2020 7:50 am
AviatorNL wrote:
Thu Mar 12, 2020 10:37 pm
Still have this problem with Windows 10 x64
Are you sure you are running 1.2? The error message has been removed aiui, so it would be odd to still get it.
Minor point, but having just reinstalled it there are now two indistinguishable entries in the pop-up menu. This is on Mint-19 running Mate, so a Ubuntu derivative.
PeterO
Yes, I run V1.2

User avatar
DougieLawson
Posts: 38500
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: Imager says "error writing to storage (while flushing)"

Fri Mar 13, 2020 8:45 pm

jamesh wrote:
Fri Mar 13, 2020 7:50 am
Are you sure you are running 1.2? The error message has been removed aiui, so it would be odd to still get it.
Thank you James. The current version has a clear display of version info and installed without the scary Win10 [You're going to destroy your system] pop-up.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

I'll do your homework for you for a suitable fee.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

Area30
Posts: 5
Joined: Fri Nov 08, 2013 12:35 pm

Re: Imager says "error writing to storage (while flushing)"

Mon May 18, 2020 4:04 pm

Hi,

using Raspberry Pi Imager v1.2 on Windows 10, I still get the message "Error writing to storage".
I try to write Raspian Lite to a 4 Gb SD-Card. The card can be written with W32 Disk Imager or with Etcher without problems.
RPI-Imager-Error.png
RPI-Imager-Error.png (27.81 KiB) Viewed 368 times
Any hints?

Regards
Area

sjz
Posts: 1
Joined: Mon May 18, 2020 5:16 pm

Re: Imager says "error writing to storage (while flushing)"

Mon May 18, 2020 5:23 pm

I have the same problem and have been able to determine that it (so far) seems to be related to USB3.x read/write. In addition to the imager ultimately help identify several bad SD cards, I have only been able to successfully image on a USB2.x port using the same SDCard adapter (the adapter itself is just fine).

I am unsure (because I have spent almost no time looking for it) what the ACTUAL error means. I hope to download the sources later (I believe that it's open source) and see what more I can learn. I am writing this primarily because I want to note that others have this issue, and that I have, through trial-and-error, identified a place to begin looking for a solution.

Return to “Troubleshooting”