bablu_boy
Posts: 5
Joined: Mon Dec 10, 2012 3:24 pm

Berryboot Headless Install

Mon Dec 24, 2012 2:17 am

hi,
I do not have a monitor attached to my Raspberry Pi and trying to do a headless install with Berryboot. I added the vnc install option to the cmdline.txt before copy the berryboot files to the SD Cards.
The contents of the cmdline.txt looks like this:
quiet bootmenutimeout=10
vncinstall

After switching on the Pi, I can see that it has obtained a IP from my router (using nmap scan) and can ping it as well.
however when I try to vnc into it from my ubuntu desktop using:
xtightvncviewer 192.168.1.6:0

I get the following:
xtightvncviewer: ConnectToTcpAddr: connect: Connection refused
Unable to connect to VNC server
sid@sid-NC10:~/Downloads$

I have tried VNC ports of 0 and 1, but still the same issue.
Appreciate help on how I can see the Berryboot options and complete the installation remotely.

Many thanks in advance.

Max

Re: Berryboot Headless Install

Mon Dec 24, 2012 12:55 pm

bablu_boy wrote: The contents of the cmdline.txt looks like this:
quiet bootmenutimeout=10
vncinstall
cmdline.txt options must be on a single line (as opposed to the stuff in config.txt).

bablu_boy
Posts: 5
Joined: Mon Dec 10, 2012 3:24 pm

Re: Berryboot Headless Install

Mon Dec 24, 2012 1:14 pm

Max wrote:
bablu_boy wrote: The contents of the cmdline.txt looks like this:
quiet bootmenutimeout=10
vncinstall
cmdline.txt options must be on a single line (as opposed to the stuff in config.txt).
OK. Will try that. However what is the delimiter between the options on the single line. Is the below ok for cmdline.txt?
quiet bootmenutimeout=10;vncinstall

many thanks.

Max

Re: Berryboot Headless Install

Mon Dec 24, 2012 1:16 pm

bablu_boy wrote: OK. Will try that. However what is the delimiter between the options on the single line.
Spaces
"quiet" and "bootmenutimeout=10" are two separate options.

Return to “Troubleshooting”

Who is online

Users browsing this forum: No registered users and 56 guests