bennydrill
Posts: 1
Joined: Fri Feb 14, 2020 4:32 am

IOGEAR KVM locks up following Raspberry boot

Fri Feb 14, 2020 4:49 am

Hi, I have an IOGEAR GCS1104 KVM switch connected to a Raspberry Pi, and whenever the Raspberry is booted it locks the KVM which has to be powered off/on in order to accept any keystrokes. Once the KVM is power reset, everything works as expected. The IOGEAR manufacturer has no useful answers, so perhaps I can get an answer here.

The boot log messages are shown below:
Feb 10 17:50:04 raspberrypi kernel: [ 95.457242] usb 1-1.1.3.4: new full-speed USB device number 10 using dwc_otg
Feb 10 17:50:04 raspberrypi kernel: [ 95.589088] usb 1-1.1.3.4: New USB device found, idVendor=0557, idProduct=8021, bcdDevice= 1.00
Feb 10 17:50:04 raspberrypi kernel: [ 95.589098] usb 1-1.1.3.4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
Feb 10 17:50:04 raspberrypi kernel: [ 95.590149] hub 1-1.1.3.4:1.0: USB hub found
Feb 10 17:50:04 raspberrypi kernel: [ 95.590708] hub 1-1.1.3.4:1.0: 4 ports detected

Feb 10 17:50:10 raspberrypi kernel: [ 100.877326] usb 1-1.1.3.4.1: new full-speed USB device number 11 using dwc_otg
Feb 10 17:50:10 raspberrypi kernel: [ 101.039118] usb 1-1.1.3.4.1: New USB device found, idVendor=0557, idProduct=2213, bcdDevice= 1.00
Feb 10 17:50:10 raspberrypi kernel: [ 101.039136] usb 1-1.1.3.4.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Feb 10 17:50:10 raspberrypi kernel: [ 101.039146] usb 1-1.1.3.4.1: Product: GCS1104 V1.3.122
Feb 10 17:50:10 raspberrypi kernel: [ 101.039155] usb 1-1.1.3.4.1: Manufacturer: IOGEAR

Feb 10 17:50:10 raspberrypi kernel: [ 101.062131] input: IOGEAR GCS1104 V1.3.122 as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.1/1-1.1.3/1-1.1.3.4/1-1.1.3.4.1/1-1.1.3.4.1:1.0/0003:0557:2213.0006/input/input10
Feb 10 17:50:10 raspberrypi kernel: [ 101.128710] hid-generic 0003:0557:2213.0006: input,hidraw0: USB HID v1.00 Keyboard [IOGEAR GCS1104 V1.3.122] on usb-3f980000.usb-1.1.3.4.1/input0
Feb 10 17:50:10 raspberrypi kernel: [ 101.155231] usbhid 1-1.1.3.4.1:1.1: can't add hid device: -32
Feb 10 17:50:10 raspberrypi kernel: [ 101.155296] usbhid: probe of 1-1.1.3.4.1:1.1 failed with error -32

Feb 10 17:50:10 raspberrypi kernel: [ 101.158122] hub 1-1.1.3.4:1.0: hub_ext_port_status failed (err = -32)

Feb 10 17:50:10 raspberrypi kernel: [ 101.159848] usb 1-1.1.3.4-port1: cannot reset (err = -32)
I have been unable to find an explanation for an error 32. Any thoughts anyone?
Raspbian details:
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
Thanks, Nigel

Return to “Troubleshooting”