HvdW
Posts: 47
Joined: Tue Jun 17, 2014 12:41 pm

Lost: Change keyboard layout

Sun Feb 09, 2020 12:50 pm

Hi,
I crippled my RPI install. (on RPI 3+)
I don't know how, but the result is that when I connect through PuTTY the lines in Raspi-Config and in mc are displayed as signs, like + and others.
When I open rasp-config and goto localiasation I can set language and timezone.
Changing keyboard layout gives strange output:

Code: Select all

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = "en_GB.UTF-8",
        LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales (this might take a while)...
  en_GB.UTF-8... done
Generation complete.
or

Code: Select all

Reloading keymap. This may take a short while
I don't get the chance to change keyboard layout.
Maybe I erased something? But what? How can I restore this.

This failure of displaying lines wouldn't be a big problem, hoever I have installed pivpn with WireGuard and now the QR code doesn't display as such.
Help is appreciated.

PS
I did the buster install on my old RPI B as well to test and there everything displays just fine.

PPS
The output of locale :

Code: Select all

LANG=en_GB.UTF-8
LANGUAGE=
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=en_GB.UTF-8
The contents of /etc/default/locale:

Code: Select all

#  File generated by update-locale
LANG=en_GB.UTF-8
The contencts of /etc/default/keyboard:

Code: Select all

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="us"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"
Running the option Change WiFi country results in:

Code: Select all

Could not communicate with wpa_supplicant
I tried export LC_ALL=en_GB.UTF-8 which resulted in a locale display like:

Code: Select all

LANG=en_GB.UTF-8
LANGUAGE=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=en_GB.UTF-8
Watch the missing " " on some lines.
Who knows knows
Who doesn't doesn't

User avatar
jojopi
Posts: 3190
Joined: Tue Oct 11, 2011 8:38 pm

Re: Lost: Change keyboard layout

Sun Feb 09, 2020 7:16 pm

HvdW wrote:
Sun Feb 09, 2020 12:50 pm
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = "en_GB.UTF-8",
LANG = "en_GB.UTF-8"
are supported and installed on your system.
Those settings are valid. Rather than debug why the locale is selected but not generated, I suggest installing the locales-all package. This trades some disk space for making all locales work without generation:

Code: Select all

sudo apt update
sudo apt install locales-all
I don't know how, but the result is that when I connect through PuTTY the lines in Raspi-Config and in mc are displayed as signs, like + and others.
Fix locale first. Check that PuTTY is set to UTF-8 for remote character set, and to "Use Unicode line drawing code points". If this does not solve the problem, it would help to show us exactly what the lines and QR codes are looking like.
I don't get the chance to change keyboard layout.
Did you see my reply in the other thread? You do not have a USB keyboard plugged into the Pi (or dpkg-reconfigure thinks you do not). PuTTY sends ASCII/Unicode character numbers, not keyboard codes, so the keyboard setting is irrelevant in that case.
Running the option Change WiFi country results in:
Could not communicate with wpa_supplicant
I do not know about WiFi, sorry.

HvdW
Posts: 47
Joined: Tue Jun 17, 2014 12:41 pm

Re: Lost: Change keyboard layout

Sun Feb 09, 2020 11:06 pm

Hi,

Solution found!
Shame on me!
From Lubuntu everything's fine, not from W10
Conclusion: it's me and not RPI
Then I deleted the PuTTY profile and created a new profile.
Connected: SUCCESS!

Anyway, thank you very much for assisting.

Here is a view like it was on my RPI 3+ (left) and RPI B (right)
Knipsel.PNG
Knipsel.PNG (53.48 KiB) Viewed 174 times
The QR looked like this and is now back to normal.
Knipselqr.PNG
Knipselqr.PNG (12.63 KiB) Viewed 174 times
Who knows knows
Who doesn't doesn't

Return to “Troubleshooting”