PaulUK
Posts: 2
Joined: Tue Feb 04, 2020 5:24 pm

Not able to install software on R-PI 4 running Buster

Tue Feb 04, 2020 5:44 pm

Hello All,
First post here, I'm having problems installing packages/software using "sudo apt install XXXX" from terminal and using the Add/Remove Programs app. For example I wanted to install GIMP with "sudo apt install gimp", here are the errors that I get after I enter "y" to continue.

Code: Select all

Err:1 http://raspbian.raspberrypi.org/raspbian buster/main armhf ghostscript armhf 9.27~dfsg-2
  404  Not Found [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/g/ghostscript/ghostscript_9.27~dfsg-2_armhf.deb  404  Not Found [IP: 93.93.128.193 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
I get similar messages when I try to install Octave, KiCad, FreeCAD and many others. Please can someone please help? I did not have these problems with the Rasberry Pi 2. Thank you.

6by9
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 9943
Joined: Wed Dec 04, 2013 11:27 am
Location: ZZ9 Plural Z Alpha, aka just outside Cambridge.

Re: Not able to install software on R-PI 4 running Buster

Tue Feb 04, 2020 5:52 pm

"sudo apt update" first.
Software Engineer at Raspberry Pi Trading. Views expressed are still personal views.
I'm not interested in doing contracts for bespoke functionality - please don't ask.

TheoPA3DSS
Posts: 29
Joined: Fri Nov 09, 2018 9:27 am
Location: Netherlands

Re: Not able to install software on R-PI 4 running Buster

Mon Feb 10, 2020 10:11 am

I have serveral Pi's, one will not update and i don't know why:

Code: Select all

pi@28:~ $ sudo apt update
Get:1 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Fetched 25.4 kB in 3s (6,808 B/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
pi@28:~ $ sudo apt full-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
pi@28:~ $ uname -a
Linux 28 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux
pi@28:~ $ ./model.sh
Raspberry Pi 3 Model B Plus Rev 1.3
Revision        : a020d3
I have an old Pi from 2014 and no problems with the update:

Code: Select all

Raspberry Pi Model B Rev 2
Revision        : 000e
No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 10 (buster)
Release:        10
Codename:       buster
Linux 200 4.19.97+ #1294 Thu Jan 30 13:10:54 GMT 2020 armv6l GNU/Linux
The Pi4 also no problems with the update.

User avatar
davidcoton
Posts: 5517
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK
Contact: Website

Re: Not able to install software on R-PI 4 running Buster

Mon Feb 10, 2020 10:49 am

Your Pi3B+ appears to be still running Stretch. The update is reporting that there is nothing to upgrade, as might be expected for an old OS.

Nothing to worry about (except that your OS is outdated), but you might want to start over with Buster. Upgrade across versions is possible but not recommended.
Location: 345th cell on the right of the 210th row of L2 cache

TheoPA3DSS
Posts: 29
Joined: Fri Nov 09, 2018 9:27 am
Location: Netherlands

Re: Not able to install software on R-PI 4 running Buster

Mon Feb 10, 2020 11:04 am

Ah, thank you for the fast clear answer David !!

Return to “Troubleshooting”