Swap_File
Posts: 24
Joined: Sun Apr 06, 2014 5:31 pm

Buster's libvisual plugin for gstreamer is broken?

Mon Jan 13, 2020 1:32 am

The libvisual plugins (libgstlibvisual.so) that come with Buster's gstreamer packages seem to be broken.

The plugin file exists, but if I type "gst-inspect-1.0 libvisual", it says the plugin contains 0 elements. The file is also oddly small.

I grabbed a 1.14.4 copy of gst-plugins-base and compiled it with libvisual support and now the plugin seems to work OK.

A precompiled file is here:
https://github.com/Swap-File/portal-gun ... bvisual.so

It goes here:
/usr/lib/arm-linux-gnueabihf/gstreamer-1.0/libgstlibvisual.so

Anyone else run into problems with this?

Swap_File
Posts: 24
Joined: Sun Apr 06, 2014 5:31 pm

Re: Buster's libvisual plugin for gstreamer is broken?

Thu Jan 23, 2020 12:58 am

Correction: Just installing libvisual-0.4-plugins will enable the features, no recompiling needed. I guess it used to automatically be included in the packages that installed with gstreamer and now it isn't

Return to “Troubleshooting”