Paccmpura
Posts: 38
Joined: Sat May 02, 2015 9:37 am

Can't update/upgrade old raspi. :(

Sun Jan 12, 2020 9:51 am

Hello dear All!

Just tried to "sudo apt-get update/upgrade" my RaspI and got this fault:
> Failed to fetch ht##tp://mirrordirector.raspbian.org/raspbian/dists/wheezy/.....
> ...
> Some index files failed to download. ...
How to fix the index files download URL(s) if that's the reason of fault, or what to do if the reason differs from that one?
Board: Raspberry Pi 2 mod.B,
OS: Raspbian 7.8 (сore 3.18.7-v7+, #755, 12.02.2015, armv7l GNU/Linux

User avatar
PeterO
Posts: 5623
Joined: Sun Jul 22, 2012 4:14 pm

Re: Can't update/upgrade old raspi. :(

Sun Jan 12, 2020 10:10 am

Probably it's just too old !
PeterO
Discoverer of the PI2 XENON DEATH FLASH!
Interests: C,Python,PIC,Electronics,Ham Radio (G0DZB),1960s British Computers.
"The primary requirement (as we've always seen in your examples) is that the code is readable. " Dougie Lawson

Paccmpura
Posts: 38
Joined: Sat May 02, 2015 9:37 am

Re: Can't update/upgrade old raspi. :(

Sun Jan 12, 2020 10:32 am

PeterO wrote:
Sun Jan 12, 2020 10:10 am
Probably it's just too old !
PeterO
Sorry, but what do You mean exactly - too old hardware (Raspberry Pi 2 mod B), or just Wheezy's not supported anymore?
Board: Raspberry Pi 2 mod.B,
OS: Raspbian 7.8 (сore 3.18.7-v7+, #755, 12.02.2015, armv7l GNU/Linux

User avatar
DougieLawson
Posts: 37619
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Can't update/upgrade old raspi. :(

Sun Jan 12, 2020 10:43 am

Wheezy isn't updated now (it's too old).

The repo has been moved and archived.

The time to start with a fresh new install of Raspbian Buster is NOW!
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
buja
Posts: 542
Joined: Wed Dec 31, 2014 8:21 am
Location: Netherlands

Re: Can't update/upgrade old raspi. :(

Sun Jan 12, 2020 10:47 am

Nothing wrong with a 2B, but Raspbian Wheezy is too old and I guess the links are not active anymore.
Time for a fresh installation of Raspbian Buster.
Backup your important files to a USB stick or something and put a fresh install of Raspbian Buster on the SD card. It might be a good time for a fresh SD card as well.

Paccmpura
Posts: 38
Joined: Sat May 02, 2015 9:37 am

Re: Can't update/upgrade old raspi. :(

Sun Jan 12, 2020 11:15 am

DougieLawson wrote:
Sun Jan 12, 2020 10:43 am
Wheezy isn't updated now (it's too old).
The repo has been moved and archived.
The time to start with a fresh new install of Raspbian Buster is NOW!
buja wrote:
Sun Jan 12, 2020 10:47 am
...
Time for a fresh installation of Raspbian Buster.
...
Thanks for explanations!
Then the next question is - will the RasPi 2 mod B carry Raspbian Buster? O'Henry: "Bolivar, he's plenty tired, and he can't carry double.")
Board: Raspberry Pi 2 mod.B,
OS: Raspbian 7.8 (сore 3.18.7-v7+, #755, 12.02.2015, armv7l GNU/Linux

User avatar
buja
Posts: 542
Joined: Wed Dec 31, 2014 8:21 am
Location: Netherlands

Re: Can't update/upgrade old raspi. :(

Sun Jan 12, 2020 11:24 am

Yes, Raspbian Buster runs very well on a 2B, no problem at all.

Paccmpura
Posts: 38
Joined: Sat May 02, 2015 9:37 am

Re: Can't update/upgrade old raspi. :(

Sun Jan 12, 2020 11:32 am

Sounds very good! Thank you! :D
[... mooving to Buster!]
Board: Raspberry Pi 2 mod.B,
OS: Raspbian 7.8 (сore 3.18.7-v7+, #755, 12.02.2015, armv7l GNU/Linux

GlowInTheDark
Posts: 390
Joined: Sat Nov 09, 2019 12:14 pm

Re: Can't update/upgrade old raspi. :(

Sun Jan 12, 2020 11:34 am

I've noticed that Wheezy systems no longer can get new software (get errors as reported by OP).

But the note above that the Wheezy repo has been moved/archived gives me hope that it still does exist, in some form. Is that the case? If so, can it still be used?

And, no, the whole point of this question is that "updating" the system is not an option. If it were, there would be no problem.
GitD's list of things that are not ready for prime time:
1) IPv6
2) 64 bit OSes
3) USB 3
4) Bluetooth

fruitoftheloom
Posts: 22024
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Can't update/upgrade old raspi. :(

Sun Jan 12, 2020 11:36 am

Paccmpura wrote:
Sun Jan 12, 2020 9:51 am
Hello dear All!

Just tried to "sudo apt-get update/upgrade" my RaspI and got this fault:
> Failed to fetch ht##tp://mirrordirector.raspbian.org/raspbian/dists/wheezy/.....
> ...
> Some index files failed to download. ...
How to fix the index files download URL(s) if that's the reason of fault, or what to do if the reason differs from that one?

Yes Wheezy repositories being archived / moved has been discussed:

https://www.raspberrypi.org/forums/view ... p?t=242895
Retired disgracefully.....
......to an uncomplicated life !

Rather than negativity think outside the box !

Paccmpura
Posts: 38
Joined: Sat May 02, 2015 9:37 am

Re: Can't update/upgrade old raspi. :(

Sun Jan 12, 2020 1:03 pm

Thanks to All of you! :D
Finally, I've got updated Wheezy from 'legacy.raspbian.org/raspbian' (as good as it got), then saved command line history to recall all config file editions, app installations, git clonings etc., and now I'll backup SD-card (just in case) and move to the Raspbian Buster.
Board: Raspberry Pi 2 mod.B,
OS: Raspbian 7.8 (сore 3.18.7-v7+, #755, 12.02.2015, armv7l GNU/Linux

Return to “Troubleshooting”