Article23399
Posts: 1
Joined: Sat Dec 14, 2019 4:22 am

pi4 hdmi 4k 60hz not work

Sat Dec 14, 2019 4:46 am

Hi, I'm new here. I have a pi4 4GB and use xv273k monitor (4k support hdmi 2.0). I flash raspbian 2019-09-26 to sd card and change config.txt with hdmi_enable_4kp60=1. Here is my config.txt https://gist.github.com/Article23399/0c ... 5579619f1c.
After reboot, my screen will show 4 raspberry logo then black and no signal.

Code: Select all

[email protected]:~ $ tvservice -s
state 0xa [HDMI CUSTOM RGB full 16:9], 3840x2160 @ 60.00Hz, progressive
If I comment hdmi_enable_4kp60=1, it will be good with 640*480.
What's wrong?

yabusa
Posts: 4
Joined: Mon Dec 09, 2019 12:01 am

Re: pi4 hdmi 4k 60hz not work

Sat Dec 28, 2019 2:26 pm

Try this

Code: Select all

sudo apt update

Code: Select all

sudo apt full-upgrade
Then copy the text in your config.txt somewhere, and paste mine in and see if it works.

https://drive.google.com/open?id=14szGg ... 7-ATXValWg

It's really weird. I had two SD Cards, one provided in the desktop kit, and the other Sandisk 64gb U3 would crash when I enabled the 4k. I'm not sure what the error is, but I used the other SD card config.txt, and it worked :)

dominic03
Posts: 91
Joined: Fri Dec 21, 2018 1:50 am

Re: pi4 hdmi 4k 60hz not work

Sat Dec 28, 2019 5:24 pm

Your HDMI cable might be bad
Raspberry Pi 4B running Raspbian Buster v3.1 (via PINN)
Kingston 32 GB C10 (U1) microSD
Sceptre E225W 22" 75hz 1080p monitor
Flash drive for backups and swap
-or-
pi-top 3 running Raspbian with drivers and pi-topHUB 2.0 / 16GB SanDisk C10 microSD

Hugh
Posts: 12
Joined: Wed Nov 09, 2011 7:38 pm
Location: Toronto, Canada

Re: pi4 hdmi 4k 60hz not work

Sun Jan 05, 2020 11:02 pm

I've got a somewhat similar problem.

Be sure to use only the HDMI port closest to the USB C power socket (that's HDMI-0). Only one HDMI port can be used when you are trying for UltraHD at 60Hz. See https://www.raspberrypi.org/documentati ... -config.md

The default /boot/config.txt suppresses UltraHD @ 60 Hz. You need a line

Code: Select all

hdmi_enable_4kp60=1
In my painful experience, you currently need to comment out the config.txt line

Code: Select all

#dtoverlay=vc4-fkms-v3d
This last line will slow the desktop down:. I don't know why it is needed. See the thread https://www.raspberrypi.org/forums/view ... &t=255563

trejan
Posts: 1203
Joined: Tue Jul 02, 2019 2:28 pm

Re: pi4 hdmi 4k 60hz not work

Sun Jan 05, 2020 11:08 pm

Hugh wrote:
Sun Jan 05, 2020 11:02 pm
The default /boot/config.txt suppresses UltraHD @ 60 Hz. You need a line

Code: Select all

hdmi_enable_4kp60=1
It increases power consumption and heat when you enable 4Kp60 support which is why it is disabled by default.
Hugh wrote:
Sun Jan 05, 2020 11:02 pm
In my painful experience, you currently need to comment out the config.txt line

Code: Select all

#dtoverlay=vc4-fkms-v3d
As mentioned in that thread, you're disabling all 3D acceleration if you do that and not a good fix. If you have issues with 4Kp60 support then you should post your configuration and a base64 encoded version of the EDID so the Pi engineers can look into it. The decoded version using the tool doesn't show everything which is why you need to raw EDID itself.

Return to “Troubleshooting”