Francis_Le
Posts: 6
Joined: Wed Dec 04, 2019 12:00 am

Raspberry Pi 4 not working.

Wed Dec 04, 2019 11:23 am

I don't know what kind of problem my Pi 4, it just shows the red light always flash and the green one flash for 6 seconds then it flicks 4 times (without sd card), then I put SD card in with Rasbain. It shows me the green light is on for 2 sec only, then it flicks random time for a few seconds and the light is flashing with a lot multi flick and it going weaker. I try every HDMI port and it just shows "No Signal", I also tri the Raspberry Pi 4 Screen 3.5 inch and it just white.

crofter
Posts: 83
Joined: Thu Feb 22, 2018 11:28 pm

Re: Raspberry Pi 4 not working.

Wed Dec 04, 2019 2:26 pm

hi
please try information in downloads section about boot problem

Recovery
If your Raspberry Pi 4 will not boot, it is possible that the SPI EEPROM has become corrupted.

To check, remove the SD card, disconnect the device from power, then reconnect it. If the green LED does not flash, you will need to reprogram the EEPROM:

Download the bootloader
SHA-256: 444e0f68aa21d5b4e158259061de55738d36a1986e2ced14bb14d7af1a04881c
Extract it to an empty FAT-formatted SD card and insert it into your Raspberry Pi 4
Connect the power and wait for the green LED to flash quickly
Notes:

The updated bootloader improves compatibility with HATs by changing the behaviour of HALT to keep the 3V3 pin powered (view the full bootloader release notes)
The previous bootloader remains available for download


thanks

User avatar
rpdom
Posts: 17454
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Raspberry Pi 4 not working.

Wed Dec 04, 2019 2:37 pm

Francis_Le wrote:
Wed Dec 04, 2019 11:23 am
it just shows the red light always flash
If the red light is flashing it means the Pi is not getting enough power. The red light should be always on.
Unreadable squiggle

Francis_Le
Posts: 6
Joined: Wed Dec 04, 2019 12:00 am

Re: Raspberry Pi 4 not working.

Wed Dec 04, 2019 6:36 pm

The Green flash light working nomal without SD card. Flicker 4 times like any other Raspberry Pi.

renice123
Posts: 237
Joined: Tue Oct 15, 2019 3:56 pm

Re: Raspberry Pi 4 not working.

Wed Dec 04, 2019 7:03 pm

The red LED should always be on. This is a power indicator. If the green LED is constantly on, then this is a problem. Constantly on green LED - Raspberry is not working.
Try another hdmi cord. Sometimes they are of poor quality.
If the green LED flickers randomly, it means that the OS is loading and Raspberry is working fine. But there is no way out to the monitor. You can also try connecting via ssh to the problematic Raspberry to make sure that Raspberry is working properly.
But most often in such cases the monitor cord is “to blame”
Will you connect the cord to the first output? What's closer to the power jack? There is another interesting feature of Raspberries of the fourth version: first you need to turn on the monitor, and then turn on the Raspberries. Otherwise, Raspberry will not receive the EDID from the monitor.

Francis_Le
Posts: 6
Joined: Wed Dec 04, 2019 12:00 am

Re: Raspberry Pi 4 not working.

Wed Dec 04, 2019 8:40 pm

Ok, nice idea. I'll try other HDMI cable and text both TV. Last time i i text the fisrt time, the TV got signal that it asking me connect to HDMI so i press "OK", but nothing show and "No Signal" :(

Francis_Le
Posts: 6
Joined: Wed Dec 04, 2019 12:00 am

Re: Raspberry Pi 4 not working.

Wed Dec 04, 2019 8:46 pm

The Greed Led is flicks randomly strong and week for a moment then green Led has no longer flick, i wait a few sec then it flick 1 time again and stop, and a moment it flick 1 time again. It keep runing like that.

User avatar
rpdom
Posts: 17454
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Raspberry Pi 4 not working.

Thu Dec 05, 2019 5:55 am

Francis_Le wrote:
Wed Dec 04, 2019 8:46 pm
The Greed Led is flicks randomly strong and week for a moment then green Led has no longer flick, i wait a few sec then it flick 1 time again and stop, and a moment it flick 1 time again. It keep runing like that.
That sound normal. It is SD card activity. Lots of activity during boot, then little activity while waiting for a login.
Unreadable squiggle

Francis_Le
Posts: 6
Joined: Wed Dec 04, 2019 12:00 am

Re: Raspberry Pi 4 not working.

Thu Dec 05, 2019 8:53 pm

Thanks for help, Raspberry Pi 4 Is working normally but the HDMI out put just too week and Raspbain is have some error like When i add memory for GPU, it restarting, i know it know it ok. But when Reboot complete, both of USB 2.0 and 3.0 output is not working!.

User avatar
davidcoton
Posts: 5199
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK
Contact: Website

Re: Raspberry Pi 4 not working.

Thu Dec 05, 2019 10:08 pm

Francis_Le wrote:
Thu Dec 05, 2019 8:53 pm
Thanks for help, Raspberry Pi 4 Is working normally but the HDMI out put just too week and Raspbain is have some error like When i add memory for GPU, it restarting, i know it know it ok. But when Reboot complete, both of USB 2.0 and 3.0 output is not working!.
Don't add memory for GPU on a Pi4. Main video memory is allocated differently, so extra GPU memory is not helpful and, in excess, will cause problems.
Location: 345th cell on the right of the 210th row of L2 cache

renice123
Posts: 237
Joined: Tue Oct 15, 2019 3:56 pm

Re: Raspberry Pi 4 not working.

Fri Dec 06, 2019 7:22 am

As far as I remember, RPI engineers wrote on the forum that if you add more than 512 Mb to the config.txt GPU file (I may be wrong in the numbers), then Raspberry may not load correctly.
As I understood from the messages of the programmers of the developers, in the fourth version of Raspberry there is no need to "expand" the video memory in the configuration file, since working with video memory is now carried out somewhat differently than before.
However, other programs (Kodi) may need the GPU memory option, therefore it is recommended to set the minimum value. Here on the forum there was a thread dedicated to this issue, it can be found.
I am glad that your problem has been resolved!

Francis_Le
Posts: 6
Joined: Wed Dec 04, 2019 12:00 am

Re: Raspberry Pi 4 not working.

Fri Dec 06, 2019 2:50 pm

Yea, thank. It working normal with 524 GPU memory.

Return to “Troubleshooting”