LTolledo
Posts: 2833
Joined: Sat Mar 17, 2018 7:29 am
Location: Anime Heartland

VLC wont run properly (even after uninstall and re-install)

Sat Sep 28, 2019 11:05 pm

Good day everyone!

Faced with a problem with VLC and have not found any solution yet (even after some web search on the topic)

When did this start:
while trying to enable bluetooth audio in VLC (but failed anyway so aborted it)
the problem started after this.

Actions done:
uninstalling and reinstalling VLC

using

Code: Select all

sudo apt remove --purge vlc
then

Code: Select all

sudo apt remove --purge vlc*
sudo apt clean
sudo apt autoremove
also removed all contents of ~/.config/vlc

reboot, then install vlc

Code: Select all

sudo apt install vlc*

Symptoms: (observed after the re-install)
clicking on the VLC icon does not start the application
an hourglass-cursor does appear after clicking the icon, but after a few seconds it reverts back to cursor.

selecting a media file (video) and selecting VLC as player did start the app
however, closing the window to stop the app does close VLC but the audio still continues

selecting an another file to play stops the audio, but still VLC does not open.

this is the output of vlc -v,

Code: Select all

~ $ vlc -v
VLC media player 3.0.8 Vetinari (revision 3.0.8-0-gf350b6b5a7)
[01f3cb40] main libvlc warning: cannot load module `/usr/lib/arm-linux-gnueabihf/vlc/plugins/gui/libqt_plugin.so' (/usr/lib/arm-linux-gnueabihf/libQt5Widgets.so.5: undefined symbol: arBaseC1Ei, version Qt_5_PRIVATE_API)
[01fbffe8] vlcpulse audio output error: PulseAudio server connection failure: Connection refused
[01f3cb40] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[01fbb4e0] skins2 interface error: cannot instantiate dialogs provider
[01f9ce00] main playlist: playlist is empty
[01fbb4e0] [cli] lua interface: Listening on host "*console".
VLC media player 3.0.8 Vetinari
Command Line Interface initialized. Type `help' for help.
> [acb06860] mmal_codec decoder: VCSM init succeeded: CMA
[ass] Shaper: FriBidi 0.19.7 (SIMPLE) HarfBuzz-ng 2.3.1 (COMPLEX)
[ass] Using font provider fontconfig
[acb12c70] faad decoder warning: decoded zero sample
[01fbffe8] alsa audio output warning: device cannot be paused
[a9502eb8] main video output warning: picture is too late to be displayed (missing 26 ms)
[ass] fontselect: (Open Sans Semibold, 700, 0) -> OpenSans-Semibold, 0, OpenSans-Semibold
[a952e710] xcb_window window error: X server failure
System spec: (RPi desktop am using to post to this forum)
Raspberry Pi 4 Model B 4GB
Raspbian Buster Full Desktop in 32GB A1 microSD, raspbian updated and upgraded as 2019-09-28
12V powered X400 v3 DAC-Amp supplying 5.1v to RPi4B.

is there another way to cleanly remove VLC and do a clean re-install (short of re-flashing the whole microSD)

thanks!
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

lerner
Posts: 509
Joined: Sun Mar 29, 2015 12:12 am

Re: VLC wont run properly (even after uninstall and re-install)

Sun Sep 29, 2019 12:59 am

I am sorry to say I don't have a magic answer. I too am having problems with VLC.

But for what it is worth, I would get rid of the bluetooth part.

From the terminal also try this:

Code: Select all

amixer cset numid=3 2
Then try something like:

Code: Select all

sudo aplay /usr/share/sounds/alsa/Front_Center.wav
And see if that plays a sound.

You need to establish if the sound is being played first.

If the bluetooth is messing with how the audio is played, then re-installing VLC isn't going to help/fix the problem.

LTolledo
Posts: 2833
Joined: Sat Mar 17, 2018 7:29 am
Location: Anime Heartland

Re: VLC wont run properly (even after uninstall and re-install)

Sun Sep 29, 2019 1:07 am

Thank you for your interest in finding solution to my VLC problem :)

My audio is default to DAC-amp and I've already established it is functional under Chrome and Kodi 18.4
also audio to HDMI and analog are OK (now watching Youtube video in chrome, HDMI audio out selected)

so the cause may be specific to VLC only.... :(
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

LTolledo
Posts: 2833
Joined: Sat Mar 17, 2018 7:29 am
Location: Anime Heartland

Re: VLC wont run properly (even after uninstall and re-install)

Fri Oct 04, 2019 10:35 am

bump

...just checking if somebody out there know a better way to cleanly remove VLC from raspbian buster, all its dependencies, and the list of files and folders I need to "search and destroy" (ones not actively removed by via apt remove)

a procedure would be appreciated...
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

lerner
Posts: 509
Joined: Sun Mar 29, 2015 12:12 am

Re: VLC wont run properly (even after uninstall and re-install)

Sun Oct 13, 2019 1:47 am

I know this is an OLD thread.

I recently had a similar problem.

My solution was (from the cli)

Code: Select all

vlc --reset-config
And it worked.

I am not going to say that will be the answer for you, but after a lot of messing around, it was for me.

RossDv8
Posts: 244
Joined: Thu Jan 21, 2016 12:35 pm

Re: VLC wont run properly (even after uninstall and re-install)

Sun Oct 13, 2019 2:55 am

I have a similar problem that recurs occasionally/regularly. VLC sometimes attempts to run, but fails, then any time I try to restart it from the menu, it flat out refuses to do anything except show the hour glass.
Eventually I noticed that there was an icon in the Panel which meant it 'should' have been running. Right clicking the icon and choosing 'Quit' should have closed it, but didn;t.

I opened Task Manager, and sure enough there was VLC. I did a Right Click > Kill and it went. And VLC worked on next start up. I didn;t know about the vlc --reset-config option (thanks lerner)

So using Task Manager might also work. The icon in the panel was the giveaway.
Remember, nobody is listening to you
until you fart ...

ilovetoprogramstuff
Posts: 2
Joined: Tue Jan 21, 2020 5:31 pm

Re: VLC wont run properly (even after uninstall and re-install)

Sat Feb 22, 2020 5:38 am

Hey, I know how to fix your problem.
COMPLETELY removing a program, and all it's dependencies is called "perging".
In the terminal, type

Code: Select all

sudo dpkg --purge vlc
wich will remove all of vlc garunteed

LTolledo
Posts: 2833
Joined: Sat Mar 17, 2018 7:29 am
Location: Anime Heartland

Re: VLC wont run properly (even after uninstall and re-install)

Sat Feb 22, 2020 10:30 am

Nah.... a fresh install is much better....and faster.... and cleaner.....
....
or
.....
a restore from the last known working system backup image.....this is much faster than above...

and nowadays I rarely use VLC....as in very very rare.....
and bluetooth has been banned, exiled, "programma indesiderato" on my RPi systems.
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

Return to “Troubleshooting”