studentaccount4
Posts: 1
Joined: Wed Sep 25, 2019 3:33 pm

getting eclipse start error on RS Pi 4

Wed Sep 25, 2019 3:52 pm

I'm facing a small problem here.
so recently I got my raspberry pi 4 and as you know it comes with pre-installed eclipse and java OpenJDK 11.
but when I start the eclipse app, I get this Error:

Code: Select all

An error has occurred.  See the log file
/home/pi/.eclipse/org.eclipse.platform_3.8_155965261/configuration/1569428228669.log

The log file

Code: Select all

    !SESSION Wed Sep 25 17:10:13 CEST 2019 -----------------------------------------
    !ENTRY org.eclipse.equinox.launcher 4 0 2019-09-25 17:10:13.859
    !MESSAGE Exception launching the Eclipse Platform:
    !STACK
    java.lang.ClassNotFoundException: 
    org.eclipse.core.runtime.adaptor.EclipseStarter
	at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:471)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:588)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
       
to the command

Code: Select all

java --version
I get this output:

Code: Select all

    openjdk 11.0.3 2019-04-16
    OpenJDK Runtime Environment (build 11.0.3+7-post-Raspbian-5)
    OpenJDK Server VM (build 11.0.3+7-post-Raspbian-5, mixed mode)
to the command

Code: Select all

javac --version
I get this output:

Code: Select all

 javac 11.0.3 
and to the

Code: Select all

lsb_release -a
i get this output:

Code: Select all

    Distributor ID:	Raspbian
    Description:	Raspbian GNU/Linux 10 (buster)
    Release:	10
    Codename:	buster
 

please notice that this is happening on since the first run I didn't get the chance to make a workspace.

I have a little doubt that it is because of the java 11 and the old eclipse version that comes with the raspbian.
do i have to downgrade to java < than 8?

User avatar
neilgl
Posts: 2544
Joined: Sun Jan 26, 2014 8:36 pm
Location: Near Aston Martin factory

Re: getting eclipse start error on RS Pi 4

Wed Sep 25, 2019 7:25 pm

I might be missing something but my Pi4 (i.e. Raspbian Buster) did not come with eclipse pre-installed?

kinlee88
Posts: 1
Joined: Fri Sep 27, 2019 11:27 pm

Re: getting eclipse start error on RS Pi 4

Fri Sep 27, 2019 11:33 pm

I'm getting the same error upon launching eclipse on my raspberry pi4 running with Raspbian. I installed eclipse via apt.
sudo apt update
sudo apt install eclipse


!SESSION Sat Sep 28 09:23:05 AEST 2019 -----------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2019-09-28 09:23:05.760
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:471)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:588)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)


Tried to install with an installer but failed to find an eclispe installer for ARM.

Appreciated if anyone here could give some advice. Thanks.

SykomantiS
Posts: 1
Joined: Thu Oct 17, 2019 10:03 am

Re: getting eclipse start error on RS Pi 4

Thu Oct 17, 2019 10:08 am

neilgl wrote:
Wed Sep 25, 2019 7:25 pm
I might be missing something but my Pi4 (i.e. Raspbian Buster) did not come with eclipse pre-installed?
My Pi4 didn't come with Eclipse by default, I also installed mine via apt (Eclipse 3.8 I believe), and I'm getting the exact same issue as the other posters.

zipzapx2002
Posts: 11
Joined: Fri Dec 27, 2019 9:00 pm

Re: getting eclipse start error on RS Pi 4

Mon Jan 13, 2020 7:34 pm

same issue. im on a RS pi 3 b+ though. would really like a fix, or if anyone knows a java IDE with Intellisense.

Carnivorus
Posts: 2
Joined: Tue Jun 16, 2020 9:09 am

Re: getting eclipse start error on RS Pi 4

Tue Jun 16, 2020 9:43 am

I also had a problem with running eclipse on Buster. Upgraded from Jessie to Buster and also reinstalled. After quite some searches on the internet and fora, I stumbled upon this link and it provide me with the solution.

https://www.mail-archive.com/search?l=d ... newest&f=1
At the bottom a solution was posted, essentially a symbolic link was missing. (You might need to sudo the ln command)

Code: Select all

cd /usr/lib/eclipse/plugins
ln -s ../../../share/java/org.eclipse.osgi-3.9.1.jar org.eclipse.osgi_3.8.1.dist.jar
In addition it is required to specify the correct Java VM to use. The eclipse version only works with Java 8. There are plenty of links that can instruct how to install Java 8 . You can have multiple Java versions on your system so no need to replace or downgrade.
Specify the Java VM in eclipse.ini to point to a Java 1.8 version, in my case the one from Oracle but OpenJDK might also work.

Code: Select all

sudo  nano /usr/lib/eclipse/eclipse.ini
Insert the -vm option before the -vmargs

Code: Select all

openFile
-vm
/usr/lib/jvm/jdk-8-oracle-arm32-vfp-hflt/bin/java
-vmargs
This is what worked for me.

ilg
Posts: 14
Joined: Sat Aug 08, 2020 3:54 pm
Location: Bucharest, Romania

Re: getting eclipse start error on RS Pi 4

Tue Sep 08, 2020 1:23 pm


alik55
Posts: 2
Joined: Mon Feb 16, 2015 2:28 am

Re: getting eclipse start error on RS Pi 4

Sat Sep 12, 2020 9:27 pm

For me this worked instead of ./../../share/java/org.eclipse.osgi-3.9.1.jar as above:

Code: Select all

ln -s ../../../share/java/org.eclipse.osgi.nb-3.9.1.jar org.eclipse.osgi_3.8.1.dist.jar

zephyrprime
Posts: 3
Joined: Sun Sep 27, 2020 11:02 pm

Re: getting eclipse start error on RS Pi 4

Sun Sep 27, 2020 11:03 pm

alik55 wrote:
Sat Sep 12, 2020 9:27 pm
For me this worked instead of ./../../share/java/org.eclipse.osgi-3.9.1.jar as above:

Code: Select all

ln -s ../../../share/java/org.eclipse.osgi.nb-3.9.1.jar org.eclipse.osgi_3.8.1.dist.jar
Ditto. I had the same issue.

Return to “Troubleshooting”