JDH90
Posts: 1
Joined: Fri Aug 23, 2019 1:51 pm

Tried installing Brave and now can't install anything

Fri Aug 23, 2019 2:20 pm

Hi all. I'm very new to Pi and Linux, and not fully understanding how it all works.

I bought the Pi 4 which came with NOOBS pre-installed on an SD card. Whenever i try installing something through the terminal, it never works. I follow all the guides on the websites to no avail. For example, I was trying to install Nord/OpenVPN using the guide seen here: https://nordvpn.com/tutorials/raspberry-pi/openvpn/

If i run sudo apt-get update I get:
[email protected]:~ $ sudo apt-get update
E: Malformed entry 1 in list file /etc/apt/sources.list.d/brave-browser-release-.list (Component)
E: The list of sources could not be read.

Then running sudo apt-get install openvpn I get:
[email protected]:~ $ sudo apt-get install openvpn
E: Malformed entry 1 in list file /etc/apt/sources.list.d/brave-browser-release-.list (Component)
E: The list of sources could not be read.
E: Malformed entry 1 in list file /etc/apt/sources.list.d/brave-browser-release-.list (Component)
E: The list of sources could not be read.

When I first got the Pi, I tried installing Brave to use as a browser, but couldn't get it to install. Now I see it's just causing me headaches, but I don't know how to remove it.

Having a look round, I opened Add/Remove Software which I assume should have programs in there ready to be installed, but mine doesn't. It has nothing in any of the categories to choose from. I clicked Options and Check for Updates, and another malformed entry for Brave pops up.

If anyone could help me resolve this issue, I would be hugely thankful. Cheers!

fruitoftheloom
Posts: 20440
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Tried installing Brave and now can't install anything

Fri Aug 23, 2019 6:47 pm

JDH90 wrote:
Fri Aug 23, 2019 2:20 pm
Hi all. I'm very new to Pi and Linux, and not fully understanding how it all works.

I bought the Pi 4 which came with NOOBS pre-installed on an SD card. Whenever i try installing something through the terminal, it never works. I follow all the guides on the websites to no avail. For example, I was trying to install Nord/OpenVPN using the guide seen here: https://nordvpn.com/tutorials/raspberry-pi/openvpn/

If i run sudo apt-get update I get:
[email protected]:~ $ sudo apt-get update
E: Malformed entry 1 in list file /etc/apt/sources.list.d/brave-browser-release-.list (Component)
E: The list of sources could not be read.

Then running sudo apt-get install openvpn I get:
[email protected]:~ $ sudo apt-get install openvpn
E: Malformed entry 1 in list file /etc/apt/sources.list.d/brave-browser-release-.list (Component)
E: The list of sources could not be read.
E: Malformed entry 1 in list file /etc/apt/sources.list.d/brave-browser-release-.list (Component)
E: The list of sources could not be read.

When I first got the Pi, I tried installing Brave to use as a browser, but couldn't get it to install. Now I see it's just causing me headaches, but I don't know how to remove it.

Having a look round, I opened Add/Remove Software which I assume should have programs in there ready to be installed, but mine doesn't. It has nothing in any of the categories to choose from. I clicked Options and Check for Updates, and another malformed entry for Brave pops up.

If anyone could help me resolve this issue, I would be hugely thankful. Cheers!

AFAIAA Brave Web Browser is for machines with x86 CPU Architecture...

...the Raspberry Pi has ARM CPU Architecture !

You need to undo the changes you made..



If you installed Raspbian Buster with Desktop via the NoobS installer / chooser then you will have the chromium-browser already installed.


.
adieu

Asus CS10 Chromebit / HP Envy 4500 Wireless Printer / Raspberry Pi Model 2B v1.1 / RealVNC Software...

LTolledo
Posts: 1763
Joined: Sat Mar 17, 2018 7:29 am
Location: Anime Heartland

Re: Tried installing Brave and now can't install anything

Fri Aug 23, 2019 10:28 pm

if you cant install anything now because of what you did....
start again from a fresh install of Raspbian

and dont ever install Brave again.... simple as that.
if you still insist, your problem will persist as well.... and you're on your own....
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

Return to “Troubleshooting”