namasteybhaisab
Posts: 7
Joined: Mon Jul 29, 2019 11:47 am

No HDMI output on RPi 4 (but it boots)

Thu Aug 08, 2019 5:05 pm

Hi,

I have Raspberry Pi4 4Gb. I have etched latest raspbian buster. Powering on using this image doesn't show any output on my TV/Monitor.
I tried troubleshooting by removing all devices including memory card. The ACT light blinked repeatedly in pattern of fours. Apart from that when I power on the Pi with micro sd card plugged in, the ACT light blinks randomly.

Using the same card with RPi 3B boots fine and I get the display.

Can someone please help out in debugging this?

UPDATE:
I can successfully ssh. So we can rule out any boot issues.
Last edited by namasteybhaisab on Thu Aug 08, 2019 7:39 pm, edited 1 time in total.

Peder
Posts: 2
Joined: Wed Sep 23, 2015 12:32 pm

Re: No HDMI output on RPi 4

Thu Aug 08, 2019 6:08 pm

Have same problem when I startup with my Raspberry Pi 4.
My problem was that the raspberry Pi was startup with a high screen resolution, and my TV was to old to show this, so I only have black screen on this TV.
Then I try to connect to a new type of TV, and now it show a beautiful picture.

So check if your TV can show a high resolution on HDMI input.

scotty101
Posts: 4221
Joined: Fri Jun 08, 2012 6:03 pm

Re: No HDMI output on RPi 4

Thu Aug 08, 2019 6:27 pm

Seems to be a common and yet not fixed problem.

There is a work around that has had some success. See https://www.raspberrypi.org/forums/view ... 6#p1488488
Electronic and Computer Engineer
Pi Interests: Home Automation, IOT, Python and Tkinter

User avatar
HawaiianPi
Posts: 6272
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: No HDMI output on RPi 4

Thu Aug 08, 2019 6:43 pm

Make sure you are using the HDMI-0 port on the Pi4 (closest to USB-C power jack), also check that you have the correct input selected on your TV/monitor, and the TV/monitor is turned on before you boot the Pi.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

namasteybhaisab
Posts: 7
Joined: Mon Jul 29, 2019 11:47 am

Re: No HDMI output on RPi 4

Thu Aug 08, 2019 7:14 pm

Peder wrote:
Thu Aug 08, 2019 6:08 pm
Have same problem when I startup with my Raspberry Pi 4.
My problem was that the raspberry Pi was startup with a high screen resolution, and my TV was to old to show this, so I only have black screen on this TV.
Then I try to connect to a new type of TV, and now it show a beautiful picture.

So check if your TV can show a high resolution on HDMI input.
I had my pi working. I was trying to set up raspiraw to capture raw images using C++. It used to work fine before. I think I updated raspbian and having this issue since then.
I am sure my TV supports this.

Also, I have tried using HDMI0 but with no results.
Last edited by namasteybhaisab on Thu Aug 08, 2019 7:20 pm, edited 1 time in total.

namasteybhaisab
Posts: 7
Joined: Mon Jul 29, 2019 11:47 am

Re: No HDMI output on RPi 4

Thu Aug 08, 2019 7:18 pm

scotty101 wrote:
Thu Aug 08, 2019 6:27 pm
Seems to be a common and yet not fixed problem.

There is a work around that has had some success. See https://www.raspberrypi.org/forums/view ... 6#p1488488
Didn't help :/

aBUGSworstnightmare
Posts: 2674
Joined: Tue Jun 30, 2015 1:35 pm

Re: No HDMI output on RPi 4

Fri Aug 09, 2019 4:38 am

What is your displays resolution and/or resolution you want to run your Pi with?
Post your config.txt.

lemonahmas
Posts: 17
Joined: Thu Dec 13, 2018 11:56 pm

Re: No HDMI output on RPi 4

Fri Aug 09, 2019 9:24 am

Think I met the same issue, my RPi4 can't achieve edid info from my portable monitor, ssh ON so I gave up.
Any suggestion is welcomed.

aBUGSworstnightmare
Posts: 2674
Joined: Tue Jun 30, 2015 1:35 pm

Re: No HDMI output on RPi 4

Fri Aug 09, 2019 9:58 am

lemonahmas wrote:
Fri Aug 09, 2019 9:24 am
Think I met the same issue, my RPi4 can't achieve edid info from my portable monitor, ssh ON so I gave up.
Any suggestion is welcomed.
As long as you don't provide details on your setup nobody will be able to help

lemonahmas
Posts: 17
Joined: Thu Dec 13, 2018 11:56 pm

Re: No HDMI output on RPi 4

Sun Aug 11, 2019 7:15 pm

aBUGSworstnightmare wrote:
Fri Aug 09, 2019 9:58 am
lemonahmas wrote:
Fri Aug 09, 2019 9:24 am
Think I met the same issue, my RPi4 can't achieve edid info from my portable monitor, ssh ON so I gave up.
Any suggestion is welcomed.
As long as you don't provide details on your setup nobody will be able to help
edid: https://www.raspberrypi.org/forums/view ... 8&t=246738

config.txt: tried every config.txt this forum provided, waste of time.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 28371
Joined: Sat Jul 30, 2011 7:41 pm

Re: No HDMI output on RPi 4

Sun Aug 11, 2019 9:13 pm

lemonahmas wrote:
Sun Aug 11, 2019 7:15 pm
aBUGSworstnightmare wrote:
Fri Aug 09, 2019 9:58 am
lemonahmas wrote:
Fri Aug 09, 2019 9:24 am
Think I met the same issue, my RPi4 can't achieve edid info from my portable monitor, ssh ON so I gave up.
Any suggestion is welcomed.
As long as you don't provide details on your setup nobody will be able to help
edid: https://www.raspberrypi.org/forums/view ... 8&t=246738

config.txt: tried every config.txt this forum provided, waste of time.
In order to test in house, we would need the actual binary EDID, not the parsed version. You can attached or convert to base64 and cut and paste here.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed.
I've been saying "Mucho" to my Spanish friend a lot more lately. It means a lot to him.

kmax70
Posts: 3
Joined: Sat Aug 10, 2019 10:37 am

Re: No HDMI output on RPi 4

Mon Aug 12, 2019 1:40 am

Hi,
I have a new Rpi4 and have connected 2 x 7" HDMI displays.

When I first booted up with both screens, it wouldn’t detect them after boot until I unplugged the HDMI cables and replugged them back in and then the GUI would display.

I then followed the instructions that came with the displays to install the 1024x600 driver and then it booted up ok, but only one display would be detected by the GUI.

I did notice however, that i have one python script that i can run that will run the Omxplayer and output video on a selected HDMI and this seems to work for both displays.

So my issue seems to be with the Raspian Buster GUI not detecting multiple displays after installing the display driver.

Any help would be appreciated.

Below is the config.txt file after the drivers were installed:

For more options and information see
http://www.raspberrypi.org/documentatio ... fig-txt.md
Some settings may impact device functionality. See link above for details
uncomment if you get no picture on HDMI for a default “safe” mode
#hdmi_safe=1

uncomment this if your display has a black border of unused pixels visible
and your display can output without overscan
#disable_overscan=1

uncomment the following to adjust overscan. Use positive numbers if console
goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

uncomment to force a console size. By default it will be display’s size minus
overscan.
#framebuffer_width=1280
#framebuffer_height=720

uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

uncomment to force a HDMI mode rather than DVI. This can make audio work in
DMT (computer monitor) modes
#hdmi_drive=2

uncomment to increase signal to HDMI, if you have interference, blanking, or
no display
#config_hdmi_boost=4

uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on
#dtparam=i2s=on
dtparam=spi=on
enable_uart=1

Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

Additional overlays and parameters are documented /boot/overlays/README
Enable audio (loads snd_bcm2835)
dtparam=audio=on
hdmi_group=2
hdmi_mode=1
hdmi_mode=87
hdmi_cvt 1024 600 60 6 0 0 0
dtoverlay=ads7846,cs=1,penirq=25,penirq_pull=2,speed=50000,keep_vref_on=0,swapxy=0,pmax=255,xohms=150,xmin=200,xmax=3900,ymin=200,ymax=3900
hdmi_drive=2
hdmi_force_hotplug=1
#max_usb_current=1

Thanks
Keith

User avatar
nmstewart
Posts: 18
Joined: Sun Jul 23, 2017 2:36 pm
Location: River Vale NJ US

Re: No HDMI output on RPi 4

Mon Aug 12, 2019 1:56 am

try uncommenting this line

original
# uncomment if you get no picture on HDMI for a default "safe" mode
# hdmi_safe=1

Modified
# uncomment if you get no picture on HDMI for a default "safe" mode
hdmi_safe=1

it worked for my TV/Monitor

After this I could go into preferences displays and play around.

kmax70
Posts: 3
Joined: Sat Aug 10, 2019 10:37 am

Re: No HDMI output on RPi 4

Mon Aug 12, 2019 9:47 pm

No luck with the hdmi_safe=1.

lemonahmas
Posts: 17
Joined: Thu Dec 13, 2018 11:56 pm

Re: No HDMI output on RPi 4

Wed Aug 14, 2019 1:56 pm

jamesh wrote:
Sun Aug 11, 2019 9:13 pm
lemonahmas wrote:
Sun Aug 11, 2019 7:15 pm
aBUGSworstnightmare wrote:
Fri Aug 09, 2019 9:58 am

As long as you don't provide details on your setup nobody will be able to help
edid: https://www.raspberrypi.org/forums/view ... 8&t=246738

config.txt: tried every config.txt this forum provided, waste of time.
In order to test in house, we would need the actual binary EDID, not the parsed version. You can attached or convert to base64 and cut and paste here.
Hi. Glad that someone official finally noticed. The edid file has been forward as the attachment. I am afraid that the problem is the Pi4 simply cannot get edid info from the monitor as my Pi3B+ did. This edid file was collected on Pi3B+
Hopefully, this is helpful for solving this issue.
Attachments
1.rar
the original edid file
(266 Bytes) Downloaded 396 times

marciano
Posts: 29
Joined: Mon Oct 23, 2017 10:54 pm

Re: No HDMI output on RPi 4 (but it boots)

Sun Jul 26, 2020 7:42 pm

I had the same problem.
I bought a Canakit kit and the HDMI cable is faulty. I changed it by a Gopro 3 cable I have and the display is good now.
....
Well, after 15 minutes or so I got No Signal.
After reboot signal comes again

Wizard451345
Posts: 9
Joined: Fri Jul 31, 2020 3:11 am

Re: No HDMI output on RPi 4 (but it boots)

Wed Aug 05, 2020 2:23 am

Having the same problem here. Rasp 4b 4gb purchased from canakit, arrived Today. Why dis not work. :((((((((

adlibirel
Posts: 1
Joined: Wed Aug 05, 2020 5:36 pm

Re: No HDMI output on RPi 4 (but it boots)

Wed Aug 05, 2020 5:48 pm

I have been working with Raspberry Pis for a few years now and was well acquainted with the 2 and 3 models prior to picking up my RPi4. I was particularly excited to set up a retro gaming console with this one as the hardware supports better play for N64 and Dreamcast. I never had any issues with my 3B+ regarding HDMI output but it has been a struggle with the 4 for some reason.

I tried every solution on every thread imaginable and grew incredibly frustrated with the process! Every config.txt alteration, new HDMI cables, different micro sd cards, hard reboots using the image from the Pi site, different micro-HDMI adapters, nothing was working. I was on the verge on giving up, but I put in one last ditch effort before I was going to give up and just go back to my 3B+.

When I used a 32gb micro SD to do a hard reboot (or whatever it's called) utilizing the image from the Pi site, I noticed that it had no problem with the HDMI connection. The green screen stayed on while the green light began rapidly flashing. I let it sit for a couple of minutes to see if it would eventually go out; it did not. This made me think that the size of the micro SD card I was using might be the issue (256 GB). I realized that with cards larger then 32gb, they have either a FAT or exFAT format automatically; however, this is incompatible with the Pi's boot up process. You have to make sure, with larger SD cards, that you format them FAT32. I, sadly, erased my card, reformatted it FAT32, reinstalled the operating system (the RetroPie image), and now I have no issues with HDMI connectivity!

I hope this helps someone. I was working on this tirelessly and tried every solution before I did this. Now there are no issues with my connectivity.

rakizi
Posts: 12
Joined: Wed Oct 21, 2020 2:44 am

Re: No HDMI output on RPi 4 (but it boots)

Fri Oct 23, 2020 9:21 pm

I received 2 raspberry pi from canakit last week(ordered 2nd to make sure something wasn't wrong with first)

Neither can output anything at all to my Samsumg UN4N5200 tv(full hd, newer model) My laptop can display perfectly fine at full hd.

I have tried multiple cables(the 2 from canakit, plus a 3rd from Ugreen)

Laptop plugged in has picture, unplug laptop and plug in pi and have nothing, plug laptop back in and have signal. And that was after booting the pi up attached to a acer monitor successfully. Attaching pi to the tv and then back to the monitor to make sure it still had a signal. Have booted up with HDMI's connected to tv and never got a signal on the TV.

tvservice gets the correct info from the tv

calbacohen
Posts: 1
Joined: Sat Nov 14, 2020 3:12 pm

Re: No HDMI output on RPi 4 (but it boots)

Sat Nov 14, 2020 3:15 pm

I have this as well, but this seems isolated to Rasperian rather than the Pi. Ubuntu displays without any issues.

awe215
Posts: 1
Joined: Wed Dec 02, 2020 3:47 pm

Re: No HDMI output on RPi 4 (but it boots)

Wed Dec 02, 2020 3:49 pm

I had this problem, when I changed power supplies, it fixed the problem!

Try a different usb-c power supply (as a possible solution!)

Fallon
Posts: 5
Joined: Sun Mar 29, 2015 7:10 pm
Location: Parker, CO
Contact: Website

Re: No HDMI output on RPi 4 (but it boots)

Mon Jan 18, 2021 1:16 am

I've been running into a similar issue. I have some of my pi's connected via a KVM at times. If it boots with no monitor attached or the KVM on a different port I can't ever get any video out of it. If I boot with the monitor connected or on the right KVM port it will work fine even if I later switch away. I assume it's something with it checking for supported display resolution or something from the monitor on boot.

It annoys me, but not enough to sort out properly. I've just been making sure I switch to the pi port on the KVM when booting and/or rebooting the pi.

User avatar
butchkemper
Posts: 72
Joined: Sat Jul 22, 2017 8:03 pm
Location: Sachse, Texas USA

Re: No HDMI output on RPi 4 (but it boots)

Mon Jan 18, 2021 3:24 am

I purchased some micro HDMI to HDMI adapters for my Pi4B. With the Pi4B installed in a case, the monitor did not display anything because the micro HDMI plugs were not long enough to make proper contact with the connector on the PI4B board. The solution was to make the micro HDMI plugs on the adapter longer by using a sharp knife to trim some plastic molding from the micro HDMI plug. Did not take much trimming to make the plug long enough.

Butch

rougefun
Posts: 1
Joined: Tue Mar 02, 2021 11:58 pm

Re: No HDMI output on RPi 4 (but it boots)

Wed Mar 03, 2021 12:02 am

@butchkemper

Thank you thank you thank you so much for this suggestion. I had the same issue but didn't connect the dots because i had connected the 7" display at the time. I decided i needed higher resolution but nothing was working and i couldn't even see the HDMI connected which i thought was odd. Didn't click until i read your comment and now my HDMI is working without the case, will be trimming my cables as well to make sure they fit completely!

Return to “Troubleshooting”