dominic03
Posts: 91
Joined: Fri Dec 21, 2018 1:50 am

Camera not mounting to Raspbian / Pcmanfm

Sun Aug 04, 2019 12:27 am

I have a camera I'm trying to access via USB. When I plug it in, nothing happens. I've been able to access it before - when I plugged it in, it would say "Removable medium inserted, type: camera" and I could access it. I can still access the camera via my Windows computer. How can I get it to mount?

Also, flash drivers I connect to the computer (using the same USB port) work fine.

dmesg says the following when connecting:

Code: Select all

[  217.929034] usb 1-1.1.3: new high-speed USB device number 7 using dwc_otg
[  218.062292] usb 1-1.1.3: New USB device found, idVendor=04b0, idProduct=0356, bcdDevice= 1.00
[  218.062309] usb 1-1.1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  218.062321] usb 1-1.1.3: Product: NIKON DSC COOLPIX S32-PTP
[  218.062330] usb 1-1.1.3: Manufacturer: NIKON
[  218.062340] usb 1-1.1.3: SerialNumber: 0000000000000000VNA581UA31010473
lsusb shows the following:

Code: Select all

Bus 001 Device 005: ID 258a:000c  
Bus 001 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 007: ID 04b0:0356 Nikon Corp. 
Bus 001 Device 006: ID 0424:7800 Standard Microsystems Corp. 
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Last edited by dominic03 on Sun Aug 04, 2019 6:45 pm, edited 2 times in total.
Raspberry Pi 4B running Raspbian Buster v3.1 (via PINN)
Kingston 32 GB C10 (U1) microSD
Sceptre E225W 22" 75hz 1080p monitor
Flash drive for backups and swap
-or-
pi-top 3 running Raspbian with drivers and pi-topHUB 2.0 / 16GB SanDisk C10 microSD

DirkS
Posts: 10200
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Camera not mounting to Raspbian / Pcmanfm

Sun Aug 04, 2019 6:18 am

Open a terminal window and use

Code: Select all

lsusb
to list all USB devices. Does your camera show up?
And does the red power led stay on at all times (assuming you're not using any of the Pi Zero models)?

dominic03
Posts: 91
Joined: Fri Dec 21, 2018 1:50 am

Re: Camera not mounting to Raspbian / Pcmanfm

Sun Aug 04, 2019 6:44 pm

DirkS wrote:
Sun Aug 04, 2019 6:18 am
Open a terminal window and use

Code: Select all

lsusb
to list all USB devices. Does your camera show up?
And does the red power led stay on at all times (assuming you're not using any of the Pi Zero models)?
lsusb says this:

Code: Select all

Bus 001 Device 005: ID 258a:000c  
Bus 001 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 007: ID 04b0:0356 Nikon Corp. 
Bus 001 Device 006: ID 0424:7800 Standard Microsystems Corp. 
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
The red PWR light stays on consistently.
Raspberry Pi 4B running Raspbian Buster v3.1 (via PINN)
Kingston 32 GB C10 (U1) microSD
Sceptre E225W 22" 75hz 1080p monitor
Flash drive for backups and swap
-or-
pi-top 3 running Raspbian with drivers and pi-topHUB 2.0 / 16GB SanDisk C10 microSD

Return to “Troubleshooting”