Page 1 of 1

Rasberry Pi Zero W No HDMI Output

Posted: Sat Aug 03, 2019 12:59 pm
by BRETT_No5
Hello everyone,

Here is the story.

I bought a Rasperry Pi Zero W. Set it up and everything was great. I could connect it via a Mini-HDMI to HDMI to my TV with no issues. Running of 2.4A USB power.

However, my project is a bartop arcade. With that I have an old VGA Monitor. I bought a Mini-HDMI to VGA adapter and initial tests after some adjustments to the config.txt were it was working. I got a picture and I could use.

Further along in the project I have now got the buttons, joystick etc.

Whilst the arcade isn't finished I thought I would connect it all in a dry run and enjoy. 3 hours later I am angry as no display at all.

Tried in my VGA and switched back to HDMI and nothing working. I am getting a green flashing light on the Pi and I was able to access it over the wifi network so it was powered on but no display. Here is what I have tried:

1) Un-commenting every conceivable combiniation of the following from the config.txt:
hdmi_force_unplug=1
config_hdmi_boost=4 (tried increasing this number also)
hdmi_safe=1
hdmi_drive=2
After each variation I tried connecting to HDMI and VGA to no avail

2) Tried re-flashing the SD card - Still nothing and now I can't access it over network anymore as can't access via wifi

3)Tried different HDMI cables and different monitors/tvs

4) Tried different power supplies.

Nothing is working. Is 2.4A enough or do I go higher as I read that HDMI can draw more power, but it was working previously. The only thing I did tonight that was different was connect the buttons (which are LED) to the encoder, to the Pi via a USB HUB. Is there any chance in doing this it has damaged the Pi or HDMI port?

Any help would be greatly appreciated.

Re: Rasberry Pi Zero W No HDMI Output

Posted: Sun Aug 04, 2019 12:54 am
by BRETT_No5
Update:

Used a different monitor with my HDMI to VGA and the green light comes on the monitor to say it is receiving a signal but the screen remains black.

After a lot of disconnecting and trying the same screens over and over one of my VGA monitors came on but the picture was bad, very grainy with many many green lines through it. Then it would drop in and out until it just went black again.

I am strongly thinking the HDMI port on the Pi is stuffed now.

Re: Rasberry Pi Zero W No HDMI Output

Posted: Tue Aug 06, 2019 4:23 am
by BRETT_No5
Further update. Store allowed me to return for a replacement.