HankB
Posts: 123
Joined: Fri Jan 01, 2016 2:45 pm

TL-WN725N no joy on Buster

Tue Jul 23, 2019 2:25 am

I'm trying to upgrade a Pi 2B to Buster with a clean install. I'm using this TP-Linbk adapter and the LAN is not coming up. I'm working with 2019-07-10-raspbian-buster.img.

I first tried putting wpa_supplicant.conf in the /boot partition:

Code: Select all

country=US
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="Giant Voice System"
    scan_ssid=1
    psk="your_real_password"
    key_mgmt=WPA-PSK
}
(Not actually my real password)
I also tried w/out this and configuring from the GUI. When I click on the up/down arrow icon it reports "No wireless interfaces found." raspi-config->Network Options -> N2 Wi-Fi reports the same.

Other information:
Info from dmesg when I plug in this adapter

Code: Select all

[   73.712352] usb 1-1.5: new high-speed USB device number 6 using dwc_otg
[   73.843828] usb 1-1.5: New USB device found, idVendor=0bda, idProduct=8179, bcdDevice= 0.00
[   73.843858] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[   73.843871] usb 1-1.5: Product: 802.11n NIC
[   73.843886] usb 1-1.5: Manufacturer: Realtek
[   73.843916] usb 1-1.5: SerialNumber: 00E04C0001
[   73.936824] lib80211: common routines for IEEE802.11 drivers
[   73.936851] lib80211_crypt: registered algorithm 'NULL'
[   73.967611] r8188eu: module is from the staging directory, the quality is unknown, you have been warned.
[   73.992533] Chip Version Info: CHIP_8188E_Normal_Chip_TSMC_D_CUT_1T1R_RomVer(0)
[   74.029680] usbcore: registered new interface driver r8188eu
[   74.992671] MAC Address = 60:e3:27:1a:08:3e
[   74.996486] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   84.065424] logitech-hidpp-device 0003:046D:1017.0007: HID++ 1.0 device connected.
From lsusb

Code: Select all

[email protected]:~ $ lsusb
Bus 001 Device 006: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
Bus 001 Device 005: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 004: ID 04d9:0132 Holtek Semiconductor, Inc. 
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[email protected]:~ $ 
From network utilities

Code: Select all

[email protected]:~ $ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:aa:e6:2f brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.156/24 brd 192.168.1.255 scope global noprefixroute eth0
       valid_lft forever preferred_lft forever
    inet6 2601:249:e00:6b24::16a9/128 scope global dynamic noprefixroute 
       valid_lft 7038sec preferred_lft 4338sec
    inet6 2601:249:e00:6b24:722f:c402:c3eb:544c/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 86388sec preferred_lft 14388sec
    inet6 fe80::2d51:b30b:140a:9dd6/64 scope link 
       valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 60:e3:27:1a:08:3e brd ff:ff:ff:ff:ff:ff
[email protected]:~ $ ifconfig wlan0
wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 60:e3:27:1a:08:3e  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

[email protected]:~ $ 
modules

Code: Select all

[email protected]:~ $ lsmod|egrep "8188|80211"
r8188eu               438272  0
lib80211               16384  1 r8188eu
cfg80211              614400  1 r8188eu
rfkill                 28672  2 cfg80211
[email protected]:~ $ 
Firmware

Code: Select all

[email protected]:~ $ dpkg -l firmware-realtek
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name             Version           Architecture Description
+++-================-=================-============-==================================================
ii  firmware-realtek 1:20190114-1+rpt2 all          Binary firmware for Realtek wired/wifi/BT adapters
[email protected]:~ $ 
This worked with Stretch with no difficulty. What is needed to get it working with Buster?
Do I need to follow the instructions at https://www.raspberrypi.org/forums/view ... 28&t=62371? Pretty sure I did not need that with Stretch.

Thanks!

Edit: If I plug the card into a Pi 3B I am able to use raspi-config to enter country, SSID and password and bring up the on board WiFi.

MrEngman
Posts: 3850
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: TL-WN725N no joy on Buster

Tue Jul 23, 2019 8:37 pm

I've had issues using the built in 8188eu wifi driver with Buster, as others have, but the driver I compile works OK.

You can download the driver from http://downloads.fars-robotics.net/wifi ... u-drivers/.

Download the file with the file name that matches the output from command uname -a, for kernel version and build number.
Untar the file and run the script ./install.sh to install the driver, then reboot to activate it.

Installing my driver will disable the built in r8188eu driver.



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

HankB
Posts: 123
Joined: Fri Jan 01, 2016 2:45 pm

Re: TL-WN725N no joy on Buster

Tue Jul 23, 2019 9:24 pm

Hi MrEngman. Thank you for the help.

The implication of this is that if the kernel is upgraded, then I need to update the drivers as well (until this is fixed.) Is that correct. That is a non-starter for headless systems which is how i operate most of my Pis.

I just tried an install image for Stretch (2019-04-08-raspbian-stretch.img) and this dongle works fine with this image. I guess I'll keep the systems that use this adapter on Stretch for now.

thanks,
hank

Edit.0: https://github.com/raspberrypi/linux/issues/3102

dmtech
Posts: 1
Joined: Mon Sep 30, 2019 9:31 am

Re: TL-WN725N no joy on Buster

Mon Sep 30, 2019 9:54 am

MrEngman wrote:
Tue Jul 23, 2019 8:37 pm
I've had issues using the built in 8188eu wifi driver with Buster, as others have, but the driver I compile works OK.

You can download the driver from http://downloads.fars-robotics.net/wifi ... u-drivers/.

Download the file with the file name that matches the output from command uname -a, for kernel version and build number.
Untar the file and run the script ./install.sh to install the driver, then reboot to activate it.

Installing my driver will disable the built in r8188eu driver.

MrEngman
Hi MrEngman,
Your driver works fine for me on Buster (V4.19.66), however the dongle LED no longer works. Is there a way to enable it ?
It would really be useful if it could be configured to flash or not to flash.

MrEngman
Posts: 3850
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: TL-WN725N no joy on Buster

Mon Sep 30, 2019 3:34 pm

dmtech wrote:
Mon Sep 30, 2019 9:54 am
MrEngman wrote:
Tue Jul 23, 2019 8:37 pm
I've had issues using the built in 8188eu wifi driver with Buster, as others have, but the driver I compile works OK.

You can download the driver from http://downloads.fars-robotics.net/wifi ... u-drivers/.

Download the file with the file name that matches the output from command uname -a, for kernel version and build number.
Untar the file and run the script ./install.sh to install the driver, then reboot to activate it.

Installing my driver will disable the built in r8188eu driver.

MrEngman
Hi MrEngman,
Your driver works fine for me on Buster (V4.19.66), however the dongle LED no longer works. Is there a way to enable it ?
It would really be useful if it could be configured to flash or not to flash.
Seems like the LED was not enabled in the source I am currently using. I have enabled the LED and recompiled the drivers and tried it on a Pi4 using Buster and the LED is working OK now.

You will need to download and reinstall the driver. I have currently updated drivers for kernel version 4.19.66 and all later versions.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Return to “Troubleshooting”