Sunoo
Posts: 13
Joined: Thu Jul 18, 2019 5:52 pm

Overscan Now Ignored for DMT Video Modes

Thu Jul 18, 2019 5:58 pm

I have a Raspberry Pi 3B+ that was working fine with overscan adjustments at the DMT 1024x768 resolution mode on an older Raspbian Jessie. I just did an apt-get upgrade, and now the overscan is ignored. After some testing, I was able to determine that it seems to be working for CEA modes, but is ignored on DMT modes now.

Can someone let me know if anything can be done to get that working for DMT modes again? I also tried Raspbian Buster on this Pi, with the same results. The only thing I have seen is that for the Pi 4B you need to disable the new GL driver, but this is already using the legacy driver.

trejan
Posts: 2327
Joined: Tue Jul 02, 2019 2:28 pm

Re: Overscan Now Ignored for DMT Video Modes

Thu Jul 18, 2019 7:14 pm

https://github.com/raspberrypi/linux/is ... -510108535 explains it.

What happens if you actually set disable_overscan=0? If that doesn't work then you can try testing the firmware change at https://github.com/raspberrypi/firmware ... 03ac04b72d by using rpi-update. If you don't want to use rpi-update then you'll need to wait for the new firmware to be pushed via apt.

Sunoo
Posts: 13
Joined: Thu Jul 18, 2019 5:52 pm

Re: Overscan Now Ignored for DMT Video Modes

Thu Jul 18, 2019 7:20 pm

That did it, thanks so much.

While I was waiting on a response, I had found that the last version before the Pi 4 launched worked for me. But it looks like whatever regression was made is fixed now.

And for what it's worth, I had set disable_overscan to 0 during my testing, it made no difference.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 26826
Joined: Sat Jul 30, 2011 7:41 pm

Re: Overscan Now Ignored for DMT Video Modes

Thu Jul 18, 2019 7:35 pm

It is/was a conscious decision to ignore overcan in DMT modes. DMT is for monitors, and they should not require overscan to be enabled at all. CEA, being TV, may or may not require overscan.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed.
I've been saying "Mucho" to my Spanish friend a lot more lately. It means a lot to him.

Sunoo
Posts: 13
Joined: Thu Jul 18, 2019 5:52 pm

Re: Overscan Now Ignored for DMT Video Modes

Thu Jul 18, 2019 7:37 pm

jamesh wrote:
Thu Jul 18, 2019 7:35 pm
It is/was a conscious decision to ignore overcan in DMT modes. DMT is for monitors, and they should not require overscan to be enabled at all. CEA, being TV, may or may not require overscan.
I have an iPad screen mounted in an old Mac SE/30 case, and it's slightly too big, so I need the overscan setting to adjust the viewable area to fit.

wisnoskij
Posts: 6
Joined: Thu Mar 31, 2016 7:19 pm

Re: Overscan Now Ignored for DMT Video Modes

Fri Jul 19, 2019 12:45 am

Not sure what the fix is for this. The issue says this was fixed 8 days ago, the original poster seems to have just spontaneously gotten his issue fixed?? But ever since I ran dist-upgrade yesterday I seem to have this issue. Tried running it again, and the issue persists. Do I need to subscribe to some beta channel?

DMT seems to be the only option available to me, but I definitely am using a TV.
I use an overscan of 142 (and I think that is in addition to the standard overscan applied to 1920), so the desktop is basically unusable without it.
Last edited by wisnoskij on Fri Jul 19, 2019 12:53 am, edited 1 time in total.

Sunoo
Posts: 13
Joined: Thu Jul 18, 2019 5:52 pm

Re: Overscan Now Ignored for DMT Video Modes

Fri Jul 19, 2019 12:47 am

wisnoskij wrote:
Fri Jul 19, 2019 12:45 am
Not sure what the fix is for this. The issue says this was fixed 8 days ago, the original poster seems to have just spontaneously gotten his issue fixed. But ever since I ran dist-upgrade yesterday I seem to have this issue. Tried running it again, and the issue persists. Do I need to subscribe to some beta channel?
Run rpi-update, that’s what did it for me.

trejan
Posts: 2327
Joined: Tue Jul 02, 2019 2:28 pm

Re: Overscan Now Ignored for DMT Video Modes

Fri Jul 19, 2019 1:07 am

wisnoskij wrote:
Fri Jul 19, 2019 12:45 am
Not sure what the fix is for this. The issue says this was fixed 8 days ago, the original poster seems to have just spontaneously gotten his issue fixed?? But ever since I ran dist-upgrade yesterday I seem to have this issue. Tried running it again, and the issue persists. Do I need to subscribe to some beta channel?
Changes to the firmware don't get released to everybody immediately as they have to go through testing first. The fix for overscan was only put into the firmware 3 days ago and hasn't been pushed as a regular update via apt yet. If you want to test it then you can run the rpi-update like Sunoo did. Read the warnings here first. If you don't want to run rpi-update then you'll need to wait for the apt update.

wisnoskij
Posts: 6
Joined: Thu Mar 31, 2016 7:19 pm

Re: Overscan Now Ignored for DMT Video Modes

Fri Jul 19, 2019 1:08 am

That's fixed it. Thanks Sunoo!

Return to “Troubleshooting”