Cael
Posts: 96
Joined: Sat Jul 07, 2012 7:08 am

Composite Video DOA on RPi 4?

Fri Jul 12, 2019 3:26 pm

After being a little later than CanaKit had said over email, my Pi4 4GB arrived yesterday, (and i forgot to order MicroHDMI cables in time so thats arriving on monday,) i still have my Zune TV Cable thats working perfectly w/ my 3B+ for analouge out.

now i dont know if its NOOBS 3.1.1 or if the composite out is actually dead, on my tv the "VIDEO 2" (Composite In, as 1 is for Svideo) goes away once signal is received, when i power on the Pi and wait for noobs to boot, i press 4 to bring up Composite (NTSC) and it distorts and gives a noisy screen but no actual screen. (indicated the tv is still displaying "VIDEO 2")

i go to think as i havent yet looked to see if its changed between previous pi's or not if somehow its swapped so i try changing the L/R audio plugs in video in, Nothing. plug video back in and same nosy distortion. so now i try my Elgato HD Capture (the first gen that still does Component and Composite capture) and flat out no signal is detected.

i havent yet flashed Raspian with Buster to the SD Card and i'm going to after posting this but, is this Noob's bug? or is my Pi's analouge out dead on arrival?

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 26349
Joined: Sat Jul 30, 2011 7:41 pm

Re: Composite Video DOA on RPi 4?

Fri Jul 12, 2019 3:40 pm

There is an option in raspi-config to turn on the composite. We default to off as it requires some clocks to be turned down which affects performance.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed.
I've been saying "Mucho" to my Spanish friend a lot more lately. It means a lot to him.

Cael
Posts: 96
Joined: Sat Jul 07, 2012 7:08 am

Re: Composite Video DOA on RPi 4?

Fri Jul 12, 2019 7:18 pm

ahh then to use it for now i need the direct Raspbian image, (the readme for NOOBS says to press 4 for composite)

Hmm still acting like that, is it something other than setting SDTV_Mode=0 ?

drgeoff
Posts: 10618
Joined: Wed Jan 25, 2012 6:39 pm

Re: Composite Video DOA on RPi 4?

Fri Jul 12, 2019 9:11 pm

jamesh wrote:
Fri Jul 12, 2019 3:40 pm
There is an option in raspi-config to turn on the composite. We default to off as it requires some clocks to be turned down which affects performance.
Which seems to make it not straightforward to enable by those without HDMI displays. Requires headless setup and ssh from another computer.

Return to “Troubleshooting”