ljones586
Posts: 2
Joined: Wed Jul 10, 2019 1:50 pm

KDE plasma problems on Pi 3B+/4

Wed Jul 10, 2019 2:29 pm

Hello all,

Since the new pi 4 arrived I've been intrested to see how well the new pi 4 runs kde/plasma. Unfortunatly I haven't been getting all that far.

FYI I'm using the latest version of raspbian buster lite (June 2019) and the official power supplies for the pi 3b+ and 4. The micro sd card is a 32gb samsung pro endurance.

Unfortunatly both the pi3b+ and 4 seem to have problems with kde plasma. I do understand that in particular the pi3b+ is going to have a hard time running kde however for some reason (I normally install the packages manually btw) sddm refused to start on the pi3b+. After logging in at the command line and typing startx however kde plasma on the pi3b+ works, albeit very slowly(!).

A much worse problem seems to exist on the pi4 however. Using the same software on the same microsd card (and with the official pi4 PSU) sddm this time works ok, but unfortunatly kde plasma dosen't. I've attached a picture which seems to show lots of graphical issues - missing icons, text, window decorations.

BTW here's what I did from the command line to install kde plasma;

Code: Select all

$ apt update
$ apt upgrade
$ apt dist-upgrade
$ apt-get install firmware-linux-free firmware-linux-nonfree
$ apt-get install xorg kde-plasma-desktop
From memory off the debian website the package "kde-plasma-desktop" should pull in enough for a basic kde desktop. This steup works fine btw for my main x86 box.

Unrelated note: I'm also finding the "reboot" command (command line) works fine on the pi3b+ dosen't actually want to reboot the pi4! (The pi 4 just shuts down instead).

Can anyone else think what might be wrong here?
Attachments
kde-plasma-not-working-on-pi4_buster.jpg
kde-plasma-not-working-on-pi4_buster.jpg (78.15 KiB) Viewed 4509 times

Giga_Pi
Posts: 115
Joined: Mon May 20, 2019 9:48 am

Re: KDE plasma problems on Pi 3B+/4

Thu Aug 01, 2019 6:38 am

Hey!

I had problems with KDE plasma on my 3B+, but I've got it running really well. Here is my setup:

I use stretch instead of buster, as I found buster didn't work so good. I'm not quite sure why.

I also enable the OpenGL driver with full KMS in the raspi-config

I then install the kde plasma desktop, and SDDM and the KDE Plasma desktop run fine with me.

Not quite sure about the 4B, as I don't have one myself, but I do hope this helps!

Giga_Pi
As soon as the DM smiles, you know it's too late...

ljones586
Posts: 2
Joined: Wed Jul 10, 2019 1:50 pm

Re: KDE plasma problems on Pi 3B+/4

Sun Sep 01, 2019 10:49 pm

Well I got kde plasma to work on the PI 4 in the end. It involves either commenting out dtoverlay=vc4-fkms-v3d in /boot/config.txt or pressing shift-alt-f12 (and disabling composite effects) once you login (but get that screen display above).

I found it best to turn off all composite effects on the pi but still although they work I can't get all 3 things correct - 2d xorg acceleration, 3d acceleration and compositing. I can get one right but then the other two are affected.

ljones

MikeOffenbach
Posts: 3
Joined: Wed Dec 21, 2016 6:18 am
Contact: Skype

Re: KDE plasma problems on Pi 3B+/4

Sat Oct 12, 2019 2:42 am

I have KDE Desktop running on a Raspberry Pi2B
Some of the tricks I used may be helpful to get the Plasma Desktop running on Raspberry 3 & 4

You can find the details here

[url]https://raspberrypi.stackexchange.com/q ... berry-pi-3[/url]

Return to “Troubleshooting”