pcmanbob
Posts: 7134
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Network fails after rebooting but fine after shutting down

Wed Jul 10, 2019 6:47 pm

yanewby wrote:
Wed Jul 10, 2019 5:57 pm
pcmanbob wrote:
Wed Jul 10, 2019 5:13 pm
Do you have a relative or friend that would allow you to connect your pi to their network and try testing it then ?
Sadly not. I am Billy No Mates.
May be if you tell us where in the world you are some one may be able to help or suggest a local club that could help.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

yanewby
Posts: 58
Joined: Sun Nov 18, 2012 12:22 pm

Re: Network fails after rebooting but fine after shutting down

Wed Jul 10, 2019 8:22 pm

ncguk wrote:
Wed Jul 10, 2019 6:44 pm
I'm having a similar problem here. I have a Samsung Evo 32GB microSD card with Buster on it (with a static eth0 IP address set outside of the DHCP range in /etc/network/interfaces) that has been working just fine at boot and between reboots on a Pi 4 2GB model. I've just taken the card, put it into a previously unbooted Pi 4 4GB model, and I cannot ssh into it. I can successfully ping the 4GB Pi, I can see that port 22 on the 4GB Pi is open, the right-hand light on the Pi 4GB ethernet port is solid orange and the left hand light blinks green at approximately 2 second intervals, occasionally blinking twice quickly. When attempting to ssh into the 4GB Pi from my Mac, no timeout or network error message is returned - the Mac's ssh just perpetually attempts to connect. If I unplug and re-plug the ethernet cable I can then ssh into the 4GB Pi until next reboot.

I'm hoping this isn't a duff Pi 4, but a software problem instead.

Huh. I had unbound running on the 2GB Pi and thus on the 4GB Pi. I uninstalled it, rebooted the 4GB Pi and could ssh into it immediately on reboot. I don't imagine this is the same as the OP's issue.
There are similarities... my card is a 16Gb Samsung Evo and I do have unbound on my router. I am trying to ssh in on LMDE instead of a Mac. Your LAN lights sound very familiar too. My Pi4 is a 4Gb.

yanewby
Posts: 58
Joined: Sun Nov 18, 2012 12:22 pm

Re: Network fails after rebooting but fine after shutting down

Wed Jul 10, 2019 8:25 pm

pcmanbob wrote:
Wed Jul 10, 2019 6:47 pm
yanewby wrote:
Wed Jul 10, 2019 5:57 pm
pcmanbob wrote:
Wed Jul 10, 2019 5:13 pm
Do you have a relative or friend that would allow you to connect your pi to their network and try testing it then ?
Sadly not. I am Billy No Mates.
May be if you tell us where in the world you are some one may be able to help or suggest a local club that could help.
I'm housebound due to a long term chronic illness. Programming is the only thing that keeps me sane but hardware issues like this jeopardise that sanity.

epoch1970
Posts: 3801
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Network fails after rebooting but fine after shutting down

Wed Jul 10, 2019 8:40 pm

https://github.com/raspberrypi/linux/issues/3034
I think this matches your case?
Running 'mii-tool -r eth0' might be a workaround
The thread is a bit inconclusive unfortunately.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

yanewby
Posts: 58
Joined: Sun Nov 18, 2012 12:22 pm

[SOLVED]* Re: Network fails after rebooting but fine after shutting down *with hack

Thu Jul 11, 2019 10:00 am

epoch1970 wrote:
Wed Jul 10, 2019 8:40 pm
https://github.com/raspberrypi/linux/issues/3034
I think this matches your case?
Running 'mii-tool -r eth0' might be a workaround
The thread is a bit inconclusive unfortunately.
rustle, rustle (gets Pi4 from the bin)

Woo-hoo! You beauty epoch1970! Woo-hoo!

For anyone else pulling their hair out over a similar issue, putting this in /etc/rc.local will fix the problem for now (while the brains try to sort this out):

Code: Select all

(sleep 30s; ethtool -r eth0;) &
Thank-you, thank-you, thank-you epoch1970!

I've rebooted successfully 5 times in a row now. I think I can stop and start properly playing with my new toy.

epoch1970
Posts: 3801
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Network fails after rebooting but fine after shutting down

Thu Jul 11, 2019 10:31 am

Great! Saving one Pi4 at a time :)

Perhaps you could contribute a slight "me-too" message with the specs of your router/pi/OS in that github ticket?
This behaviour is weird, there is quite possibly a bug somewhere, in kernel, driver or firmware.

Cheers.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

yanewby
Posts: 58
Joined: Sun Nov 18, 2012 12:22 pm

Re: Network fails after rebooting but fine after shutting down

Thu Jul 11, 2019 1:06 pm

OK. Small update.

This morning I took delivery of my second Pi4.

I commented out the fix epoch1970 discovered that I had put in /etc/rc.local (https://www.raspberrypi.org/forums/view ... 0#p1497497) and put the old SD card in the new Pi4. Used the same router, same cable, same power supply, same everything apart from the Pi4.

The new Pi4 booted first time and acquired the proper static IP address without issue.

I rebooted a few times just in case but I have been unable to cause it not to boot.

So I took the SD card back out and put it into the original Pi4 again. It did not boot. Put the SD card into the new Pi4, booted fine.

This is pointing towards some sort of strange hardware problem. What should I do? Is there someone at Raspberry Pi this can be reported to?

(FWIW I tried to report this on github but they flagged my account and removed my comment. Oh well, I tried.)

pcmanbob
Posts: 7134
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Network fails after rebooting but fine after shutting down

Thu Jul 11, 2019 1:48 pm

yanewby

I have flagged your last post to the mods and asked jamesh if its some thing he would be interested in,

that's the only way I can think of to get his attention as private messages are no turned off.
We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

yanewby
Posts: 58
Joined: Sun Nov 18, 2012 12:22 pm

Re: Network fails after rebooting but fine after shutting down

Thu Jul 11, 2019 2:25 pm

pcmanbob wrote:
Thu Jul 11, 2019 1:48 pm
yanewby

I have flagged your last post to the mods and asked jamesh if its some thing he would be interested in,

that's the only way I can think of to get his attention as private messages are no turned off.
Thank-you, I would be happy to send it back to anyone at the Raspberry Pi team for investigation especially as this seems it might be an issue with the board and possibly not just my board.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12351
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Network fails after rebooting but fine after shutting down

Thu Jul 11, 2019 2:42 pm

pcmanbob wrote:
Thu Jul 11, 2019 1:48 pm
yanewby

I have flagged your last post to the mods and asked jamesh if its some thing he would be interested in,

that's the only way I can think of to get his attention as private messages are no turned off.
warned jamesh....

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23918
Joined: Sat Jul 30, 2011 7:41 pm

Re: Network fails after rebooting but fine after shutting down

Thu Jul 11, 2019 3:28 pm

I've passed this on the the HW team to see if they want the board back - will get back once I know.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23918
Joined: Sat Jul 30, 2011 7:41 pm

Re: Network fails after rebooting but fine after shutting down

Fri Jul 12, 2019 10:44 am

Quick question. It appears you are using static IP's? What happens if you use dynamic IP's? Also, a vanilla Buster image would be best for testing - no config changes etc.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

yanewby
Posts: 58
Joined: Sun Nov 18, 2012 12:22 pm

Re: Network fails after rebooting but fine after shutting down

Fri Jul 12, 2019 11:32 am

jamesh wrote:
Fri Jul 12, 2019 10:44 am
Quick question. It appears you are using static IP's? What happens if you use dynamic IP's? Also, a vanilla Buster image would be best for testing - no config changes etc.
I have tried setting static IP's only on the Pi, only on my router and on both the Pi and the router. I have also tried asking for dynamic IP's (by removing all the static IP requests). I have rebooted my router in between each change (and tried not rebooting the router). Nothing has worked. They all resulted in the Pi hanging during the boot process. I got really cheesed off with re-booting stuff and the Pi even landed up in the bin overnight (until epoch1970 rescued the day)!

I have been using the Buster image downloaded from the Rapberry Pi website. The only things I have added are my wpa_supplicant.conf file in order to be able to log in via wifi. No updates have been performed. It was just burnt to a 16Gb Samsung Evo+ card using Etcher. Heck, I've even tried without the wpa_supplicant.conf file.

Putting the SD card in another Pi4 (4Gb) resulted in that Pi booting reliably every time first time. Swapping the card to the old Pi again resulted in no boot. Swapping the card back to the new Pi and the new Pi boots with no problem. The only variable I can see is the Pi - one of mine works and one doesn't.

The only thing that works every time is the ethtool -r eth0 command and run at boot in rc.local. Sometimes (but not in a reproducible way) altering the dhcpcd.conf file allows it to boot the first time but rarely on subsequent boots (estimate 5% of the time).

Using sudo shutdown -h now seems to allow it to boot more often than using sudo reboot (but even this is not reliable).

I hope some of this is helpful. If you need me to run any commands on either/both Pi's I would be happy to.

shrd
Posts: 5
Joined: Fri Jul 12, 2019 1:20 pm

Re: Network fails after rebooting but fine after shutting down

Fri Jul 12, 2019 1:46 pm

I can confirm the same problem with a 2GB rapsberry 4 : I need to unplug/replug the ethernet cable to get the correct IP.
Sometimes I get the correct IP (ping is ok) but no ssh possible.
A second raspeberry 4 (1 GB) seems to have no problem (with the same SD card and same ethernet cable on the same router jack) but I have tested less than 10 boot for now with it.

(sleep 10s; ethtool -r eth0;) & in /etc/rc.local increase the boot time process but no problem after.

yanewby
Posts: 58
Joined: Sun Nov 18, 2012 12:22 pm

Re: Network fails after rebooting but fine after shutting down

Fri Jul 12, 2019 3:31 pm

shrd wrote:
Fri Jul 12, 2019 1:46 pm
I can confirm the same problem with a 2GB rapsberry 4 : I need to unplug/replug the ethernet cable to get the correct IP.
Sometimes I get the correct IP (ping is ok) but no ssh possible.
A second raspeberry 4 (1 GB) seems to have no problem (with the same SD card and same ethernet cable on the same router jack) but I have tested less than 10 boot for now with it.

(sleep 10s; ethtool -r eth0;) & in /etc/rc.local increase the boot time process but no problem after.
It is interesting to hear that your 2Gb Pi4 has the problem. All of the other people I have heard about with this issue so far I think have reported they had 4Gb versions.

I am glad the ethtool fix works for you also but IMHO it is a bit of a hack. As far as I can tell it adds a delay to the boot which may or may not happen in the correct period during the boot sequence (I can imagine it still failing in some cases). It is also not helpful if you are trying to buy a headless machine as it requires you add another step to the setup process (altering the /etc/rc.local file in addition to creating a /boot/ssh) which may be difficult to explain to complete amateurs. I know I would not have been able to resolve this without the expertise here and searching the web.

I hope that I will be allowed to replace my non-fully functional Pi 4 at some point at Raspberry Pi.org. I would never feel confident using that Pi with a wired connection.

yanewby
Posts: 58
Joined: Sun Nov 18, 2012 12:22 pm

Re: Network fails after rebooting but fine after shutting down

Tue Jul 16, 2019 6:54 am

jamesh wrote:
Fri Jul 12, 2019 10:44 am
Quick question. It appears you are using static IP's? What happens if you use dynamic IP's? Also, a vanilla Buster image would be best for testing - no config changes etc.
Any further news or should I just throw away this defective Pi 4? I do not feel it is up to the usual Pi standard in manufacture (I own/have owned more than 10 and this is only the second I have had problems with) and would not feel confident using it in a production environment due to the hack required to make it boot. I wish there was some other way of contacting Raspberry Pi rather than having to air my grievances in public.

Esskaaell
Posts: 5
Joined: Thu Jul 18, 2019 11:33 pm

Re: Network fails after rebooting but fine after shutting down

Fri Jul 19, 2019 2:36 pm

Hi,

I have a Pi 4 1GB version with the very last Buster and with the exactly same issue.
I am glad didn't have to do all the things you did, but tried everything I could by myself.
Many image writing, DHCP, fix IP, quasi fix IP, different cables, even a secondary router.
My last thought was this should be a hardware issue and it looks like I was right.
I am going to change it for an other one at shop where I bought it. It was good to get a message from somebody about this topic.

AnInternetPerson
Posts: 1
Joined: Thu Jul 25, 2019 4:11 pm

Re: Network fails after rebooting but fine after shutting down

Thu Jul 25, 2019 4:15 pm

I am also experiencing the same issue on my Pi 4 4GB model. Is there any chance of getting a refund or are we out of luck? I bought it though Pimoroni.

yanewby
Posts: 58
Joined: Sun Nov 18, 2012 12:22 pm

Re: Network fails after rebooting but fine after shutting down

Fri Jul 26, 2019 6:33 am

I returned mine to Raspberry Pi Ltd.

I received an email from them saying that they could not replicate the problem and that they would return my Pi to me. A week later I have still not received it back.

Very disappointed. The enthusiasm I had for Raspberry Pi is rapidly disappearing especially as I was also effected by the PoE fiasco as well. Now with this they seem to be saying there is no problem despite there obviously being one.

yanewby
Posts: 58
Joined: Sun Nov 18, 2012 12:22 pm

Re: Network fails after rebooting but fine after shutting down

Fri Jul 26, 2019 11:24 am

My replacement Pi was delivered today.

A word of warning for anyone else thinking of returning their Pi to Raspberry Pi at your own expense after they request it and offer you goodies in lieu of the postage... it cost me £15 to return the Pi, they generously gave me a £5 cable to cover my costs.

Both the Pi and the cable have gone straight in the bin.

User avatar
rpdom
Posts: 15418
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Network fails after rebooting but fine after shutting down

Fri Jul 26, 2019 11:42 am

yanewby wrote:
Fri Jul 26, 2019 11:24 am
My replacement Pi was delivered today.

A word of warning for anyone else thinking of returning their Pi to Raspberry Pi at your own expense after they request it and offer you goodies in lieu of the postage... it cost me £15 to return the Pi, they generously gave me a £5 cable to cover my costs.

Both the Pi and the cable have gone straight in the bin.
Send the Pi and the cable to me. I'll pay the postage just to save the environment.

RGJ-PI
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 25
Joined: Fri May 24, 2019 2:10 pm
Location: Cambridge UK

Re: Network fails after rebooting but fine after shutting down

Fri Jul 26, 2019 11:58 am

yanewby wrote:
Fri Jul 26, 2019 11:24 am
I returned mine to Raspberry Pi Ltd.

I received an email from them saying that they could not replicate the problem and that they would return my Pi to me. A week later I have still not received it back.

My replacement Pi was delivered today.

A word of warning for anyone else thinking of returning their Pi to Raspberry Pi at your own expense after they request it and offer you goodies in lieu of the postage... it cost me £15 to return the Pi, they generously gave me a £5 cable to cover my costs.

Both the Pi and the cable have gone straight in the bin.
Well actually I emailed you on Tuesday of this week so hardly a week later?

As well as returning your no fault found Pi 4 we also shipped a micro HDMI lead so you could check it actually reboots and not just a network issue. We also sent a replacement Pi 4 4GB along with your board so that seems to be about £60 up or £57 after your £3 postage cost.

Did you try your returned Pi 4 with the cable to determine it booted before chucking it in the bin?

User avatar
liz
Raspberry Pi Foundation Employee & Forum Moderator
Raspberry Pi Foundation Employee & Forum Moderator
Posts: 5202
Joined: Thu Jul 28, 2011 7:22 pm
Contact: Website

Re: Network fails after rebooting but fine after shutting down

Fri Jul 26, 2019 12:02 pm

I've checked the manifest, and Yanewby's not being quite straightforward here. For more, please see GitHub. There's quite a lot of...fibbing going on.

https://github.com/raspberrypi/linux/is ... -515424536
Director of Communications, Raspberry Pi

yanewby
Posts: 58
Joined: Sun Nov 18, 2012 12:22 pm

Re: Network fails after rebooting but fine after shutting down

Fri Jul 26, 2019 12:11 pm

liz wrote:
Fri Jul 26, 2019 12:02 pm
I've checked the manifest, and Yanewby's not being quite straightforward here. For more, please see GitHub. There's quite a lot of...fibbing going on.

https://github.com/raspberrypi/linux/is ... -515424536
Please have a member of your legal team contact me. I take libel very seriously.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23918
Joined: Sat Jul 30, 2011 7:41 pm

Re: Network fails after rebooting but fine after shutting down

Fri Jul 26, 2019 12:14 pm

Closing.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

Return to “Troubleshooting”