Posts: 20
Joined: Sat Jul 06, 2019 12:49 am

RPI4 4gb, not loading textures properly in some games, and an issue with chrome, hardware accel, and the latest debian.

Sun Jul 07, 2019 8:39 pm

So I'm getting this weird issue where my RPI4 4gb doesn't seem to load textures properly in some games.

I've tested it on a few different ones with the same result. This particular one is

I'm running Raspbian Buster. I've done apt-get update, apt-get dist-upgrade, and rpi-update (did this for the latest firmware that allows hardware acceleration in chromium again). My chrome://gpu shows hardware acceleration is working. I've also tried setting gpu_mem=512 in the config.txt.

Any idea on what's going on?


Here's my chrome://gpu to clear that up.

Code: Select all

Graphics Feature Status
Canvas: Hardware accelerated
Flash: Hardware accelerated
Flash Stage3D: Hardware accelerated
Flash Stage3D Baseline profile: Hardware accelerated
Compositing: Hardware accelerated
Multiple Raster Threads: Enabled
Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
Out-of-process Rasterization: Disabled
Hardware Protected Video Decode: Unavailable
Rasterization: Software only. Hardware acceleration disabled
Skia Renderer: Disabled
Surface Control: Disabled
Surface Synchronization: Enabled
Video Decode: Unavailable
Viz Service Display Compositor: Enabled
WebGL: Hardware accelerated
WebGL2: Hardware accelerated
Edit 2:

I don't think it's actually HTML5 related as it's happening in games from apt-get like Seven Kingdoms and Widelands as well. Some games run fine, others seem to have the texture bug. Adjusted title to reflect this.
Last edited by thrustpork on Mon Jul 08, 2019 4:27 pm, edited 1 time in total.

Posts: 20
Joined: Sat Jul 06, 2019 12:49 am

Re: RPI4 4gb, not loading textures properly in some games?

Mon Jul 08, 2019 4:26 pm

I’ve got another issue now. I ran apt update last night and my debian switched from test to inrelease as well as downloaded some files. Now when I try to play a video in chromium the whole tab turns black and locks up.

I’m running the latest rpi-update and if I disable the hardware acceleration in chrome it works, but I think the fix in testing was broken by the debian update somehow.

Return to “Troubleshooting”