LFHeller
Posts: 10
Joined: Mon Aug 03, 2015 12:07 pm
Location: St. Leonards-on-Sea, E. Sussex, UK.

Latest Raspbian doesn't recognise @ on UK keyboard

Wed Jul 03, 2019 3:41 pm

Whilst waiting for my Pi4 I've downloaded the latest Raspbian (Buster) and tried it on one of my 3B boards. Unlike the earlier version I had been using, the new version seems to have a problem with the @ key, and doesn't recognise Alt-64. Both ways of getting @ work fine if I plug the keyboard into my Win10 laptop.

Has anyone got any suggestions?
Last edited by LFHeller on Wed Jul 03, 2019 4:23 pm, edited 1 time in total.
Leon Heller
G1HSM

gordon77
Posts: 5040
Joined: Sun Aug 05, 2012 3:12 pm

Re: Latest Raspbian doesn't recognise @ on UK keyboard

Wed Jul 03, 2019 3:49 pm

Have you checked in the pi config you have a UK keyboard chosen?

LFHeller
Posts: 10
Joined: Mon Aug 03, 2015 12:07 pm
Location: St. Leonards-on-Sea, E. Sussex, UK.

Re: Latest Raspbian doesn't recognise @ on UK keyboard

Wed Jul 03, 2019 3:53 pm

Thanks.

I chose UK when setting things up initially, I didn't realise I had to do anything else - I haven't previously. I'll try pi config. It should have recognised Alt-64, though.
Last edited by LFHeller on Wed Jul 03, 2019 4:23 pm, edited 2 times in total.
Leon Heller
G1HSM

gordon77
Posts: 5040
Joined: Sun Aug 05, 2012 3:12 pm

Re: Latest Raspbian doesn't recognise @ on UK keyboard

Wed Jul 03, 2019 3:55 pm

choose Preferences > Raspberry Pi Configuration > Localisation > Keyboard > English (UK)
Attachments
keyb.jpg
keyb.jpg (41.08 KiB) Viewed 751 times
Last edited by gordon77 on Wed Jul 03, 2019 4:49 pm, edited 3 times in total.

jahboater
Posts: 5789
Joined: Wed Feb 04, 2015 6:38 pm
Location: West Dorset

Re: Latest Raspbian doesn't recognise @ on UK keyboard

Wed Jul 03, 2019 4:02 pm

I have the same problem.
I carefully did not select US keyboard during the initial config dialog.

Yet the keyboard layout is US.

You can set the UK layout in raspi-config.

LFHeller
Posts: 10
Joined: Mon Aug 03, 2015 12:07 pm
Location: St. Leonards-on-Sea, E. Sussex, UK.

Re: Latest Raspbian doesn't recognise @ on UK keyboard

Wed Jul 03, 2019 4:04 pm

Thanks very much, that did the trick!

Like the previous poster I did not select US keyboard during initial config.
Last edited by LFHeller on Wed Jul 03, 2019 4:24 pm, edited 1 time in total.
Leon Heller
G1HSM

gordon77
Posts: 5040
Joined: Sun Aug 05, 2012 3:12 pm

Re: Latest Raspbian doesn't recognise @ on UK keyboard

Wed Jul 03, 2019 4:15 pm

I found the same, maybe a bug / feature.

SimUK
Posts: 7
Joined: Wed Jun 26, 2019 10:06 am

Re: Latest Raspbian doesn't recognise @ on UK keyboard

Wed Jul 03, 2019 4:41 pm

.
Last edited by SimUK on Mon Jul 22, 2019 6:33 pm, edited 1 time in total.

LFHeller
Posts: 10
Joined: Mon Aug 03, 2015 12:07 pm
Location: St. Leonards-on-Sea, E. Sussex, UK.

Re: Latest Raspbian doesn't recognise @ on UK keyboard

Thu Jul 04, 2019 6:51 pm

I found this in Using your Raspberrry Pi:

https://projects.raspberrypi.org/en/pro ... pi-using/3
Leon Heller
G1HSM

User avatar
startrek.steve
Posts: 386
Joined: Thu Aug 30, 2012 7:19 pm

Re: Latest Raspbian doesn't recognise @ on UK keyboard

Fri Jul 05, 2019 8:45 am

Same problem on mine, you have to select all the uk locales AND the US ones, I know it sounds stupid, but it works and you will have a UK region and keyboard.

Steve
Pi 2 running LibreElec Krypton, Pi 2 running Wheezy Desktop, Pi 1 headless Wheezy, downloading Radio, Pi 1 running Picore headless Media Server, Pi Zero to be an Old Time Radio Project. Pi 3 testing. Pi Zero W downloading Radio shows headless.

Return to “Troubleshooting”