tshot
Posts: 1
Joined: Thu Jun 27, 2019 2:58 pm

Pi 4 not booting

Thu Jun 27, 2019 3:04 pm

Heya all!
First off , sorry for my english, not my main leguage :oops:

I just recived the Pi4 (4gb), tried to install NOOBS on a sd card (Transcend 256gb) formated on FAT32 but Pi4 does nothing, tried to unplug all usbs, the sd card, even the video but same results. Allways the gree and red leds are ON, no flicker, they are just allways ON
Also tried to install last raspbian buster with etcher, but same results, leds allways on, no flicker and video signal

Any ideas?

Weynoon
Posts: 1
Joined: Thu Jun 27, 2019 5:13 pm

Re: Pi 4 not booting

Thu Jun 27, 2019 5:16 pm

Hey,

I got the 2gb version and also have the Problem. I tested noobs and libreelec, but got Only a coloured screen with noobs and nothing happens then. LED is only Red after some short green blinking.

Thx
Chris

1GuyFromHalton
Posts: 1
Joined: Thu Jun 21, 2012 8:03 pm

Re: Pi 4 not booting

Thu Jun 27, 2019 8:20 pm

Hi. Perhaps the capacity of the SD card is too much.

I have been trying to find the maximum size supported but all the Official stuff just says micro SD card slot.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23393
Joined: Sat Jul 30, 2011 7:41 pm

Re: Pi 4 not booting

Thu Jun 27, 2019 9:39 pm

1GuyFromHalton wrote:
Thu Jun 27, 2019 8:20 pm
Hi. Perhaps the capacity of the SD card is too much.

I have been trying to find the maximum size supported but all the Official stuff just says micro SD card slot.
1TB should work. If you have an SD card bigger than that, it should also work.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
"My grief counseller just died, luckily, he was so good, I didn't care."

mrlinux2u
Posts: 215
Joined: Sat Sep 24, 2011 8:38 pm

Re: Pi 4 not booting

Fri Jun 28, 2019 9:18 am

I had a similar issue this morning (booting off a 32gb SD card with Buster desktop on it, not NOOBS) - powered up got the rainbow screen and then the monitor went blank (no display signal), however this was using HDMI 1, when I swapped over to HDMI 0 everything went as expected.

Cheers

Paul

sy-subrc
Posts: 1
Joined: Fri Jun 28, 2019 12:11 pm

Re: Pi 4 not booting

Fri Jun 28, 2019 12:18 pm

Similar for me (PI4 1MB), didn't get the system to boot with noobs. Got always stuck at the rainbow screen. Then I tried a buster image (using PIBaker) and it finally worked. Probably some problem with the SD card or the FAT filesystem...

cyber2024
Posts: 1
Joined: Fri Jun 28, 2019 2:27 pm

Re: Pi 4 not booting

Fri Jun 28, 2019 2:34 pm

Paul, you **....**

I was very careful initially with ensuring HDMI Port 0 was being used, so when I got the rainbow screen I was quite confused.

Somewhere along the way I must have unplugged the micro HDMI because I was in Port 1.

Cheers for the heads up.

Russ

mrlinux2u
Posts: 215
Joined: Sat Sep 24, 2011 8:38 pm

Re: Pi 4 not booting

Sat Jun 29, 2019 8:26 am

Glad I could help Russ :D

matthait
Posts: 2
Joined: Sun Jun 30, 2019 1:01 am

Re: Pi 4 not booting

Sun Jun 30, 2019 1:10 am

Got a new pi 4 4gb model today.
After etching Buster and initial set up system would not boot with dual monitors connected.
Would boot with only one monitor in hdmi 0 (did not matter which of the two monitors i used, they are the same model number)
After lots of troubleshooting solved dual monitor boot up issue you guys may be having by using the following.

when turning on the Pi 4 (plugging in or from reboot) I have to power cycle one of my monitors (plugged in hdmi port 1) so that the monitor does not time out (no signal displayed on monitor) before the pi displays the 4 pis on the primary screen. If i time it right, i get a rainbow square on the other screen.

I have tried many ways in config.txt to fix this timeout issue but I believe its part the pi problem, part Buster problem, and part my monitor.

if i do not time the power cycle of the monitor right, the unit locks up after the 4 pis and will not display anything on either monitor and will not boot far enough to permit an SSH connection.

Hopefully this helps someone else.

WindyMiller
Posts: 7
Joined: Sat Dec 08, 2012 7:06 pm

Re: Pi 4 not booting

Tue Jul 02, 2019 7:15 pm

I have an Eyoyo monitor. I couldn't get my shiny new Pi4 to boot, so after reading this I tried an old vga monitor with HDMI adaptor and 'hey presto' it works.
Now I'm having trouble SSHing into it.
Pi4 an improvement? It's the first Pi ive had trouble with Hmmmm :roll:

User avatar
PeterO
Posts: 4942
Joined: Sun Jul 22, 2012 4:14 pm

Re: Pi 4 not booting

Tue Jul 02, 2019 7:20 pm

matthait wrote:
Sun Jun 30, 2019 1:10 am
when turning on the Pi 4 (plugging in or from reboot) I have to power cycle one of my monitors (plugged in hdmi port 1) so that the monitor does not time out (no signal displayed on monitor) before the pi displays the 4 pis on the primary screen. If i time it right, i get a rainbow square on the other screen.
I have same issue, but I find just turning everything (Pi + monitors) on at the same time produced a reliable boot.
RPT are aware of this issue.
PeterO
Discoverer of the PI2 XENON DEATH FLASH!
Interests: C,Python,PIC,Electronics,Ham Radio (G0DZB),1960s British Computers.
"The primary requirement (as we've always seen in your examples) is that the code is readable. " Dougie Lawson

k-pi
Posts: 922
Joined: Sun Feb 12, 2017 1:46 pm
Location: Upper Hale, Surrey, UK.

Re: Pi 4 not booting

Tue Jul 02, 2019 8:45 pm

WindyMiller wrote:
Tue Jul 02, 2019 7:15 pm
I have an Eyoyo monitor. I couldn't get my shiny new Pi4 to boot, so after reading this I tried an old vga monitor with HDMI adaptor and 'hey presto' it works.
Now I'm having trouble SSHing into it.
Pi4 an improvement? It's the first Pi ive had trouble with Hmmmm :roll:
I'm having troubles with HDMI too, mine is also an Eyoyo monitor that works perfectly with all 4 of my other RPi's, it's just this RPi4B & Buster, my card works perfectly well in my RPi3B+.

Here's my rant, & what I've managed to get working so far.
https://www.raspberrypi.org/forums/view ... 3&t=244431

amilino
Posts: 83
Joined: Fri Feb 05, 2016 6:01 pm

Re: Pi 4 not booting

Mon Jul 08, 2019 3:19 pm

In my case, sometimes it is booting sometimes not, very unstable one must say. Never had this issues on old RPi's. Also if you try to reboot sometimes it works sometimes not. I guess it is Buster or hardware issue or both.

andsoitgoes
Posts: 6
Joined: Mon Oct 15, 2012 9:08 pm

Re: Pi 4 not booting

Thu Jul 11, 2019 9:11 pm

mrlinux2u wrote:
Fri Jun 28, 2019 9:18 am
I had a similar issue this morning (booting off a 32gb SD card with Buster desktop on it, not NOOBS) - powered up got the rainbow screen and then the monitor went blank (no display signal), however this was using HDMI 1, when I swapped over to HDMI 0 everything went as expected.

Cheers

Paul
I feel like such an idiot, this was exactly it. I thought the port I plugged into WAS the primary HDMI and was too stupid to check it, thanks for the suggestion, Paul!

User avatar
PeterO
Posts: 4942
Joined: Sun Jul 22, 2012 4:14 pm

Re: Pi 4 not booting

Thu Jul 11, 2019 9:14 pm

PeterO wrote:
Tue Jul 02, 2019 7:20 pm
I have same issue, but I find just turning everything (Pi + monitors) on at the same time produced a reliable boot.
RPT are aware of this issue.
PeterO
Latest updates have fixed this now.

PeterO
Discoverer of the PI2 XENON DEATH FLASH!
Interests: C,Python,PIC,Electronics,Ham Radio (G0DZB),1960s British Computers.
"The primary requirement (as we've always seen in your examples) is that the code is readable. " Dougie Lawson

GiacomoV
Posts: 1
Joined: Wed Jul 24, 2019 5:45 am

Re: Pi 4 not booting

Wed Jul 24, 2019 6:01 am

tshot wrote:
Thu Jun 27, 2019 3:04 pm
Heya all!
First off , sorry for my english, not my main leguage :oops:

I just recived the Pi4 (4gb), tried to install NOOBS on a sd card (Transcend 256gb) formated on FAT32 but Pi4 does nothing, tried to unplug all usbs, the sd card, even the video but same results. Allways the gree and red leds are ON, no flicker, they are just allways ON
Also tried to install last raspbian buster with etcher, but same results, leds allways on, no flicker and video signal

Any ideas?
As of today, I've the same problem with Pi4 4GB, original power supply and original micro HDMI cable. Tried on different screens. Green and red leds are both on. On boot the green one flashes, the red one is alway still.
I used:
- Samsung microSD (32GB) https://www.amazon.it/gp/product/B06XFS ... UTF8&psc=1
- Both the latest Noobs Lite https://www.raspberrypi.org/downloads/noobs/ on FAT 32 formatted SD and latest Raspbian Buster Lite burned with Etcher (MAC version)
Pi4 does not boot and my screen is saying "No signal" yet. Tried to unplug all usbs, powered off, removed SD, rebooted Pi4 with no SD, powered off again and finally rebooted with SD. The result is always the same.
Any help, please.
Thank you in advance

jullrey
Posts: 2
Joined: Sun Jul 28, 2019 7:22 pm

Re: Pi 4 not booting

Sun Jul 28, 2019 7:29 pm

I had a similar problem with my brand new Raspberry Pi 4 today. I had to edit the /boot/config.txt file on my MicroSD card using my PC and un-comment the following line near the bottom of the file:

config_hdmi_boost=4

This fixed my problem, the screen worked when I booted up the next time.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12125
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Pi 4 not booting

Sun Jul 28, 2019 9:01 pm

The boot problem sticky https://www.raspberrypi.org/forums/view ... 28&t=58151 now also has a RPI4 specific section.

Piflyer
Posts: 8
Joined: Sat Aug 10, 2019 1:08 pm

Re: Pi 4 not booting

Mon Aug 12, 2019 11:29 pm

Okay, so I was able to solve it by doing a workaround. If anyone experienced anything like me, here is how to get it working. First, download Raspbain Lite. I used the one released in June, and that seems to work. For some reason, you can't use the regular distro, or it will not fully boot. Next, update the pi, and install raspberrypi-ui-mods. After rebooting, you should be greeted by a login page. I think there is a bug with the regular Buster release. Hope this helps.
RPi0W RPi0 RPi3B RPi3B+ RPi3A+ RPi4B4G

IrishTwins2
Posts: 17
Joined: Sat Aug 17, 2019 11:56 am

Re: Pi 4 not booting

Sat Aug 17, 2019 1:30 pm

Are you able to post the link to the June version! I am having similar problems and getting frustrated now!!

Also tried the July version of Raspbian lite. No change still one red flash and nothing else!

Return to “Troubleshooting”