Jonovich
Posts: 14
Joined: Tue May 05, 2015 11:31 am
Location: Sunny Rutland
Contact: Website

Pi4 - Buster failing to boot - Flashing Green lights

Wed Jun 26, 2019 9:14 pm

Hi folks,

Is anyone else having any problems getting the Pi4 to boot? Mine worked twice in about twenty attempts - both times getting as far as doing the first reboot, then just a four flashing green LED cycle. I've tried multiple images (Full and Light), multiple downloads, multiple cards (32Gb/4Gb), tried both HDMI ports. Taken the cards out and popped them into a PiZero and they boot just fine.

I've raised a return ticket with PiHut to get my Pi4 board swapped out - but wondered if this something more than just a one off?

I've already tried re-flashing the EEPROM - no joy at all - still just the four flash response. No sign of the Pi4 going to the 'rapid flash' indicating a successful reflash.

King regards,

Jono

chrislongden
Posts: 3
Joined: Wed Jun 26, 2019 11:05 pm

Re: Pi4 - Buster failing to boot - Flashing Green lights

Wed Jun 26, 2019 11:10 pm

I'm having the same issue. Got the PI4, 2GB version. NOOBs card, USB power supply and an HDMI cable from the pi hut.

Booted fine the other day and has been shutdown correctly. Now it just will not boot at all. I've lost count of the time I've flashed various images (desktop with recommended, desktop only, lite) I even tried the NOOBs files again on to the SD cardt. The activity light flashes a few times then goes out with the odd flash now and again or its just off.

I've seen the 4 raspberries before now and also the rainbow splash screen but that just sat there a while and then there is no HDMI signal and just a steady red light on the Pi.

Is this something that can be fixed or would I need to organise a replacement from The Pi Hut?


Jonovich
Posts: 14
Joined: Tue May 05, 2015 11:31 am
Location: Sunny Rutland
Contact: Website

Re: Pi4 - Buster failing to boot - Flashing Green lights

Thu Jun 27, 2019 5:46 am

Already tried the suggestions on that very extensive and thorough link thanks, but still no closer to getting it to boot again.

Powering it up results in one of several outcomes, which is leading me to believe faulty hardware: -

Most attempts result in solid red and flashing green LEDs, no video.
A few result in just red LED, no video, but if left for a few minutes results in large coloured square on screen.
On just two occasions i’ve booted into Buster and been able to complete the startup questions, but after the subsequent reboot i’m back at the flashing green LEDs

I’ve never been able to boot into Buster lite at all.

I’ve tried the EEPROM re flash from the link and no joy. FAT formatted 4gb SD card with the two bin files copied to it. The Pi4 simply does the usual Solid Red and four flashing green. No sign of the ‘fast flashing green’ indication the process has worked.

Jono

chrislongden
Posts: 3
Joined: Wed Jun 26, 2019 11:05 pm

Re: Pi4 - Buster failing to boot - Flashing Green lights

Thu Jun 27, 2019 8:59 am

Jono, have you tried plugging in your display to the HDMI 0 port next to the power. I thought mine wasn't working, it just turned out the Pi wasn't detecting/outputing via HDMI 1 on the board.

Jonovich
Posts: 14
Joined: Tue May 05, 2015 11:31 am
Location: Sunny Rutland
Contact: Website

Re: Pi4 - Buster failing to boot - Flashing Green lights

Thu Jun 27, 2019 10:35 am

Thanks, yes, I was using that HDMI port anyway, but have tried both.

Kind regards

Jono

User avatar
RaTTuS
Posts: 10458
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: Pi4 - Buster failing to boot - Flashing Green lights

Thu Jun 27, 2019 11:18 am

what PSU are you using ?
try a raspbian lite , and no hdmi plugged in at all just do a headless install
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

Jonovich
Posts: 14
Joined: Tue May 05, 2015 11:31 am
Location: Sunny Rutland
Contact: Website

Re: Pi4 - Buster failing to boot - Flashing Green lights

Thu Jun 27, 2019 1:20 pm

I’ve tried both lite and full Buster, multiple downloads of each, both direct and via Torrent. On four different sdhc cards, no joy other than a couple of successful boots on the full buster, which then results in a fail after the first post config reboot.

If it wasn’t for the occasional successful boots, I’d consider the card slot to be faulty...

Jono
Last edited by Jonovich on Thu Jun 27, 2019 1:24 pm, edited 1 time in total.

Jonovich
Posts: 14
Joined: Tue May 05, 2015 11:31 am
Location: Sunny Rutland
Contact: Website

Re: Pi4 - Buster failing to boot - Flashing Green lights

Thu Jun 27, 2019 1:22 pm

Will a none Buster release of Raspbian work on Pi4? It’s the only thing I haven’t tried.

Jono

fruitoftheloom
Posts: 20694
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Pi4 - Buster failing to boot - Flashing Green lights

Thu Jun 27, 2019 1:32 pm

Jonovich wrote:
Thu Jun 27, 2019 1:22 pm
Will a none Buster release of Raspbian work on Pi4? It’s the only thing I haven’t tried.

Jono

Only Raspbian Buster release have the required kernel / firmware to support the RPi 4B. There is no need to backport to Stretch as Buster runs on ALL models of Pi & CM.


Hopefully developers of other Operating Systems will release compatible versions.



May I ask how you are creating the bootable SD Card ?

I always use plain Raspbian and use Etcher software to create a bootable SD Card.

NoobS only used once and never ever again !
Retired disgracefully.....

Jonovich
Posts: 14
Joined: Tue May 05, 2015 11:31 am
Location: Sunny Rutland
Contact: Website

Re: Pi4 - Buster failing to boot - Flashing Green lights

Thu Jun 27, 2019 1:43 pm

Thanks FotL, so I’m not sure what to do next?

I am using Etcher on a Win 10 machine to build the cards.

To answer RaTTus suggestion I’m already running a new Pi4 genuine PSU and tried booting headless, but still get the flashing green LED.

If other folks are not seeing this, it must be a faulty unit... still waiting to hear back from PiHut about a swap out. Have ordered a second from the Pirates of the North to compare against.

Very frustrating 🙁

Jono

fruitoftheloom
Posts: 20694
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Pi4 - Buster failing to boot - Flashing Green lights

Thu Jun 27, 2019 1:53 pm

Jonovich wrote:
Thu Jun 27, 2019 1:43 pm
Thanks FotL, so I’m not sure what to do next?

I am using Etcher on a Win 10 machine to build the cards.

To answer RaTTus suggestion I’m already running a new Pi4 genuine PSU and tried booting headless, but still get the flashing green LED.

If other folks are not seeing this, it must be a faulty unit... still waiting to hear back from PiHut about a swap out. Have ordered a second from the Pirates of the North to compare against.

Very frustrating 🙁

Jono

If you are using the built in SD Card Reader, try a USB SDHC Card Reader, my last one was from Poundland.
Retired disgracefully.....

User avatar
RaTTuS
Posts: 10458
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: Pi4 - Buster failing to boot - Flashing Green lights

Thu Jun 27, 2019 2:49 pm

does sound like a faulty unit to me
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23646
Joined: Sat Jul 30, 2011 7:41 pm

Re: Pi4 - Buster failing to boot - Flashing Green lights

Thu Jun 27, 2019 3:12 pm

Jonovich wrote:
Thu Jun 27, 2019 1:43 pm
Thanks FotL, so I’m not sure what to do next?

I am using Etcher on a Win 10 machine to build the cards.

To answer RaTTus suggestion I’m already running a new Pi4 genuine PSU and tried booting headless, but still get the flashing green LED.

If other folks are not seeing this, it must be a faulty unit... still waiting to hear back from PiHut about a swap out. Have ordered a second from the Pirates of the North to compare against.

Very frustrating 🙁

Jono
Sounds like you have tried everything. So might well be a dodgy unit. They all go through tough production line tests, but can fail after that in rare cases.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
"My grief counseller just died, luckily, he was so good, I didn't care."

Jonovich
Posts: 14
Joined: Tue May 05, 2015 11:31 am
Location: Sunny Rutland
Contact: Website

Re: Pi4 - Buster failing to boot - Flashing Green lights

Thu Jun 27, 2019 6:40 pm

PiHut have arranged to get this one swapped out for me, but I have ordered a second and will wait until I've got that one so I have a second unit to compare against, just in case there is some weird thing I'm not doing right.

Last attempt on this one for the moment is a Noobs build of card - just writing it now and will see how that works.

Thanks for all your help though guys - appreciate your input!

Jono

aleks93ts
Posts: 2
Joined: Thu Jun 27, 2019 7:05 pm

Re: Pi4 - Buster failing to boot - Flashing Green lights

Thu Jun 27, 2019 7:07 pm

I have the same problem. No way to boot it...

Sjurdur
Posts: 2
Joined: Thu Jun 27, 2019 7:54 am

Re: Pi4 - Buster failing to boot - Flashing Green lights

Fri Jun 28, 2019 12:24 am

I also had issues with the NOOBs card (preinstalled Buster) I got with the Pi4b. It wouldn't boot properly, stuck in rainbow screen, no hdmi found etc. Eventually I managed to get into the desktop after several reboots and changing hdmi hotplug setting in the boot config file.

Then I tried a fresh installation of Buster on a SanDisk Extreme Pro sd card and everything worked from the very first boot. I haven't tried a fresh installation on the NOOBS card so I cant say if its the card or the preinstallation which has some issues.

Jonovich
Posts: 14
Joined: Tue May 05, 2015 11:31 am
Location: Sunny Rutland
Contact: Website

Re: Pi4 - Buster failing to boot - Flashing Green lights

Fri Jun 28, 2019 5:26 am

My final attempt with Noobs also failed. Never used Noobs before, so learnt it was just a format and copy process, but still just flashing green LEDs on the Pi4 and no video.

Pulled the card and plopped it in a Pi0 and it booted right up, so this Pi4 is headed back by courier today. I’m not even going to wait for the 2nd Pi4 to compare with.

Jono

ZeroExperience
Posts: 1
Joined: Fri Jun 28, 2019 7:50 am

Re: Pi4 - Buster failing to boot - Flashing Green lights

Fri Jun 28, 2019 8:01 am

This helped me out, i'm new here. First post is to say thank you for sharing this for Raspberry Pi 4 Troubleshooting. :thumbs_up:

aleks93ts
Posts: 2
Joined: Thu Jun 27, 2019 7:05 pm

Re: Pi4 - Buster failing to boot - Flashing Green lights

Fri Jun 28, 2019 8:30 pm

Jonovich wrote:
Fri Jun 28, 2019 5:26 am
My final attempt with Noobs also failed. Never used Noobs before, so learnt it was just a format and copy process, but still just flashing green LEDs on the Pi4 and no video.

Pulled the card and plopped it in a Pi0 and it booted right up, so this Pi4 is headed back by courier today. I’m not even going to wait for the 2nd Pi4 to compare with.

Jono
Try this. it worked for me:

-Insert the SD card on your PC
-Go to device manager - Disk management
-Delete all partitions from your SD
- Create a new partition (3 or 3.5GB) with FAT32 file system
-Once done just extract the NOOB zip files into SD card and try to boot it on your Pi

SteveF_Plano
Posts: 8
Joined: Mon Jul 01, 2019 8:54 pm

Re: Pi4 - Buster failing to boot - Flashing Green lights

Tue Jul 02, 2019 1:34 am

I have the same problem and have tried everything suggested re this topic. Card works fine on a 3, but 4 will not boot.

Jonovich
Posts: 14
Joined: Tue May 05, 2015 11:31 am
Location: Sunny Rutland
Contact: Website

Re: Pi4 - Buster failing to boot - Flashing Green lights

Tue Jul 02, 2019 6:30 pm

Oh happy days!

The second Pi4 I purchased has arrived and is working fine - booted several times in a row and the only flashing the green light is doing is related to storage I/O. Now to see what this thing can do!

Thanks for all your help and suggestions folks!

Jono

Jonovich
Posts: 14
Joined: Tue May 05, 2015 11:31 am
Location: Sunny Rutland
Contact: Website

Re: Pi4 - Buster failing to boot - Flashing Green lights

Thu Jul 11, 2019 1:43 pm

Just to complete my story, I got home last night to find the swap out Pi4 for the returned one waiting for me on the doormat. It powered up and worked first time!

Definitely sounds like there were some iffy ones in the distribution channel, despite having been tested prior to despatch. Maybe the test process needs amending to pick out these ones in some way?

Kind regards one and all,

Jon.

Return to “Troubleshooting”