beemurt
Posts: 16
Joined: Fri May 24, 2019 4:27 pm

RPi3B+ Cant connect to internet

Fri Jun 21, 2019 2:51 pm

Good Afternoon All

I have been happily using my pi for a few months with no major issues.
Its connected to an ethernet cable. Wifi can be a bit patchy.

When I turned the Pi on this morning the time and date where wrong. I corrected this and indeed it may be an urealated issue. However now i cannot connect to the internet at all. I get a ERR_NAME_RESOLUTION_FAILED error from chromium

wpa_cli status shows that:
wpa_state=DISCONNECTED

Ping 8.8.8.8 shows
From 169.254.212.189 icmp_seq=59 Destination Host Unreachable

Wifi usually works, but as mentioned is a bit sketchy. Currently wlan0 is Not Associated.

Running wpa_cli -i wlan0 returns : failed to initiate sched scan CTRL-EVENT-NETWORK-NOT-FOUND

I havent changed any settings apart fro the date time and Wifi country. (Wifi country is correct this isnt the issue)

If anyone is able to assist it would be greatly appreciated I have spent hours trying to fix this and cant seem to get to the bottom of what is going on!

Many Thanks B

User avatar
B.Goode
Posts: 10356
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: RPi3B+ Cant connect to internet

Fri Jun 21, 2019 3:55 pm

I have been happily using my pi for a few months with no major issues.
Its connected to an ethernet cable.

Is the other end of that Ethernet cable connected to an active local area network?

If so, most of your other wlan-related troubleshooting may not be relevant, since by default - with Raspbian - a cabled connection will take precedence.

Could it be your local network infrastructure, not your RPi, that has failed? If relevant, have you rebooted your home ISP router?

beemurt
Posts: 16
Joined: Fri May 24, 2019 4:27 pm

Re: RPi3B+ Cant connect to internet

Fri Jun 21, 2019 4:10 pm

Hi b.Goode,

Thanks for the reply. There are no issues with the network, everything else is running as it should. I have tried restarting the router (a few times) but it didnt help.

The ethernet is connect to a range extender plug (it always has been and it has had no problems), plug seems to be working as normal. Three blue lights showing connection, i have my phone connected to the plug (though wifi) and no issues.

Thanks B

User avatar
HawaiianPi
Posts: 5856
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: RPi3B+ Cant connect to internet

Fri Jun 21, 2019 4:26 pm

Incorrect time and date is normal when the Pi has been off. There is no real time clock onboard, but the Pi will sync time and date shortly after connecting to the Internet (yours didn't because it's not connected). However, setting it manually should not affect connectivity. ¯\_(ツ)_/¯

Try flashing a fresh image to another micro SD card or USB flash drive and test with that (USB booting is enabled by default on the 3B+). If connectivity works as expected on a fresh install, then something may have gotten corrupted on your old card. Note that USB booting is slower than SD card booting and nothing will seem to happen at first (after 10 seconds or so it should start to boot).
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

beemurt
Posts: 16
Joined: Fri May 24, 2019 4:27 pm

Re: RPi3B+ Cant connect to internet

Fri Jun 21, 2019 7:27 pm

Good evening HawaiianPi

I think i have fixed this issue, but not found out what caused it.

I set up a static address for the eth0 in the dhcpcd file. I am almost certain I didn’t need this before but it appears to be working. I also unplugged my range extender plug and moved it to a different socket further away from my Pi/Components (I have a few RF Transmitter boards, but they cant be interfering with the plug...can they?)

Anyway, it appears to be working now...although i am almost afraid to say that. Fingers crossed. Just added the below to the dhcpcd file using:

sudo nano /etc/dhcpcd.conf

added my own ip addresses in

interface eth0
static ip_address= XXX
static routers=XXX
static domain_name_servers=XXX

It’s good to hear the time/date etc cant affect the rest of the settings on my Pi as i really was beginning to think that was causing the issue. As again I am almost certain i didn’t need the above in the dhcpcd file before? Also no idea if the RF transmitters would interfere with the range extender (even though they have been beside each other for weeks) Weird!

Thank you everyone for your help

Return to “Troubleshooting”