JOCPi
Posts: 3
Joined: Tue Jun 11, 2019 10:06 am

Windows explorer can no longer see my Pi shared drive

Tue Jun 11, 2019 10:27 am

I have built a Plex server from a Pi. It was all working in every respect. It was connected via Cat 5 directly to my home network BT router, I could VNC into it from a windows PC and I could browse my shared folders in Windows Network and add files directly to them.

Then I decided to upgrade my network

Now the BT Router is connected to the telephone/internet wall socket (this bit not changed) - wireless turned off
The BT router is connected via cat 5 cable to a Netgear R9000 Nighthawk which has 'cloned' the details of the BT router so things like network names and passwords have not changed. The R9000 is broadcasting wireless and taking cable connections to the home network
Everything else, including the Pi is now connected to the R9000 - the Pi is connected via an Ethernet cable

All the shares still exist and the Samba file still looks OK on the Pi. Interestingly I can still VNC into the Pi, but I needed to connect it to a new IP address - once done this has been OK and I can browse files on the Pi using the VNC link and see the Seagate media drive and all it's files that is attached to the Pi. Plex can also still see these files and the Plex side of things is working well.

However, I cannot see or appear able to connect to the shares in Windows explorer. The Pi is not even showing as connected to the network as something that could potentially be connected to. I've tried every combination of share names and passwords I can think of, but I cannot find it. I can only assume that I need to reset/change something related to an IP address (like I needed to change on the VNC link), but I am a Pi Novice and would sure appreciate some commands that I might need to feed the Pi and where to input them. Any help would be much appreciated

Ernst
Posts: 1141
Joined: Sat Feb 04, 2017 9:39 am
Location: Germany

Re: Windows explorer can no longer see my Pi shared drive

Tue Jun 11, 2019 12:37 pm

JOCPi wrote:
Tue Jun 11, 2019 10:27 am
I have built a Plex server from a Pi. It was all working in every respect. It was connected via Cat 5 directly to my home network BT router, I could VNC into it from a windows PC and I could browse my shared folders in Windows Network and add files directly to them.

Then I decided to upgrade my network

Now the BT Router is connected to the telephone/internet wall socket (this bit not changed) - wireless turned off
The BT router is connected via cat 5 cable to a Netgear R9000 Nighthawk which has 'cloned' the details of the BT router so things like network names and passwords have not changed. The R9000 is broadcasting wireless and taking cable connections to the home network
Everything else, including the Pi is now connected to the R9000 - the Pi is connected via an Ethernet cable

All the shares still exist and the Samba file still looks OK on the Pi. Interestingly I can still VNC into the Pi, but I needed to connect it to a new IP address - once done this has been OK and I can browse files on the Pi using the VNC link and see the Seagate media drive and all it's files that is attached to the Pi. Plex can also still see these files and the Plex side of things is working well.

However, I cannot see or appear able to connect to the shares in Windows explorer. The Pi is not even showing as connected to the network as something that could potentially be connected to. I've tried every combination of share names and passwords I can think of, but I cannot find it. I can only assume that I need to reset/change something related to an IP address (like I needed to change on the VNC link), but I am a Pi Novice and would sure appreciate some commands that I might need to feed the Pi and where to input them. Any help would be much appreciated
First: your problem is not related to the use of the Raspberry Pi, you have a problem in your network and this where you should look. The manual for your NetGear R9000 is only a bit over 150 pages, this is too much to do remote support and analysis because we do not know what you have done.

Second: what makes me suspicious is that you said "but I needed to connect it to a new IP address" and "Now the BT Router is connected to the telephone/internet wall socket (this bit not changed)" which could mean that you have two dhcp services active, you may have two networks active, maybe dual firewalls. This is something we can not analyze because it means that we need to have complete information on both your routers and that exceeds the purpose of this forum.

Very likely your Pi is doing well, it is the surroundings that need some attention.
The road to insanity is paved with static ip addresses

JOCPi
Posts: 3
Joined: Tue Jun 11, 2019 10:06 am

Re: Windows explorer can no longer see my Pi shared drive

Tue Jun 11, 2019 1:17 pm

Thanks for the response. I am a bit of a novice when it comes to networks and all the acronyms (like DHCP) too, but when I installed the R9000 I had some 'tame help' who knew rather more about such things than I did. However, they did say that my system set itself up differently to when they had previously done a similar exercise with their own system which was on Virgin cable.

However, perhaps if I put down what I understand happened with the setup (which might not be 100% what went on - I'm no expert) it might help

When I just had the The BT router it issued IP addresses that started 192.xx.xx.x none of these were 'static' to my knowledge and it just used to assign the next in the sequence to the next item that connected. This is still the case - if I was to plug something directly into that router it would just assing a 192 etc. IP address

We installed the R9000 and as part of its setup it wanted to know the network name and password that the BT router used. On being given that it 'cloned' (is the best term I can think of) these settings. We then switched off wireless broadcast on the BT router and anything that was picking up the wireless network just seemed to start talking via the R9000. If I log onto the BT router I can see the R9000 as a sole ethernet connection connected to a 192.19x.xx.x IP address.

As far as I know the IP address range issued by the R9000 was set by the 'tame help' to assign IP addresses in the 10.x.x.xx range. I can log onto the R9000 and see the pi attached as an Ethernet connection and it has been assigned an IP in the 10.x.x.xx range, I don't think this is a static address though and if it was disconnected and reattached I think there is a possibility that a different IP address within that range could be assigned. However, for the moment it is staying hooked to a fairly constant location and so far the VNC to that IP address has picked it up each time I've opened it.

If it's any help in terms of clues - to get the Plex server as installed on the Pi available on the new setup (it didn't initially work) I did play with the BT router. I believe what I accomplished was to assign a specific port number as instructed by plex to the BT router and this seemed to immediately solve the access issues to the media held on the Seagate drive attached to the pi (which is attached to the R9000).

Ernst
Posts: 1141
Joined: Sat Feb 04, 2017 9:39 am
Location: Germany

Re: Windows explorer can no longer see my Pi shared drive

Tue Jun 11, 2019 2:18 pm

From your description you have a cascaded natted router configuration with the Netgear acting as an WiFi extender.
The BT router has a dhcp service using the address range 192.168.x.x (most likely 192.168.1.x or so), the Netgear connects over WiFi with the BT router and has a DHCP server using the address range 10.x.x.x (most likely 10.0.0.x). DHCP means that there is a service that will supply the clients with an IP address and some more parameters. What you have is much too complex.
After looking at the fat documentation I get the impression that the Netgear is not the most ideal solution for your situation.

What I would suggest is that you disable NAT filtering on the Netgear:
NAT filtering because "Network Address Translation (NAT) determines how the router processes inbound
traffic. Secured NAT protects computers on the LAN from attacks from the Internet but might prevent
some Internet games, point-to-point applications, or multimedia applications from working. Open
NAT provides a much less secured firewall but allows almost all Internet applications to work."

There is not much that we can do because the problem is very particular to your configuration.
The road to insanity is paved with static ip addresses

JOCPi
Posts: 3
Joined: Tue Jun 11, 2019 10:06 am

Re: Windows explorer can no longer see my Pi shared drive

Tue Jun 11, 2019 2:51 pm

Hello Ernst, well at least what I put appears to have provided sufficient explanation. You mention the Netgear is acting as a WiFi extender - that is a good and clever spot as that is exactly what it was purchased to provide - I live in a three storey house without Ethernet cabling and the BT router alone was struggling to get WiFi to the top floor - the R9000 reaches it without issue.

However, the new set-up does appear to have mixed up the Pi set-up, still at least your assessment means that I am not going crazy since you indicate that it isn't the Pi at fault, therefore nothing I can do will likely fix it. My 'tame help' will re-appear in a few weeks time, maybe they will be able to do something with the network addresses which will help.

Many thanks for taking the trouble to read and reply to me.

hortimech
Posts: 266
Joined: Wed Apr 08, 2015 5:52 pm

Re: Windows explorer can no longer see my Pi shared drive

Tue Jun 11, 2019 4:34 pm

I think your problem is the setup you have chosen, your BT router will probably be a homehub, This is a combined router and modem, in its present setup it should now just be setup as modem with everything else turned off (wifi, dhcp etc)
One would be to make your netgear router into just an Access point, turn off wifi on the homehub and turn off everything but wifi & firewall on the netgear.
Your final option would be to buy an openreach modem and replace the homehub with this.

Return to “Troubleshooting”