AirLink 101 AWLL6075 USB adapter issues

9 posts
by glennhuff » Fri Nov 30, 2012 12:19 am
I have the subject adapter plugged into a powered USB hub on the latest raspian imagecat. I have previously successfully connected to the internet via my wlan using another adapter in the same hub, so I believe my wireless settings are correct for the SSID and password. With the other adapter I see it request an IP and one is assigned. On this adapter, I see the MAC address for the adapter displayed.

With the AWLL6075, i see the following in the dmesg output:
[ 4.739757] hub 1-1.3.4:1.0: 4 ports detected
[ 5.033337] usb 1- new high-speed USB device number 8 using dwc_otg
[ 5.146125] usb 1- New USB device found, idVendor=0bda, idProduct=8172
[ 5.160728] usb 1- New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 5.175761] usb 1- Product: RTL8191S WLAN Adapter
[ 5.188518] usb 1- Manufacturer: Manufacturer Realtek
[ 5.201571] usb 1- SerialNumber: 00e04c000001
[ 5.822055] udevd[137]: starting version 175
[ 7.658405] r8712u: module is from the staging directory, the quality is unknown, you have been warned.
[ 8.296447] r8712u: DriverVersion: v7_0.20100831
[ 8.437784] r8712u: register rtl8712_netdev_ops to netdev_ops
[ 8.576780] r8712u: USB_SPEED_HIGH with 4 endpoints
[ 8.712943] r8712u: Boot from EFUSE: Autoload OK
[ 9.055538] r8712u: CustomerID = 0x0000
[ 9.066921] r8712u: MAC Address from efuse = 00:e0:4c:72:00:01
[ 9.080174] r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
[ 9.096250] usbcore: registered new interface driver r8712u

Running iwlist wlan0 scan produces a valid enumeration of the access points available, so the driver can receive data from the adapter. However, executing sudo ifup wlano produces:
Listening on LPF/wlan0/ff:ff:ff:ff:ff:ff
Sending on LPF/wlan0/ff:ff:ff:ff:ff:ff
Sending on Socket/fallback
DHCPDISCOVER on wlan0 tp poet 67 interval 5
DHCPDISCOVER on wlan0 tp poet 67 interval 2
No DHCPOFFERS received.
Unable to obtain a lease on first try. Exiting.
Failed to bring up wlan0.

With the adapter that worked, the MAC address of the adapter appeared in the Listening and Sending lines and the DHCP server assigned an IP address

Any idea what the issue might be with this adapter and how I might fix it?
Posts: 4
Joined: Thu Nov 29, 2012 12:47 am
by eix » Sat Dec 01, 2012 3:24 pm
I have exactly the same issue, and my wifi dongle is an RTL8191S WLAN Adapter.

Did you manage to solve this issue?

I think it's due to the new kernel because I did not have this problem a month ago
User avatar
Posts: 82
Joined: Sat Sep 15, 2012 8:09 am
by eix » Sun Dec 02, 2012 2:49 pm
Apparently, this is related to

Do you also have errors on ethernet?
Can you measure the voltage to detect if the device is underpowered?
User avatar
Posts: 82
Joined: Sat Sep 15, 2012 8:09 am
by eix » Sun Dec 02, 2012 2:57 pm
I have just put the RaspberryPi on its own power source, not from the Sitecom hub and the wifi dongle has correct MAC address.

So note: when the power is not enough for the wifi dongle, it will not fail but set its mac to FF:FF:FF:FF:FF:FF

User avatar
Posts: 82
Joined: Sat Sep 15, 2012 8:09 am
by glennhuff » Sun Dec 02, 2012 5:55 pm
I do not have errors on eth0, and have not resolved the issue. Some additional info on my configuration might be useful. I have a Kennsingston powered USB 7 port hub which powers the Pi and has the USB input connected to the Pi. The keyboard, mouse and the power connector for the Pi are on one 4 port hub (ID 05e3:0608 Genesys Loigic, Inc. USB-.0 4-Port HUB), and the wlan adapter is on the second 4 port hub (same ID info). The power for the hub has a rated output of 5 volts @ 2.5 amps so I would not anticipate a power issue. The Pi is running in Turbo mode.
Posts: 4
Joined: Thu Nov 29, 2012 12:47 am
by glennhuff » Sun Dec 02, 2012 10:05 pm
I went back to standard clocks and put the Pi on a separate 1 amp supply, but that has no effect in my case. The adapter address still shows a ff:ff:ff:ff:ff:ff. I'm glad that fixed it for you, though.
Posts: 4
Joined: Thu Nov 29, 2012 12:47 am
by eix » Mon Dec 03, 2012 10:02 pm
Thanks for replying, this is interesting.

Did you try all ports of the 7-ports hub? That identified a pattern for me.

Also what happens if you plug only the wifi dongle to the RPI and nothing else? I have tried that and it works for me also in that way.
User avatar
Posts: 82
Joined: Sat Sep 15, 2012 8:09 am
by glennhuff » Mon Dec 03, 2012 11:47 pm
Wonder of wonders, moving the AWLL6975 to a port on the first USB hub (within the 7 port hub) made the MAC address show up correctly and connected to my router using the SSID/Key info correctly. That first hub also has the keyboard and mouse.

I reconfigured turbo mode and changed the cabling so the Pi is also powered off one of the ports on the second 4 port hub (within the 7 port hub) and rebooted successfully. The downlink via the wlan0 measures about 2.3 Mbps, which is about the same as the eth0 interface.

Given that this makes the adapter work, I suppose that the second 4 port hub could be connected off the 4th port on the first 4 port hub within the 7 port hub) and somehow there is an issue connecting via the downstream hub. I have a USB memory stick on that second 4 port hub that seems to work fine, so the issue would seem to be specific to the wlan USB adapter. It's interesting to note that another wlan adapter worked fine off the second hub within the 7 port hub.

I did try the wlan adapter in the Pi USB port. My unit has the poly fuses, so I didn't expect there to be adequate power on the Pi's USB port. However, the wlan adapter worked OK in the Pi USB slot. USB on the Pi seems to be quite the puzzle. Thanks for your suggestions.
Posts: 4
Joined: Thu Nov 29, 2012 12:47 am
by eix » Wed Dec 05, 2012 7:07 am
Very glad to know that scientific method still works around here :D

I suppose that those ports have not enough voltage for the drain of WLAN adapters, but do not have a multimeter to test it.

Thanks for trying!

User avatar
Posts: 82
Joined: Sat Sep 15, 2012 8:09 am