dudewheresmycode
Posts: 16
Joined: Thu Aug 16, 2012 5:28 am

External USB Hard Disk

Wed Nov 28, 2012 2:21 am

Im having issues with keeping an external USB hard disk mounted.

Got my pi, started playing and decided to go out and buy a 3TB external HD to connect to my pi. The hard drive is self powered and I'm connecting that to a powered USB hub and then into one of the pi's USB ports.

Using the pi, I created a new partition and reformatted the drive using mkfs.ext3.

The drive mounts (takes FOREVER) and I can read/write files to the drive. But after some inactivity, I come back to the pi and get I/O errors when I try to access the drive. I then need to umount and re-mount the drive.

What could be causing this disconnect? I'm trying to rule out power because the drive is self powered by it's own PSU and it's also being connected to a 2.0 A usb hub before the pi. The pi itself has its own 1.0 A power supply (phone charger).

Anyone have any ideas?

ToxicMed
Posts: 11
Joined: Tue Nov 20, 2012 11:46 pm

Re: External USB Hard Disk

Wed Nov 28, 2012 3:25 am

Ive just been doing a search myself about powered USB hubs, found that some don't work nicely with the Rpi. check and see if yours is on the list of Known working Hubs. It may be the hub your using isn't properly compatible. http://elinux.org/RPi_VerifiedPeriphera ... d_USB_Hubs

dudewheresmycode
Posts: 16
Joined: Thu Aug 16, 2012 5:28 am

Re: External USB Hard Disk

Wed Nov 28, 2012 8:20 pm

I don't think it's the USB hub. I get the same issues with the hard disk connectivity regardless of whether it's plugged in to the powered usb hub or directly into the pi.

Also I'm using a Belkin 4-port desktop hub (F4U040). Listed as "working" here: http://elinux.org/RPi_VerifiedPeripherals

Return to “Troubleshooting”