m4dm4n
Posts: 4
Joined: Thu May 09, 2019 10:06 am

Connection to Rpi 3B+ WiFi stops responding

Thu May 09, 2019 10:25 am

Symptoms : After some random time (hour, hours, day), I can't ssh or ping to Rpi anymore.

Solutions : Reboot. Yeah, this works until next unresponsive state.
Ping FROM Rpi to home gateway or another PC activates WiFi, and this works also for some random time until it again become unresponsive.


I have lurked many places on the Internet and tried the solutions:

1. Buy better power adapter --

Tried 1A,2A, 3A, and now BlitzWolf 4A adapter. Behaviour is always the same.

2. Use some CheckWifi.sh script --

This script pings default gateway and if it fails, it reboots or reloads wifi interface (depends on the version of the scripts on the internet). This does not work, since Rpi does not have a output ping problem.
Interestingly, when script pings, it does not solve unresponsive state to Rpi. Maybe i should try to use more than 4 ping packets. Even so, I don't like this "solution".

3. Turn wifi power save state off --


Done it with, iwconfig, iw, /etc/network/interface, /etc/rc.local. Does nothing.
Someone stated that Rpi doesn't even have WiFi power state idle mode, that this is useless, since it is already disabled in kernel driver. Whatever.

4. Use different versions of Raspbian Stretch images --

Doesn't work.


I didn't try rpi-update, since it says you should do it only if you exactly know why. Should I try it?

Please, provide some other solutions, so I can try them, I will edit this post and give the report it it works or not.

fruitoftheloom
Posts: 19569
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Connection to Rpi 3B+ WiFi stops responding

Thu May 09, 2019 12:30 pm

m4dm4n wrote:
Thu May 09, 2019 10:25 am
Symptoms : After some random time (hour, hours, day), I can't ssh or ping to Rpi anymore.

Solutions : Reboot. Yeah, this works until next unresponsive state.
Ping FROM Rpi to home gateway or another PC activates WiFi, and this works also for some random time until it again become unresponsive.


I have lurked many places on the Internet and tried the solutions:

1. Buy better power adapter --

Tried 1A,2A, 3A, and now BlitzWolf 4A adapter. Behaviour is always the same.

2. Use some CheckWifi.sh script --

This script pings default gateway and if it fails, it reboots or reloads wifi interface (depends on the version of the scripts on the internet). This does not work, since Rpi does not have a output ping problem.
Interestingly, when script pings, it does not solve unresponsive state to Rpi. Maybe i should try to use more than 4 ping packets. Even so, I don't like this "solution".

3. Turn wifi power save state off --


Done it with, iwconfig, iw, /etc/network/interface, /etc/rc.local. Does nothing.
Someone stated that Rpi doesn't even have WiFi power state idle mode, that this is useless, since it is already disabled in kernel driver. Whatever.

4. Use different versions of Raspbian Stretch images --

Doesn't work.


I didn't try rpi-update, since it says you should do it only if you exactly know why. Should I try it?

Please, provide some other solutions, so I can try them, I will edit this post and give the report it it works or not.

Regards Power you need a Power Supply not a Charger, the Official Power Supply has proven itself time and again !
adieu

My other Computer is an Asus CS10 ChromeBit running Chrome Operating System.
HP Envy 4500 Wireless Printer supported by HPLIP software in Raspbian Buster.
Raspberry Pi Model 2B v1.1

m4dm4n
Posts: 4
Joined: Thu May 09, 2019 10:06 am

Re: Connection to Rpi 3B+ WiFi stops responding

Thu May 09, 2019 12:57 pm

I really don't think this is the issue, we are talking about a quality charger.

Image

B.Goode
Posts: 7757
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: Connection to Rpi 3B+ WiFi stops responding

Thu May 09, 2019 1:44 pm

Could this be a symptom of your router expiring the DHCP lease on the IP address it has assigned to the RPi, and thus rendering it incommunicado?

Seems to fit with the RPi still running and the connection being reinstated by a ping.

m4dm4n
Posts: 4
Joined: Thu May 09, 2019 10:06 am

Re: Connection to Rpi 3B+ WiFi stops responding

Thu May 09, 2019 1:51 pm

Lease is 7 days, I can see leased address in router as active, so no problem on that side.

I don't know why,how or how to troubleshoot, but somehow I think it's in the power management side of the Rpi. I think something powers down the wifi/network/dhcpd or anything network based, and when I manually activate it, it powers up.

m4dm4n
Posts: 4
Joined: Thu May 09, 2019 10:06 am

Re: Connection to Rpi 3B+ WiFi stops responding

Wed May 22, 2019 9:03 pm

EDIT: Nope, Rpi stopped responding to other devices on this night. Only thing that makes it discoverable is that I have to ping those devices FROM my Rpi. And that is NOT a solution.

Ok, I would like to answer myself, maybe this will help others with similar issues. I changed the power supply, bought the original one and the problem didn't go away. I continued to diagnose the issue, and found out:

1. When i ping the Rpi from my PC, it doesn't time out, only says that destination is unreachable, which was very odd. Then I left it to ping indefinitely.

2. While my PC was trying to ping, i moved to Rpi, and then tried to ping my PC. First packet was lost, but the others went through. And at that same time, pings from my PC to Rpi also started to get replies. Even more odd, I thought.

Next day, when Rpi stopped responding again, using Wireshark , I saw on my PC that ARP requests are not getting their replies, so the ICMP packet can't be assembled.

I really thought that it was some kind of power_save issue on Rpi, but I tried a lot of things on that part (different locations to turn that power_save mode, although everyone says that it was already off, different types of scripts, nothing was stable).

Then I went to look on different options in my home router. And in WMM (Wi-Fi Multimedia) category , I found some Power_Save option (official name (APSD or Automatic Power Save Delivery), so I disabled it. 24 hours later, so far , so good, Rpi is still responsive.

I will give it a week for another testing. I got ESP32 that is sleeping for 2 hours, then it gets its job done, send some data to MQTT broker on Rpi, and now after over 30 hours (16 reboots to be exact), it had some problems, until i pinged my ESP32 from Rpi. So there is still something there, but the situation is getting more and more stable.

Return to “Troubleshooting”