dudewheresmycode
Posts: 16
Joined: Thu Aug 16, 2012 5:28 am

External Hard Drive / sleeping

Tue Nov 27, 2012 12:59 am

I'm having an issue with my 3TB external hard drive disconnecting from the pi when not in use. Here's the scenario. Everything works fine, I can:

- Turn on my pi and mount the external hard drive using the 'mount' command.
- Download files to the hard drive with no issues.
- Watch videos off the hard drive with no issues.

I can use the hard drive with no issues for hours. However, if I leave or let the pi go inactive for more then, say, 30 min or so, the hard drive disconnects from the mount point and I get I/O errors accross the board and then have to umount and re-mount the disk to use it. Usually the disk has re-connected to a different path.

Code: Select all

/dev/sda1  to   /dev/sdb1
At first I thought it was power issues. But the drive itself has it's own power adapter and I'm plugging the USB drive into a powered USB hub to first then into the pi. There are no other USB devices connected.

Is this caused by the pi or the drive itself going into a "sleep" mode or something?

SherridanSB
Posts: 1
Joined: Sun Nov 11, 2012 12:18 pm

Re: External Hard Drive / sleeping

Thu Nov 29, 2012 9:52 pm

i also habe Problems since some Time. my external harddrives refuse going into standby, i even cant remove Them safely, they emidiately reconnect. either this Problem occurs since rc5 Or since The mount point in rc4 changed . hope there will soon be a solution.

Arnlen
Posts: 1
Joined: Thu Jan 22, 2015 2:52 pm

Re: External Hard Drive / sleeping

Thu Jan 22, 2015 2:56 pm

Up!
I also encount this kind of problem: my USB hard drive (self powered) is unavailable after few minutes if I'm not using it.

It looks indeed like a sort of "auto sleep" mode.

Any news?

Return to “Troubleshooting”