User avatar
FreezeTile
Posts: 34
Joined: Thu Apr 05, 2018 6:39 pm
Location: Scotland

Pi 3B+ won't load Google-owned websites

Tue Apr 30, 2019 7:34 pm

So my Pi 3B+ has been working fine for about half a year, but recently I decided to check for updates.
There were 159 updates available, so I downlloaded them all. One of the updates was for Chromium.
Now, whenever I try to go to a Google-owned site like Google or YouTube, I get this error.

This site can’t be reached
youtube.com unexpectedly closed the connection.

Try:
Checking the connection
Checking the proxy and the firewall

ERR_CONNECTION_CLOSED

Sites not owned by Google, like eBay or raspberrypi.org, work fine with no issues.

I've even tried formatting the entire boot disk and installing a completely fresh install of Raspbian, but I still get the exact same error.

Somebody please help me, I'm at my wit's end with this...
Attachments
2019-04-30-201825_1234x714_scrot.png
2019-04-30-201825_1234x714_scrot.png (118.27 KiB) Viewed 253 times

User avatar
DougieLawson
Posts: 35340
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Pi 3B+ won't load Google-owned websites

Tue Apr 30, 2019 7:38 pm

Get the results from the following commands:

ip addr
ip route
ping -c3 $(ip route | awk '/default/ {print $3}')
ping -c3 8.8.8.8
ping -c3 google.com
cat /etc/resolv.conf
for i in $(awk '/nameserver/ {print $2}' /etc/resolv.conf); do ping -c3 $i; done
Note: Having anything remotely humorous in your signature is completely banned on this forum.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
FreezeTile
Posts: 34
Joined: Thu Apr 05, 2018 6:39 pm
Location: Scotland

Re: Pi 3B+ won't load Google-owned websites

Tue Apr 30, 2019 7:44 pm

[email protected]:~ $ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether b8:27:eb:3c:18:78 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether b8:27:eb:69:4d:2d brd ff:ff:ff:ff:ff:ff
inet 192.168.1.24/24 brd 192.168.1.255 scope global wlan0
valid_lft forever preferred_lft forever
inet6 fd84:be52:228:c900:e150:f24f:b90:9b2f/64 scope global mngtmpaddr noprefixroute dynamic
valid_lft 7019sec preferred_lft 3419sec
inet6 fe80::fa9e:55d8:e84b:276f/64 scope link
valid_lft forever preferred_lft forever
[email protected]:~ $ ip route
default via 192.168.1.1 dev wlan0 src 192.168.1.24 metric 303
192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.24 metric 303
[email protected]:~ $ ping -c3 $(ip route | awk '/default/ {print $3}')
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=2.10 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=1.49 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=1.46 ms

--- 192.168.1.1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 1.461/1.688/2.108/0.297 ms
[email protected]:~ $ ping -c3 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=121 time=17.1 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=121 time=17.6 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=121 time=19.4 ms

--- 8.8.8.8 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 17.187/18.086/19.454/0.989 ms
[email protected]:~ $ ping -c3 google.com
PING google.com (216.58.206.78) 56(84) bytes of data.
64 bytes from lhr35s11-in-f14.1e100.net (216.58.206.78): icmp_seq=1 ttl=54 time=20.2 ms
64 bytes from lhr35s11-in-f14.1e100.net (216.58.206.78): icmp_seq=2 ttl=54 time=17.9 ms
64 bytes from lhr35s11-in-f14.1e100.net (216.58.206.78): icmp_seq=3 ttl=54 time=17.6 ms

--- google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 17.655/18.614/20.207/1.134 ms
[email protected]:~ $ cat /etc/resolv.conf
# Generated by resolvconf
domain lan
nameserver 192.168.1.1
nameserver fe80::1%wlan0
[email protected]:~ $ for i in $(awk '/nameserver/ {print $2}' /etc/resolv.conf); do ping -c3 $i; done

User avatar
DougieLawson
Posts: 35340
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Pi 3B+ won't load Google-owned websites

Tue Apr 30, 2019 7:49 pm

You missed the enter key on the last command (don't worry). But your network is OK. So the problem must be with cached data from Chromium or broken Chromium profile settings.

EDIT: I'd delete everything in ~/.cache/Chromium, logout from the desktop, log back in and retry it.
Note: Having anything remotely humorous in your signature is completely banned on this forum.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
FreezeTile
Posts: 34
Joined: Thu Apr 05, 2018 6:39 pm
Location: Scotland

Re: Pi 3B+ won't load Google-owned websites

Tue Apr 30, 2019 7:56 pm

How do I find /.cache/Chromium? Thanks!

User avatar
DougieLawson
Posts: 35340
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Pi 3B+ won't load Google-owned websites

Tue Apr 30, 2019 7:58 pm

That funky little tilde (~) at the front of what I posted means /home/pi/... . So it's /home/pi/.cache/Chromium.
Note: Having anything remotely humorous in your signature is completely banned on this forum.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
Joel_Mckay
Posts: 288
Joined: Mon Nov 12, 2012 10:22 pm
Contact: Website

Re: Pi 3B+ won't load Google-owned websites

Wed May 01, 2019 6:27 am

If your device has a max time adjust forwards limit in NTP, and was left off too long... than SSL issues can occur.
Try running:
date
sudo service ntp stop
sudo ntpdate -s us.pool.ntp.org
sudo ntpd -gq
sudo service ntp start
sudo ntpdate -u time.nist.gov
date

Then reboot the machine to retry your SSL link... let me know if it helps... ;-)

Cheers,
J

User avatar
DougieLawson
Posts: 35340
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Pi 3B+ won't load Google-owned websites

Wed May 01, 2019 6:40 am

Joel_Mckay wrote:
Wed May 01, 2019 6:27 am
If your device has a max time adjust forwards limit in NTP, and was left off too long... than SSL issues can occur.
Try running:
date
sudo service ntp stop
sudo ntpdate -s us.pool.ntp.org
sudo ntpd -gq
sudo service ntp start
sudo ntpdate -u time.nist.gov
date

Then reboot the machine to retry your SSL link... let me know if it helps... ;-)

Cheers,
J
All of that will fail 100%.

There's no NTP installed in Raspbian by default. Time sync is done with systemd-timedatectl. Even with ntp added after there's no ntpdate any longer (replaced with ntpd -q -g).
Note: Having anything remotely humorous in your signature is completely banned on this forum.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
Joel_Mckay
Posts: 288
Joined: Mon Nov 12, 2012 10:22 pm
Contact: Website

Re: Pi 3B+ won't load Google-owned websites

Wed May 01, 2019 6:49 am

DougieLawson wrote:
Wed May 01, 2019 6:40 am
All of that will fail 100%.

There's no NTP installed in Raspbian by default. Time sync is done with systemd-timedatectl. Even with ntp added after there's no ntpdate any longer (replaced with ntpd -q -g).
And yes, 2 of the above lines will likely not work (20% fail to be exact)... depending on the image age and version.
If Stretch, has someone verified the output to check set-ntp state?
timedatectl

then tried this:
sudo timedatectl set-time "2019-05-01 01:00:00"
;-)

Return to “Troubleshooting”