jimjamz
Posts: 39
Joined: Sun Feb 09, 2014 12:37 am

invalid/unknown driver 'rtl8192cu' - in hostapd

Tue Apr 16, 2019 10:44 am

Re-asking this quuestion as it appears to still be a relevant issue.

None of the latest Debian distributions include a driver that resolves this issue. On the contrary, most GitHub patches that are made to build and compile ancient versions of hostapd with a specific realtek driver seem outdated:

https://jenssegers.com/43/Realtek-RTL81 ... spberry-Pi

I'm still receiving the same error as in the past when configuring to use this driver in hostapd.

As it has been incorrectly pointed out, hostapd cannot successfully run when omitting the 'driver' parameter, as it complains that the rtl8192cu-based device (in my case, the Edimax EW-7811Un N150 USB Wi-Fi adapter) is not AP capable:

Code: Select all

wlx14ca267ffa0f: AP-DISABLED 
which is not correct, as `iw list` tells me different:

Code: Select all

software interface modes (can always be added):
		 * AP/VLAN
		 * monitor

Return to “Troubleshooting”