marmoset49
Posts: 1
Joined: Sun Mar 31, 2019 1:21 pm

Can't connect to Raspberry Pi Zero W over USB SSH

Sun Mar 31, 2019 1:34 pm

I'm trying to login to my Raspberry Pi Zero W via SSH over USB, as in this article https://desertbot.io/blog/ssh-into-pi-zero-over-usb and this one https://www.thepolyglotdeveloper.com/20 ... cable-ssh/. Explicitly, I've:
  • Flashed the image to my SD card (I'm using the November 2018 Raspbian Stretch Lite image. I've also tried using a Raspbian Jessie image as per the articles.)
  • Created an empty file called ssh in the boot directory
  • Added dtoverlay=dwc2 to the bottom of the config.txt file in the boot directory
  • Added modules-load=dwc2,g_ether directly after rootwait in the cmdline.txt file in the boot directory
I've plugged a HDMI cable into the Pi and it's booting correctly to the login prompt. However, if I try and ping raspberrypi.local from my Macbook, I get no response (the exact message is "ping: cannot resolve raspberrypi.local: Unknown host"). Trying to SSH in fails as well (it just hangs). Intuitively, I feel this is a host name resolution problem on my Macbook's side, but I can't figure out how to fix it.

Having googled MacOS .local resolution problems, a commonly found issue is that these addresses are only resolved if some form of sharing has been enabled (for instance, file sharing). I've tried enabling this and it has not resolved my problem.

Has anyone else experienced this? Any help would be very much appreciated!

Return to “Troubleshooting”