Texangeek
Posts: 8
Joined: Tue Aug 28, 2018 11:57 pm

Docker Install for Raspian Stretch

Mon Mar 25, 2019 5:22 pm

So I spent a fair amount of time yesterday trying (unsuccessfully) to get Docker installed and running on my Pi Zero.

I started out by updating the existing install to the latest version of Stretch (sudo apt-get update, etc.) and this worked successfully. However I ran into errors when installing Docker. Eventually I decided to give up with the updated install and I burned a completely fresh version of Stretch onto the SD card and booted the Pi with this.

After quite a while reading various different posts I discovered that there appears to be an issue with the latest Docker release (https://github.com/moby/moby/issues/38175). There were a couple of posts providing potential workarounds, essentially reverting to an older version of docker available. I can confirm that the steps described in this post (https://abelperezmartinez.blogspot.com/ ... retch.html) seem to allow Docker to be installed and run successfully (see output below).

Code: Select all

[email protected]:~ $ systemctl status docker.service
● docker.service - Docker Application Container Engine
   Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2019-03-25 06:05:06 CDT; 6h ago
     Docs: https://docs.docker.com
 Main PID: 342 (dockerd)
      CPU: 8min 29.680s
   CGroup: /system.slice/docker.service
           ├─ 342 /usr/bin/dockerd -H fd://
           └─1073 docker-containerd --config /var/run/docker/containerd/containerd.toml
Hopefully this post may help others to get moving with Docker on their Pi Zero a little quicker than I managed to!

Return to “Troubleshooting”