tay22
Posts: 1
Joined: Sun Mar 24, 2019 10:17 am

I2S mems microphone (SPH0645LM4H) installation issue : __sanitizer_cov_trace_pc

Sun Mar 24, 2019 10:33 am

Hello,

When trying to install the Adafruit I2S MEMS Microphone (SPH0645LM4H) on a raspberry pi 3 b+ with the latest raspbian distribution (stretch) following :

https://learn.adafruit.com/adafruit-i2s ... g-and-test

I had a lot of problems.

The issues of the adafruit tutorial starts from the section "Download kernel source & compile"

Indeed the "rpi-source --skip-gcc" ouputs a lot of errors !

I solved most of them using :

# apt-get install build-essential
# apt-get install bison
# apt-get install flex
# apt-get install libssl-dev

But !!

At the step of compiling the I2S module proposed in the tutorial (written by Paul Creaser)
I had this warning about "__sanitizer_cov_trace_pc" :

pi:~/rpi-i2s-audio# make -C /lib/modules/$(uname -r )/build M=$(pwd) modules
make: Entering directory '/root/linux-5b12bd4c8cc5043a24fe2aaec09d4ded0e8d56d4'
Building modules, stage 2.
MODPOST 1 modules
WARNING: "__sanitizer_cov_trace_pc" [/root/rpi-i2s-audio/my_loader.ko] undefined!
make: Leaving directory '/root/linux-5b12bd4c8cc5043a24fe2aaec09d4ded0e8d56d4'


and when trying to run the module it fails with "Unknown symbol in module":

pi:~/rpi-i2s-audio# sudo insmod my_loader.ko
insmod: ERROR: could not insert module my_loader.ko: Unknown symbol in module


pi:~/rpi-i2s-audio# dmesg | tail
....
[ 67.839324] my_loader: loading out-of-tree module taints kernel.
[ 67.839637] my_loader: Unknown symbol __sanitizer_cov_trace_pc (err -2)
...

I guess, I have to modify something in the ~/rpi-i2s-audio/my_loader.c and compile it again [with make -C /lib/modules/$(uname -r )/build M=$(pwd) modules]. but what to modify ?

Any help please ?

brandoncheah
Posts: 28
Joined: Thu Sep 27, 2018 9:52 am

Re: I2S mems microphone (SPH0645LM4H) installation issue : __sanitizer_cov_trace_pc

Tue Jul 02, 2019 3:32 am

Hi, I have also the same issue during (make -C /lib/modules/$(uname -r )/build M=$(pwd) modules) step:
WARNING "__sanitizer_cov_trace_pc" [/home/pi/rpi-i2s-audio/my_loader.ko] undefined!

Anybody know what's going on?

Alberto82
Posts: 1
Joined: Tue Sep 24, 2019 9:23 am

Re: I2S mems microphone (SPH0645LM4H) installation issue : __sanitizer_cov_trace_pc

Tue Sep 24, 2019 9:48 am

Hi.

I had the same issue too. Actually, I've solved the problem!
I've done the following steps.

1. First of all I've removed all the files related with "rpi-i2s-audio".

2. Then I've removed all the old kernel modules in order to have only the latest ones.
The folder is /lib/modules and use the command ls -a to see all the modules inside.
My latest ones are 4.19.73+ and 4.19.73-v7+
Reboot.

3. Then follow the Adafruit guide (https://learn.adafruit.com/adafruit-i2s ... g-and-test),
skipping the updating part of the board, that is the first part of the Kernel Compiling section. The point is you already have the latest useful version.

4. In following the next steps, the most important procedure is to accept the default opition when the script pauses.
So just press Enter!
"If the script pauses at this prompt:
Code coverage for fuzzing (KCOV) [N/y/?] (NEW)
Just press enter to accept the default and continue."

5. Follow the steps until the end and everythings will be fine!

Hope it helps!


Alberto

Return to “Troubleshooting”