Vanfanel
Posts: 436
Joined: Sat Aug 18, 2012 5:58 pm

Waking up HDMI audio at boot

Mon Mar 11, 2019 1:26 pm

Hi there!

I have noticed that adding these to config.txt, I no longer have the lost 1-2 seconds of audio when an audio playback begins:

Code: Select all

config_hdmi_boos=4
force_hdmi_open=1
However, I am still missing these 1-2 seconds for the FIRST audio playback on the system when I reboot.
Is there config.txt command to FORCE HDMI audio init on boot?

thanks!!

Andyroo

Re: Waking up HDMI audio at boot

Tue Mar 12, 2019 1:00 pm

There is a option in raspi-config under advanced options that can set audio to HDMI or jack (options 7/4)

Not sure if that will help or not (come to that it maybe what you have already done :oops: )

Vanfanel
Posts: 436
Joined: Sat Aug 18, 2012 5:58 pm

Re: Waking up HDMI audio at boot

Wed Mar 13, 2019 3:22 am

Andyroo wrote:
Tue Mar 12, 2019 1:00 pm
There is a option in raspi-config under advanced options that can set audio to HDMI or jack (options 7/4)

Not sure if that will help or not (come to that it maybe what you have already done :oops: )
Thanks for trying to help me, but that answer has nothing to do with what I'm trying to get here. I have HDMI audio working, I just need it to be initialized automatically.

Return to “Troubleshooting”