Posts: 1
Joined: Sat Feb 16, 2019 12:04 pm

Cant get simple Raspi Picture frame to work using fbi or fim

Mon Feb 18, 2019 5:38 pm

simpe task i thought: make a little shell skript that displays a slideshow of a couple pics on a monitor and play some sound.

i made a skript called wash.sh (because the frame is for a laundry shop), made it executable and put a link to it in the rc.local file

the command fbi works fine by itself, works very well. but with my rc.local method at startup it says
"ioctl VT_GETSTATE: Inappropriate ioctl for device (not a linux console?)"

the user pi is member of the video group, yes. by itself it works very well. and i tried giving fbi the parameter -d /dev/fb0

then i tried fim, which i thought would be similar and replaced the fbi command by fim, with a parameter for slideshow.
aannnd .. it works!! but for some unbelivable reason the program seems to be unable to display the pictures sorted by name, it even starts with the highest name!!

so then i did something stupid, i had the rc.local script with "&" behind the command to run the wash skript and now my raspi wont boot and to press q, to exit fim doesnt work anymore.

whats the deal with all that stuff here and how can i get this seemingly easy project to work?

oh and ideally id like to have an mp3 or multiple played.

so in summary: raspi zero without gui via hdmi to screen with speakers. usb stick with photos and mp3s. raspi boots, makes slideshow in alphabetical/numerical order and plays music files in shuffle :)

:) help!

Return to “Troubleshooting”