User avatar
marcosbong
Posts: 23
Joined: Mon Dec 31, 2018 7:08 pm

Strange issue with main menu language

Mon Dec 31, 2018 7:34 pm

Hello Everybody.
First of all, take on account Iḿ a newbie.
Im having a hard time with the main menu language, and I cant find a solution searching for internet.
I installed Os in Spanish.
playing around, I changed my system language generating my locale files with raspi-config for es & en lang both UTF-8.
Them I modified my /etc/default/locale to set lang to English.
When I booted up, I got a main manu mixed language, so I modified again my /etc/default/locale to show this:

# File generated by update-locale
LANG=es_ES.UTF-8
LANGUAGE=es_ES.UTF-8
LC_ALL=es_ES.UTF-8

But "logout" & "Run" commands remain in English
I tried a lot of things searching for a solution ( I cant remember most of them ) but I look some xsession config files, openbox config, and lxpanel too, but no succeed.
I reset lxpanel from bash and no changes

The extrange thing is that if I change the menu icon from lxpanel settings I get my main menu Into spanish, but after reboot it remains in english.

Im lost with this issue. I dont have enough skills yet to track it.

Im running Raspbian Stretch and LXDE on na Raspberry pi 2B
this is my locale config

pi@raspberrypi:~ $ locale
LANG=es_ES.UTF-8
LANGUAGE=es_ES.UTF-8
LC_CTYPE="es_ES.UTF-8"
LC_NUMERIC="es_ES.UTF-8"
LC_TIME="es_ES.UTF-8"
LC_COLLATE="es_ES.UTF-8"
LC_MONETARY="es_ES.UTF-8"
LC_MESSAGES="es_ES.UTF-8"
LC_PAPER="es_ES.UTF-8"
LC_NAME="es_ES.UTF-8"
LC_ADDRESS="es_ES.UTF-8"
LC_TELEPHONE="es_ES.UTF-8"
LC_MEASUREMENT="es_ES.UTF-8"
LC_IDENTIFICATION="es_ES.UTF-8"
LC_ALL=es_ES.UTF-8
pi@raspberrypi:~ $



Any help would be much apreciated
there are 10 types of people in this world, those who understand binary and those who don´t

User avatar
Joel_Mckay
Posts: 295
Joined: Mon Nov 12, 2012 10:22 pm
Contact: Website

Re: Strange issue with main menu language

Mon Dec 31, 2018 11:07 pm

1. Open terminal with Crtl+t

2. Type:
sudo dpkg-reconfigure locales

3. Reboot system

Cheers,
J

User avatar
marcosbong
Posts: 23
Joined: Mon Dec 31, 2018 7:08 pm

Re: Strange issue with main menu language

Wed Jan 02, 2019 10:58 am

Thanks Joel, but this was done and doesn't work. Just tried again and same issue
Everithing is in spanish, but not the two mencioned items.
It must be some kind of config from lxde, because I tested xfce and this is not happening in that enviroment
there are 10 types of people in this world, those who understand binary and those who don´t

User avatar
Joel_Mckay
Posts: 295
Joined: Mon Nov 12, 2012 10:22 pm
Contact: Website

Re: Strange issue with main menu language

Wed Jan 02, 2019 3:18 pm

You may have to look for the *.desktop files for the lxpanel configuration.
https://unix.stackexchange.com/question ... cli#177839

Sometimes the label strings need changed for a specific language translation and sent to the debian package maintainer/developers.
Find the icon file with the label you need to translate:
grep -lir 'reboot' /var/lib/menu-xdg/applications/menu-xdg/*
grep -lir 'reboot' /usr/share/applications/*
grep -lir 'reboot' ~/.config/lxpanel/*


You should see something similar to the following entries in the launcher if it is a *.desktop icon config file:
[Desktop Entry]
Name=System Shutdown Dialog
Comment=Prompt the user to shutdown their computer
GenericName[es]=Cuadro de diálogo de apagado del sistema
Comment[es]=Indicar al usuario que apague su computadora


If this looks funny, keep in in mind it is the best google translate can offer today.
Also, some buzzwords simply don't translate very well into every language. Every open source project usually needs helpers to try and make the interfaces more accessible for everyone. If the program is not very popular, than this translation can be difficult. I also checked the MATE desktop menu, and was disappointed to see it too was the default generic En only (nano /usr/share/applications/mate-session-shutdown.desktop ) . ;-)

From the above URL "Finds and deletes cached menu items to ensure updates will appear."
find ~/.cache/menus -name '*' -type f -print0 | xargs -0 rm
sudo shutdown -r now



Best of luck,
J

User avatar
marcosbong
Posts: 23
Joined: Mon Dec 31, 2018 7:08 pm

Re: Strange issue with main menu language

Wed Jan 02, 2019 5:34 pm

Thanks man, but " *.desktop " files in " /usr/share/applications/ " seem to be correct. They are shown with Spanish text
What I want to change is the logout text shown in the foldable menu that appears when you press the raspberry icon, not the logout menu text
I have been digging a little and I think this issue i related to translated strings
When I installed Raspbian I choose Spanish lang and everything looked OK. ( logout button said "salir")
But after testing english lang and returning to spanish, now logout button says "logout" instead of "salir"
I dont know how to force this string to be translated into Spanish, but locale settings are correct. Im only using es_ES-UTF8.
I would post some screen captures for better description of the situation, but I dont know how to do it

Sorry for my bad English, perhaps Im not understanding your instructions
there are 10 types of people in this world, those who understand binary and those who don´t

User avatar
Joel_Mckay
Posts: 295
Joined: Mon Nov 12, 2012 10:22 pm
Contact: Website

Re: Strange issue with main menu language

Wed Jan 02, 2019 5:50 pm

Did you delete menu cache in local user directory?
Then reboot.

=)

User avatar
marcosbong
Posts: 23
Joined: Mon Dec 31, 2018 7:08 pm

Re: Strange issue with main menu language

Wed Jan 02, 2019 6:50 pm

find ~/.cache/menus -name '*' -type f -print0 | xargs -0 rm

says missing operand

and there is no " menus-name " folder in " ~/.cache/"
there are 10 types of people in this world, those who understand binary and those who don´t

User avatar
marcosbong
Posts: 23
Joined: Mon Dec 31, 2018 7:08 pm

Re: Strange issue with main menu language

Wed Jan 02, 2019 6:55 pm

Sorry for the mistake.
" menus " folder is empty
there are 10 types of people in this world, those who understand binary and those who don´t

User avatar
Joel_Mckay
Posts: 295
Joined: Mon Nov 12, 2012 10:22 pm
Contact: Website

Re: Strange issue with main menu language

Wed Jan 02, 2019 7:06 pm

Try reset of local menu config:
mv ~/.config/lxpanel ~/lxpanel_bak
sudo shutdown -r now


Usually screenshot capture is possible by pressing print screen button

User avatar
marcosbong
Posts: 23
Joined: Mon Dec 31, 2018 7:08 pm

Re: Strange issue with main menu language

Wed Jan 02, 2019 8:17 pm

Really close, but did the trick till next login. :shock:

I can take screenshoots, after installing scrot, but What Im not able to do is to add the picture to my replies.
says something like img http, url
Sorry, but i dont have enough experience using blog tools.
I come from windows, and basically all I needed till now was lurking :D
there are 10 types of people in this world, those who understand binary and those who don´t

Return to “Troubleshooting”