lindum
Posts: 39
Joined: Wed Apr 15, 2015 2:01 pm
Location: UK

A gap appears in the key strokes

Wed Dec 19, 2018 9:12 pm

I bought a RP 3 B the other day along with a 7in touchscreen and an enclosure for the two. I got everything working OK, but when I came to instal github I typed "sudo apt-get i nstall GitHub" and nothing happened because there is a gap in-between the i and the n.

Its the same on an earlier model b, I've used different keyboards and two different monitors, but it still types with the gap between those two letters.

I don't understand it as it hasn't happened in the past.

Has anyone else come across this phenomenon and is there a solution to it.

Thanks a lot.
Michael.

lindum
Posts: 39
Joined: Wed Apr 15, 2015 2:01 pm
Location: UK

Re: A gap appears in the key strokes

Wed Dec 19, 2018 9:35 pm

I just wanted to add to the last post that this bug only occurs in the terminal windows, as I've typed out several lines in Text Editor without any problems.
Michael.

User avatar
scruss
Posts: 2420
Joined: Sat Jun 09, 2012 12:25 pm
Location: Toronto, ON
Contact: Website

Re: A gap appears in the key strokes

Wed Dec 19, 2018 11:53 pm

have you set the local keyboard layout with the configuration options? Though I suspect this isn't the problem, Raspbian defaults to a UK keymap.

Are the different keyboards two from the same manufacturer?
‘Remember the Golden Rule of Selling: “Do not resort to violence.”’ — McGlashan.

rhubarbdog
Posts: 64
Joined: Mon Dec 11, 2017 9:58 pm

Re: A gap appears in the key strokes

Thu Dec 20, 2018 4:20 am

Press CTRL+ALT+F2
Login on that screen and try.
Remember to logout or exit to a login prompt.

Press CTRL+ALT+F7 to get your windows back

lindum
Posts: 39
Joined: Wed Apr 15, 2015 2:01 pm
Location: UK

Re: A gap appears in the key strokes

Thu Dec 20, 2018 10:55 am

Hi
Thanks for replying, all the keyboards are from different manufacturers and they all have the same problem. Now I can't even 'cut & paste' from the 'Text Editor'.

When I type text in the text editor it comes out OK, but as soon as I transfer it to the Terminal Window the gaps appear in the words again.

I tried typing in LibreOffice 5 without difficulty, there were no gaps between any of the words. And yet copying & pasting into the Terminal it results in the words braking up as before.

I typed two pages for a blog post in LibreOffice Writer and it came out perfectly (on both the RP2 and RP3 ) even though my keyboard wasn't in that list in the Preferences - Mouse and Keyboard Settings.

Its definitely the 'Terminal Window' that's at fought and I don't know how to rectify it.
Michael.

Return to “Troubleshooting”