User avatar
Cr4z33
Posts: 25
Joined: Fri Oct 12, 2018 3:30 pm

(HDMI) Very poor 1080p image quality!

Sat Dec 08, 2018 6:40 am

I need to run a Raspberry Pi 3 B+ at 1080p connected by HDMI, but both on a Samsung 4K monitor (U28E850R) and a Samsung 4K TV (UE55NU7170UXZT) the overall picture quality is very disappointing. :|
White colour looks almost light blue and the overall sharpness is very poor...

The same (hiqh quality/high speed) HDMI cable has been tested with other 1080p/2160p devices to be sure it is 100% OK so at this point I was wondering if I could do (perhaps in config.txt?) anything to improve overall image quality at 1080p?

This is my current config.txt:

Code: Select all

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
overscan_left=40
overscan_right=40
overscan_top=22
overscan_bottom=10

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=1
hdmi_mode=16

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on
[pi0]
dtoverlay=dwc2
[all]
start_x=1
gpu_mem=128
dtoverlay=googlevoicehat-soundcard


User avatar
Imperf3kt
Posts: 2968
Joined: Tue Jun 20, 2017 12:16 am
Location: Australia

Re: (HDMI) Very poor 1080p image quality!

Sun Dec 09, 2018 7:55 pm

Have you checked the settings on the monitor?
White looking blue would indicate you have it set to cool color.
55:55:44:44:4C
52:4C:52:42:41

DirkS
Posts: 10013
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: (HDMI) Very poor 1080p image quality!

Sun Dec 09, 2018 8:44 pm

And check the actual HDMI settings on the Pi with

Code: Select all

tvservice -s

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5194
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: (HDMI) Very poor 1080p image quality!

Sun Dec 09, 2018 11:31 pm

DirkS wrote:
Sun Dec 09, 2018 8:44 pm
And check the actual HDMI settings on the Pi with

Code: Select all

tvservice -s
+1
I also note that you appear to be forcing a display setting rather than letting the Pi detect a "best setting". There's nothing wrong in doing that, but usually only after you've used other tvservice commands to check what preferred or native options the display uses (and are detected by the Pi). FWIW, you may find these notes/examples of interest:
http://www.cpmspectrepi.uk/raspberry_pi ... tings.html
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, B2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, A+ and a B2) but Buster on the P4B's. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

Powy
Posts: 1
Joined: Mon Oct 07, 2019 1:24 am

Re: (HDMI) Very poor 1080p image quality!

Mon Oct 07, 2019 2:24 am

- I experienced the same and after a lot of googling I found out that it is the Samsung TV / monitor. You have to rename the HDMI channel to 'PC' by pressing

Menu button on Remote control > input > edit name

Watch this youtube video.


- Also, connect the Raspberry Pi to different HDMI ports on your Samsung TV, e.g. pick HDMI1/DVI and rename it to PC.

- Also, to fix the borders on a Samsung monitor press the Menu button on your remote control and set the following:
Menu > Picture > Screen Adjustment > Pick 16:9, or if that is not available choose Screen Fit.

- Not Samsung monitor related, but a setting for the Raspberry Pi:

Change the resolution via the command: sudo raspi-config
Go to: >Advanced Option > Resolution > just set your resolution compatible fit with your screen
(see also this youtube video).

- Finally, you can change the config file directly as follows.
Command in terminal: sudo nano /boot/config.txt

(You can use some other text editor beside 'nano', e.g. I installed 'gedit' via 'sudo apt-get install gedit', and then using "sudo gedit /boot/config.txt")

Then include / change lines to:
# HDMI auch ohne Monitor in Betrieb nehmen (optional)
hdmi_force_hotplug=1
# Audio über HDMI ausgeben (optional)
hdmi_drive=2
# DMT-Betriebsmodus aktivieren
hdmi_group=2
# Auflösung: 1920x1080 / 60 Hz (1080p)
hdmi_mode=82

See also this article.

Return to “Troubleshooting”