Page 1 of 1

Pi3A+ NOOBS no wifi

Posted: Fri Nov 30, 2018 11:25 am
by cg617
reposting in Troubleshooting (was under General)

Hi All,

I am the proud owner of a new Pi3A+, and got it up and running no problem. However within a few days (probably 2 hours of power up time) the wifi connection started failing.

Eventually hooked up leads (KM and HDMI) and found that ifconfig shows no wifi entry.

Went back to NOOBS v3.0.0 and found that the wifi icon is grey'ed out.

After much testing, frustration and googling, not to mention umpteen failed attempts to become a member of this forum, I am at a complete loss as to the problem.

The only thing I can suspect is a hardware failure. This appears to be confirmed by using a SD card I have in a Pi3B.
When booting with this SD Card in a Pi3B and holding the shift key, I get the NOOBS screen with wifi icon active (you can select it).
When booting the Pi3A+ with the same card, holding the shift key takes you to the NOOBS screen, but the wifi icon is NOT selectable.

I've seen loads of posts about this and that, amend various files and run various commands, but my thinking is that booting to the NOOBS screen fundamentally preempts any of that. :?

Can anyone help?

Re: Pi3A+ NOOBS no wifi

Posted: Fri Nov 30, 2018 11:48 am
by code_exec
If you're using the full NOOBS, you already get the latest version of Raspbian as of the NOOBS version release date. If you're using NOOBS Lite, you'll need an internet connection to install any OS. If you're having issues with NOOBS Lite, you should try full NOOBS since that already has Raspbian installed.

Re: Pi3A+ NOOBS no wifi

Posted: Fri Nov 30, 2018 1:52 pm
by cg617
Yes, using the full NOOBS.
I has already run NOOBS and installed the latest version of Raspbian. Wifi at that time was working fine.
If I let the Pi boot normally, it boots into Rasbian, but an 'ifconfig -a' only shows 'lo' (Pi3A+ doesn't have ethernet).
If I plug a wifi dongle in, it recognises that and connects over wifi.

After the initial build (using NOOBS), I ran the apt-get update and probably the apt-get upgrade soon after build.
It was somewhere around this point that the onboard wifi failed.

My problem is that the wifi isn't recognised by the NOOBS gui (press shift on boot). But on a Pi3B, this same step (same SD card) does show wifi in the NOOBS gui.

Therefore I don't think it's the software build, but either hardware or firmware....

Re: Pi3A+ NOOBS no wifi

Posted: Fri Nov 30, 2018 3:42 pm
by jamesh
Moved similar thread here, so locking this one.