pmlockett1
Posts: 1
Joined: Mon Oct 15, 2018 2:21 pm

Still won't boot

Mon Oct 15, 2018 2:32 pm

This is my first post and I apologize if I am not following proper etiquette/protocol. I now own 5 raspberry pi's. 3 version 2's and now I own 2 Pi3 B v1.2. I just updated to stretch this week. I downloaded fresh NOOBS files (v2.9) and put them on SD cards. Stretch is working just fine on my pi2's but did not work on my pi3 b v1.2. The boot process is getting stuck at the rainbow screen on the pi3. There is not a lightning bolt or any other icon at the top right. I have tried multiple psu including an official pi3 psu. Red light is solid, green light (ACT light) flashes 2 or 3 times, goes solid, then turns off. I switched the sd cards between the pi's and isolated it to being an issue with the pi3. I decided to purchase another pi3, thinking I had a bad connection on the pi3 sd card holder. The new pi3 is doing the exact same thing. I have tried editing the bootconfig.txt to add a delay which did not help. I'm in the process of downloading other OS'es to see if something else will work. I would like to use stretch though. If anyone has any direction that may assist me I would greatly appreciate it. Let me know if I need to clarify any of my issues or specs. Thank you.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 4612
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: Still won't boot

Mon Oct 15, 2018 3:55 pm

pmlockett1 wrote:
Mon Oct 15, 2018 2:32 pm
This is my first post and I apologize if I am not following proper etiquette/protocol. I now own 5 raspberry pi's. 3 version 2's and now I own 2 Pi3 B v1.2. I just updated to stretch this week. I downloaded fresh NOOBS files (v2.9) and put them on SD cards. Stretch is working just fine on my pi2's but did not work on my pi3 b v1.2. The boot process is getting stuck at the rainbow screen on the pi3. There is not a lightning bolt or any other icon at the top right. I have tried multiple psu including an official pi3 psu. Red light is solid, green light (ACT light) flashes 2 or 3 times, goes solid, then turns off. I switched the sd cards between the pi's and isolated it to being an issue with the pi3. I decided to purchase another pi3, thinking I had a bad connection on the pi3 sd card holder. The new pi3 is doing the exact same thing. I have tried editing the bootconfig.txt to add a delay which did not help. I'm in the process of downloading other OS'es to see if something else will work. I would like to use stretch though. If anyone has any direction that may assist me I would greatly appreciate it. Let me know if I need to clarify any of my issues or specs. Thank you.
Just to clarify, are you certain that your (newer) Pi is a P3B** and not a P3B+****? How did you write the NOOBS files (with what hardware) to the uSDHC card? (eg. USB card reader/writer or a built-in card slot). Which "official" Pi3 PSU (ie. the RPF white/black one or one supplied with a kit)?
Have you tried/Can you try not using NOOBS (since you appear to only need Raspbian Stretch) and use the direct image writing method****** instead?
Trev.
** http://www.cpmspectrepi.uk/raspberry_pi ... lPi3B.html
**** http://www.cpmspectrepi.uk/raspberry_pi ... Bplus.html
****** https://www.raspberrypi.org/documentati ... /README.md and also, FWIW, here's an old, Jessie, example of how to use a Pi to write an image: http://www.cpmspectrepi.uk/raspberry_pi ... lPi3B.html (Just download, checksum and write the current Stretch image instead)
Still running Raspbian Jessie on some older Pi's (an A, B1, B2, B+, P2B, 3xP0, P0W) but Stretch on my P3B+, P3B, B+, A+ and a B2. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

Return to “Troubleshooting”