Posts: 19
Joined: Tue Oct 02, 2018 8:24 pm

[Solved] VNC Service mode Freeze when Virtual one don't.

Tue Oct 02, 2018 8:38 pm

Title say anythings about the problem, i'm running on an raspberry pi 3B+ on RPD desktop ON raspberry Stretch (cause my connection is also stretch (DL in 4G cause i would take forever to do it on my satellite one) and my phone's memory too lel) with all the stuff (xinit, xorg, lightdm, ...) with this tutorial : ... 6&t=133691

i've also installed few programs on my raspberry like midori, sysbench, ...

I wanted to start using my raspberry on my phone using vnc cloud connection, i had a lot of trouble finding how to actually run vnc in service mode, however, when i start the first vnc's connection after a boot/reboot, the screen freeze after 5-10s and after re-connection, the screen become black. putty is fine, i've already saw this case in other topic, but didn't find a real answer to solve this problem, that the third hour that i'm trying to solve this, but it's not working as intended.

PS: the pi work well in virtual mode, but as i said, i need service mode.

If some of you could help me, it would be awesome.
Last edited by Gess1t on Sat Oct 06, 2018 5:49 pm, edited 1 time in total.

Posts: 19
Joined: Tue Oct 02, 2018 8:24 pm

Re: [Solved] VNC Service mode Freeze when Virtual one don't.

Sat Oct 06, 2018 5:48 pm

I Finally Solved it by re-flashing raspian Strech (lite) into the sd cards and start a brand new installation of the desktop environment, with these step from the tutorial : ... 6&t=133691

(for those who don't know, DO NOT USE this command during the installation :

Code: Select all

sudo apt-get install --no-install-recommends raspberrypi-ui-mods lxsession
Because of this command i had to reflash the OS 2 times.

Do not install any other VNC software on the pi, when you finished the installation of the OS / desktop environment, type :

Code: Select all

sudo apt-get install realvnc-vnc-server realvnc-vnc-viewer
If you install any other VNC software, uninstall them, and if it's still not working after you done it, then, one of the solution is re-flashing your OS ^^
then after the installation of real vnc server is done just reboot, and this one, go type :

Code: Select all

sudo raspi-config
then go to interfacing option> VNC > and finally enable it, reboot after enabling it.
Finally to connect to your raspberry in service mode, just type your raspberry local ip like :

Code: Select all
(replace the Xs to the actual raspberry ip of course)
and there you go! you're normally in service mode ! so you can connect your vnc to use cloud !
(don't judge me, i got terrible pains downloading the updates with my 32 kb/s connection)

As always, i always have to fix everything by myself.

Return to “Troubleshooting”