sora03
Posts: 192
Joined: Mon Dec 29, 2014 4:11 pm
Contact: Website

RPi internal usb hub not working

Sun Sep 02, 2018 8:10 am

Hi, I am having problems with my RPi 2B v1.1 the SMSC/lan9512 chip? Internal USB Hub is not working at all, error when booting:

Code: Select all

new high speed usb device number 2 using dwc_otg
indeed it is in host mode hprt0 00001101 
usb 1-1: device descriptor read/64, error -71 
...
another usb device number 3 ...
...
descriptor read error for 3x
...
attemp for power cycle
...
waiting for root device on /dev/sda1...
it is powered by MP1584 5V 3A DC buck converter, prior to this, all GPIO port are broken using the gpio test from wiringPi. the usb micro cable is from the official Pi PSU so no problems with that.
I cannot boot the pi since the root device is on a external HDD.

what is the expected lifetime of an RPi? I've only used mine for 1.5Years
FLOSS enthusiast, Debian user (linux-libre)

epoch1970
Posts: 3333
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: RPi internal usb hub not working

Sun Sep 02, 2018 2:20 pm

According to your previous posts the GPIO is fried on your Pi, it is possible the USB took a hit as well...
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

LTolledo
Posts: 1644
Joined: Sat Mar 17, 2018 7:29 am

Re: RPi internal usb hub not working

Sun Sep 02, 2018 2:34 pm

my very first and oldest pi is more about 2 years, its a Raspberry Pi 3 model B bought as a kit set. its the most abused RPi3B that I have. It still runs perfectly fine.

I may (and happy to) conceede the longest time to the veterans in this forum.
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

User avatar
rpdom
Posts: 14705
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: RPi internal usb hub not working

Sun Sep 02, 2018 2:40 pm

Expected lifetime is 20-30 years.

sora03
Posts: 192
Joined: Mon Dec 29, 2014 4:11 pm
Contact: Website

Re: RPi internal usb hub not working

Wed Sep 05, 2018 10:25 am

i left it unpowered for a night and the usb smsc9xx is now being detected on boot. lsusb but I cannot power an external hdd which the pi reboots after 2 minutes of uptime
FLOSS enthusiast, Debian user (linux-libre)

hippy
Posts: 5583
Joined: Fri Sep 09, 2011 10:34 pm
Location: UK

Re: RPi internal usb hub not working

Wed Sep 05, 2018 1:28 pm

If you have damaged your Pi in the past there may be nothing which will ever make it work reliably.

Try with a another Pi. If that doesn't work then presumably the damage extended beyond the Pi and that HDD may also need replacing.

If the HDD works with the new Pi but not with the old then the old Pi would seem to be damaged beyond use.

Note that connecting something damaged to a Pi may lead to that Pi also being damaged so it might be easier and less costly just to replace everything, start again.

ejolson
Posts: 3226
Joined: Tue Mar 18, 2014 11:47 am

Re: RPi internal usb hub not working

Wed Sep 05, 2018 5:28 pm

hippy wrote:
Wed Sep 05, 2018 1:28 pm
If you have damaged your Pi in the past there may be nothing which will ever make it work reliably.

Try with a another Pi. If that doesn't work then presumably the damage extended beyond the Pi and that HDD may also need replacing.

If the HDD works with the new Pi but not with the old then the old Pi would seem to be damaged beyond use.

Note that connecting something damaged to a Pi may lead to that Pi also being damaged so it might be easier and less costly just to replace everything, start again.
I recently debugged a Pi 3B with apparent broken USB: the system booted fine from the SD card but then the keyboard and network didn't function. The problem turned out to be a version mismatch between kernels, modules and binary blobs in the boot, root and initial RAM filesystem. Everything worked fine after installing a new version of Raspbian on a different SD card.

sora03
Posts: 192
Joined: Mon Dec 29, 2014 4:11 pm
Contact: Website

Re: RPi internal usb hub not working

Sun Sep 09, 2018 12:04 am

so what can I do with a Pi that has a broken USB/eth and GPIO pins?
FLOSS enthusiast, Debian user (linux-libre)

LTolledo
Posts: 1644
Joined: Sat Mar 17, 2018 7:29 am

Re: RPi internal usb hub not working

Sun Sep 09, 2018 12:20 am

sora03 wrote: so what can I do with a Pi that has a broken USB/eth and GPIO pins?
These are what I can think of at the moment.... hope you dont mind... ;)

a. display in decorative frame
b. paper weight
c. electronics/smd parts source
"Don't come to me with 'issues' for I don't know how to deal with those
Come to me with 'problems' and I'll help you find solutions"

Some people be like:
"Help me! Am drowning! But dont you dare touch me nor come near me!"

sora03
Posts: 192
Joined: Mon Dec 29, 2014 4:11 pm
Contact: Website

Re: RPi internal usb hub not working

Sun Sep 09, 2018 6:09 am

the usb keyboard is working but usb flash drive/wifi adapters do not. i can still watch using kodi.
FLOSS enthusiast, Debian user (linux-libre)

sora03
Posts: 192
Joined: Mon Dec 29, 2014 4:11 pm
Contact: Website

Re: RPi internal usb hub not working

Thu Oct 11, 2018 12:53 am

If anyone is interested in the error messages, I have posted a screen shot of it. at https://z.awsmppl.com:8443/pics/pi2err/index.html

or just see them below:
Image
Image
Image

Conclusion:
1. The Pi 2B was damaged because it was being powered with 5.6 ~ 6V of Input power via microUSB with thick 20AWG cable. So, why did the polyfuse not blow?
2. The Pi's GPIO pins may be damaged because of not using a logic converter in the MCP3002 from a MQ2 Analog gas sensor at 5V

The Pi still boots from an microSD card but the USB and Ethernet are damaged, it won't accept the USB Flash/USB WiFi/USB HDD but it does accept USB Keyboard-why?, HDMI, Audio RCA works. I have not tested the Display connector and Camera connecter since I do not have one. It still works fine as a kodi media center powered by LibreELEC
FLOSS enthusiast, Debian user (linux-libre)

User avatar
Imperf3kt
Posts: 2539
Joined: Tue Jun 20, 2017 12:16 am
Location: Australia

Re: RPi internal usb hub not working

Thu Oct 11, 2018 1:42 am

The polyfuse blows after 6v, so applying 5.5v won't blow it.

You might be able to use the Pi in a headless set up, but being a Pi2b without WiFi and having both USB and ethernet not working, well...

But that temperature, if accurate... Should mean your Pi's SOC will shortly die and is the part you broke when you broke the GPIO bank. It's just taken a while to fully break, but the damage is irreversible.
55:55:44:44:4C
52:4C:52:42:41

sora03
Posts: 192
Joined: Mon Dec 29, 2014 4:11 pm
Contact: Website

Re: RPi internal usb hub not working

Thu Oct 11, 2018 11:43 pm

Imperf3kt wrote:
Thu Oct 11, 2018 1:42 am
The polyfuse blows after 6v, so applying 5.5v won't blow it.

You might be able to use the Pi in a headless set up, but being a Pi2b without WiFi and having both USB and ethernet not working, well...

But that temperature, if accurate... Should mean your Pi's SOC will shortly die and is the part you broke when you broke the GPIO bank. It's just taken a while to fully break, but the damage is irreversible.
the temperature sensor of the pi is going haywire, one to five second it is 300+ deg C and another it is 55 deg C. GPIO, ethernet and USB are broken. I am still trying to find ways to use this broken pi, maybe a picture gallery or kodi media center is a good idea.
FLOSS enthusiast, Debian user (linux-libre)

Return to “Troubleshooting”