darkbibble
Posts: 589
Joined: Mon Mar 09, 2015 5:20 pm
Location: corby, england

quake 3 problems

Mon Aug 20, 2018 12:54 pm

i couldnt get quake 3 to build from the current instructions so decide to copy my old install from my old backup, but now i cant get it running. i was compiled on a older raspbian version for the pi3

here is the error output

Code: Select all

[email protected]:~/Quake-files/quake3old $ ./ioquake3.arm
ioq3 1.35 linux-arm Apr 25 2017
----- FS_Startup -----
Current search path:
/home/pi/.q3a/baseq3
./baseq3/xcsv_bq3hi-res.pk3 (1204 files)
./baseq3/pak8.pk3 (9 files)
./baseq3/pak7.pk3 (4 files)
./baseq3/pak6.pk3 (64 files)
./baseq3/pak5.pk3 (7 files)
./baseq3/pak4.pk3 (272 files)
./baseq3/pak3.pk3 (4 files)
./baseq3/pak2.pk3 (148 files)
./baseq3/pak1.pk3 (26 files)
./baseq3/pak0.pk3 (3539 files)
./baseq3/curry.pk3 (4 files)
./baseq3/common-spog.pk3 (29 files)
./baseq3/common-q3map2.pk3 (14 files)
./baseq3

----------------------
5324 files in pk3 files
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
Couldn't read q3history.
Your network rate is too slow for VoIP.
Set 'Data Rate' to 'LAN/Cable/xDSL' in 'Setup/System/Network' and restart.
Until then, VoIP is disabled.
----- Initializing Renderer ----
-------------------------------
QKEY building random string
QKEY generated
----- Client Initialization Complete -----
----- R_Init -----
SDL using driver "x11"
libEGL warning: DRI2: failed to authenticate
eglSaneChooseConfigBRCM() failed
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
GLimp_Init() - could not load OpenGL subsystem


i hope someone can help get it running
Q; How many Windows users does it take to fix a Linux problem??
A; Whats a Linux problem

Return to “Troubleshooting”