iklingen
Posts: 2
Joined: Sun Aug 19, 2018 2:43 pm

libtiff5_4.0.3-12.3+deb8u6 seems broken

Sun Aug 19, 2018 3:11 pm

Hi All,

After last libtiff5 package updating (around end of July 2018) the CUPS has begun to work badly: when I tried to print a file I got the message "Filter failed".

The /var/log/cups/error_log contains the message:
D [19/Aug/2018:14:32:15 +0000] [Job 58] HP_LaserJet_1022: relocation error: /usr/lib/arm-linux-gnueabihf/libtiff.so.5: symbol __cxa_fknalize, version GLIBC_2.4 not defined in file libc.so.6 with link time reference
When I tried to fix name __cxa_fknalize to __cxa_finalize in the /usr/lib/arm-linux-gnueabihf/libtiff.so.5 I got a message about other name:
... relocation error: /usr/lib/arm-linux-gnueabihf/libtiff.so.5: symbol __stack_ch+_gqard ...
I changed the __stack_ch+_gqard to __stack_chk_guard I get next message:
... HP_LaserJet_1022: symbol lookup error: /usr/lib/arm-linux-gnueabihf/libtiff.so.5: undefined symbol: _TIFFBuilti~CODECS, version LIBTIFF_4.0
Then I tried to reinstall the libtiff5 package and got the first error with __cxa_fknalize name.

It seems to me the libtiff5_4.0.3-12.3+deb8u6 is broken.

The previous package libtiff5_4.0.3-12.3+deb8u5 was OK.

----

About my system:

$ uname -a
Linux raspi02w 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 8.0 (jessie)
Release: 8.0
Codename: jessie

fruitoftheloom
Posts: 17638
Joined: Tue Mar 25, 2014 12:40 pm

Re: libtiff5_4.0.3-12.3+deb8u6 seems broken

Sun Aug 19, 2018 6:14 pm

iklingen wrote:
Sun Aug 19, 2018 3:11 pm
Hi All,

After last libtiff5 package updating (around end of July 2018) the CUPS has begun to work badly: when I tried to print a file I got the message "Filter failed".

The /var/log/cups/error_log contains the message:
D [19/Aug/2018:14:32:15 +0000] [Job 58] HP_LaserJet_1022: relocation error: /usr/lib/arm-linux-gnueabihf/libtiff.so.5: symbol __cxa_fknalize, version GLIBC_2.4 not defined in file libc.so.6 with link time reference
When I tried to fix name __cxa_fknalize to __cxa_finalize in the /usr/lib/arm-linux-gnueabihf/libtiff.so.5 I got a message about other name:
... relocation error: /usr/lib/arm-linux-gnueabihf/libtiff.so.5: symbol __stack_ch+_gqard ...
I changed the __stack_ch+_gqard to __stack_chk_guard I get next message:
... HP_LaserJet_1022: symbol lookup error: /usr/lib/arm-linux-gnueabihf/libtiff.so.5: undefined symbol: _TIFFBuilti~CODECS, version LIBTIFF_4.0
Then I tried to reinstall the libtiff5 package and got the first error with __cxa_fknalize name.

It seems to me the libtiff5_4.0.3-12.3+deb8u6 is broken.

The previous package libtiff5_4.0.3-12.3+deb8u5 was OK.

----

About my system:

$ uname -a
Linux raspi02w 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 8.0 (jessie)
Release: 8.0
Codename: jessie

Raspbian Jessie is end of life as of 12 months ago, please use the supported Raspbian Stretch:

https://www.raspberrypi.org/downloads/raspbian/

https://packages.debian.org/stretch/libtiff5
Adieu

gkreidl
Posts: 5733
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: libtiff5_4.0.3-12.3+deb8u6 seems broken

Sun Aug 19, 2018 6:47 pm

fruitoftheloom wrote:
Sun Aug 19, 2018 6:14 pm
...
Raspbian Jessie is end of life as of 12 months ago, please use the supported Raspbian Stretch:

https://www.raspberrypi.org/downloads/raspbian/

https://packages.debian.org/stretch/libtiff5
This is not true. Jessie is still supported and gets bug and security fixes. This does not include the archive at raspberrypi.org.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

fruitoftheloom
Posts: 17638
Joined: Tue Mar 25, 2014 12:40 pm

Re: libtiff5_4.0.3-12.3+deb8u6 seems broken

Sun Aug 19, 2018 7:00 pm

gkreidl wrote:
Sun Aug 19, 2018 6:47 pm
fruitoftheloom wrote:
Sun Aug 19, 2018 6:14 pm
...
Raspbian Jessie is end of life as of 12 months ago, please use the supported Raspbian Stretch:

https://www.raspberrypi.org/downloads/raspbian/

https://packages.debian.org/stretch/libtiff5
This is not true. Jessie is still supported and gets bug and security fixes. This does not include the archive at raspberrypi.org.

Debian Jessie entered into Community Only Supported LTS 17 June 2018, Debian Security Team no longer support:

https://wiki.debian.org/LTS

https://wiki.debian.org/LTS/Extended
Adieu

iklingen
Posts: 2
Joined: Sun Aug 19, 2018 2:43 pm

Re: libtiff5_4.0.3-12.3+deb8u6 seems broken

Mon Aug 20, 2018 10:10 pm

Upgrading to Stretch resolved this strange problem.
Thank you.

Return to “Troubleshooting”