Posts: 16
Joined: Sat Feb 10, 2018 8:41 am
Location: Australia

Trouble with setting up desktop in a custom script

Fri Aug 10, 2018 10:48 am

Hello forums. What I'm trying to do is create a custom script which sets up my raspberry pi from a clean install of Raspbian Lite. I've had similar problems with this script before where running the RetroPie gui installer would stop my script after it was done (even though I didn't specify it to stop with an exit). I fixed this by installing/removing what I needed from the command line by using commands like these:

Code: Select all

sudo ./ setup basic_install
sudo ./ raspbiantools lxde
sudo ./ usbromservice remove
I also ran into a similar problem with the raspi-config settings, but I fixed that by following this: ... nfig-setup

Now I've run into a new problem. Even though I was setting up most of RetroPie without abrupt termination of my script, there was still something terminating it. After hours of testing, I isolated the cause of the error: the lxde line listed above. During setup, a GUI screen shows up saying something like "Adobe Flash Player copyright 2015 blah blah blah", and after it finishes installing my script ends. Commenting out the line allows the rest of my script to continue normally. I tried installing the desktop manually, but in doing so I realised that the problem comes from installing the package rpi-chromium-mods. This is the package that brings up the adobe popup and kills my script.

So my question is: is there any way I can stop this from happening (like with my two fixes above), and if not, how else can I work around this?


So I did another manual install test to make sure, and interestingly enough, even though the adobe popup came up, it still continued on with the rest of the script normally. This isn't a problem anymore, however I would still like to get rid of that popup so I don't have to check back on the installation.

Return to “Troubleshooting”