Page 1 of 1

Cannot Install Moviepy for Python 2.7

Posted: Fri Aug 03, 2018 12:37 pm
by JonnyAlpha
Hi;

I am trying to follow this tutorial for OpenCV robot vision:

https://www.hackster.io/kemfic/simple-l ... 3db2f?f=1#

However I am having trouble with the module 'moviepy'.

I am trying to install it using

Code: Select all

sudo pip install moviepy
but the output suggests that the Requirement is already satisfied, the list of locations however are all python 3.5.

How do I force it to install it for Python 2?

Thanks

Re: Cannot Install Moviepy for Python 2.7

Posted: Fri Aug 03, 2018 12:46 pm
by JonnyAlpha
Mmm I re-read details on installing packages and

Code: Select all

sudo pip install xxxxx
should install the module for python 2 and

Code: Select all

sudo pip3 install xxxx
for python 3.
In an act of desperation I tried

Code: Select all

sudo pip2 install xxxxx
and it worked - how bizzare - it was not documented