iain1940
Posts: 16
Joined: Sat Dec 22, 2012 8:53 pm

(solved - bad NOOBS sd) Initial NOOBS run on 3B+ produces blank screen

Sat Jul 07, 2018 5:17 pm

I just bought the Essentials Kit (from PIMORONI),
assembled it,
-connected to HDMI terminal
-mouse, keyboard in USB
- inserted NOOBS sd
- fitted power cable

After 'rainbow screen
- 4 raspberries

welcome screen

- initial text (varies slightly) but no time to read it

- a reference to 'systemd'

then blank screen - no activity

I'm going to download NOOBS/Raspbian images and burn new SDs to see if that is better.
Has anyone any other explanation other than a bad SD ?

thanks
Last edited by iain1940 on Sun Jul 08, 2018 12:47 pm, edited 2 times in total.

User avatar
B.Goode
Posts: 10356
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: Initial NOOBS run on 3B+ produces blank screen

Sat Jul 07, 2018 5:36 pm

There is a Troubleshooting guide in Issue 60 of the MagPi magazine which you can access for free online. https://www.raspberrypi.org/magpi/issues/60/

The Raspberry Pi Foundation have a Troubleshooting Guide on their website: https://www.raspberrypi.org/learning/tr ... ing-guide/

These forums have a post which contains all the information currently available about getting an RPi to boot: "STICKY: Is your Pi not booting? (The Boot Problems Sticky)" at viewtopic.php?f=28&t=58151



From the description you have given my first instinct would be to suspect the Power Supply.

But since the Essentials Kit you have purchased appears to contain an official Raspberry Pi Foundation power supply that is unlikely to be the case.

My suggestion is that you should report your findings to Pimoroni (or your vendor, if different) as soon as they open for business on Monday.

iain1940
Posts: 16
Joined: Sat Dec 22, 2012 8:53 pm

Re: Initial NOOBS run on 3B+ produces blank screen

Sun Jul 08, 2018 11:13 am

Thanks for response.

Problem identified.
It was the NOOBS SD card.

The same problem occurred when I tried the card on two older Pis - similar results.
Downloaded latest NOOBS and Raspian from RPi site.
Created Raspian SD with Etcher ( 1st time used - very impressed)
NOOBS failed "Error opening image (NOOBS_v2_8_2.zip) - invalid archive image"
sha-256 OK
retried downlaod - same result.

New Raspian SD worked perfectly.

If I had been a 'NOOBi' I'd have been very confused !

User avatar
procount
Posts: 2211
Joined: Thu Jun 27, 2013 12:32 pm
Location: UK

Re: (solved - bad NOOBS sd) Initial NOOBS run on 3B+ produces blank screen

Sun Jul 08, 2018 12:25 pm

If you are using Windows to open the zip file, you may need to use another tool like 7-zip to open it due to its size.
PINN - NOOBS with the extras... https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=142574

iain1940
Posts: 16
Joined: Sat Dec 22, 2012 8:53 pm

Re: (solved - bad NOOBS sd) Initial NOOBS run on 3B+ produces blank screen

Sun Jul 08, 2018 12:50 pm

No - running on Linux - xubuntu 18.04

User avatar
B.Goode
Posts: 10356
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: (solved - bad NOOBS sd) Initial NOOBS run on 3B+ produces blank screen

Sun Jul 08, 2018 1:51 pm

Downloaded latest NOOBS and Raspian from RPi site.
Created Raspian SD with Etcher ( 1st time used - very impressed)
NOOBS failed "Error opening image (NOOBS_v2_8_2.zip) - invalid archive image"
sha-256 OK
retried downlaod - same result.
Under what circumstances do you get that message? Are you trying to flash it with Etcher in the same way as the standalone Raspbian image?

crofter
Posts: 83
Joined: Thu Feb 22, 2018 11:28 pm

Re: (solved - bad NOOBS sd) Initial NOOBS run on 3B+ produces blank screen

Sun Jul 08, 2018 2:12 pm

eitcher will not work with noobs

i have tried

crofter

User avatar
DougieLawson
Posts: 39091
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: (solved - bad NOOBS sd) Initial NOOBS run on 3B+ produces blank screen

Sun Jul 08, 2018 2:24 pm

Forget NOOBS download plain full-fat Raspbian 2018-06-27.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

User avatar
B.Goode
Posts: 10356
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: (solved - bad NOOBS sd) Initial NOOBS run on 3B+ produces blank screen

Sun Jul 08, 2018 2:31 pm

crofter wrote:
Sun Jul 08, 2018 2:12 pm
eitcher will not work with noobs

i have tried

crofter
Precisely.

That's why I wanted to clarify whether that is what @iain1940 was attempting to do.

iain1940
Posts: 16
Joined: Sat Dec 22, 2012 8:53 pm

Re: (solved - bad NOOBS sd) Initial NOOBS run on 3B+ produces blank screen

Sun Jul 08, 2018 2:52 pm

Yes - that was what I was attempting. (Flash NOOBS using Etcher)


The Installation Page (https://www.raspberrypi.org/documentati ... ng-images/) gives you the option of NOOBS and Raspian. Then tells you to use Etcher - which apparently has never worked with NOOBS. see Etcher: Invalid archive image - (viewtopic.php?t=191735)

Joined Up Thinking !! ?

I don't see the point of NOOBS if it is just going to load Raspian anyway.
Anyway all finished happily.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5616
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: (solved - bad NOOBS sd) Initial NOOBS run on 3B+ produces blank screen

Sun Jul 08, 2018 7:57 pm

iain1940 wrote:
Sun Jul 08, 2018 2:52 pm
Yes - that was what I was attempting. (Flash NOOBS using Etcher)


The Installation Page (https://www.raspberrypi.org/documentati ... ng-images/) gives you the option of NOOBS and Raspian. Then tells you to use Etcher - which apparently has never worked with NOOBS. see Etcher: Invalid archive image - (viewtopic.php?t=191735)

Joined Up Thinking !! ?

I don't see the point of NOOBS if it is just going to load Raspian anyway.
Anyway all finished happily.
1) Etcher is not mentioned in the NOOBS guide here: https://www.raspberrypi.org/learning/so ... uickstart/ (However correct uSDHC card formatting is needed before a simple "drag & drop" copy.)
2) NOOBS can install other O.S.'s than Raspbian if a network connection exists. (NOOBS is an O.S. installer that can provide limited multi-boot options too.)
3) The availability of Etcher (compared to the tools available when NOOBS was conceived) has made things easier (safer) for Windows users so NOOBS is, perhaps, less useful than it was for some situations.
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, and a A+) but Buster on the P4B's. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

iain1940
Posts: 16
Joined: Sat Dec 22, 2012 8:53 pm

Re: (solved - bad NOOBS sd) Initial NOOBS run on 3B+ produces blank screen

Sun Jul 08, 2018 8:51 pm

Fair comment - perhaps I should have done more reading.
I'm coming back to the Pi after 4 years away so things have changed (eg NOOBS & Etcher).
I just jumped straight in !

Return to “Troubleshooting”