Page 1 of 1

A/V connection problem

Posted: Fri Jun 29, 2018 7:57 am
by serozhax
Hi friends!
I have the Raspberry PI 3 B+.
I can't connect it whith TV via A/V output. There isn't a picture on TV.
I bought cable for MP3 player and little modified it like on schema on internet. Multimeter test is OK.
Maybe I should edit some setings on device?
Help me please.

Re: A/V connection problem

Posted: Fri Jun 29, 2018 11:06 am
by DougieLawson
https://www.raspberrypi-spy.co.uk/2014/ ... ideo-jack/

What's your TV standard? The default if you add nothing to /boot/config.txt is that the AV video is NTSC 60Hz 480i.

Re: A/V connection problem

Posted: Fri Jun 29, 2018 11:36 am
by serozhax
DougieLawson wrote:
Fri Jun 29, 2018 11:06 am
https://www.raspberrypi-spy.co.uk/2014/ ... ideo-jack/

What's your TV standard? The default if you add nothing to /boot/config.txt is that the AV video is NTSC 60Hz 480i.
I followed this instruction.
And how can I find standard of my TV? It's model LG 21FS2CG-TS

Re: A/V connection problem

Posted: Fri Jun 29, 2018 12:21 pm
by DougieLawson
What country are you in?

add

Code: Select all

sdtv_mode=2
sdtv_aspect=1
That sets it to PAL 50Hz 576i 4:3.

Re: A/V connection problem

Posted: Fri Jun 29, 2018 12:59 pm
by fruitoftheloom
serozhax wrote:
Fri Jun 29, 2018 11:36 am
DougieLawson wrote:
Fri Jun 29, 2018 11:06 am
https://www.raspberrypi-spy.co.uk/2014/ ... ideo-jack/

What's your TV standard? The default if you add nothing to /boot/config.txt is that the AV video is NTSC 60Hz 480i.
I followed this instruction.
And how can I find standard of my TV? It's model LG 21FS2CG-TS

SDTV Modes

https://www.raspberrypi.org/documentati ... t/video.md

Re: A/V connection problem

Posted: Fri Jun 29, 2018 1:29 pm
by serozhax
DougieLawson wrote:
Fri Jun 29, 2018 12:21 pm
What country are you in?

add

Code: Select all

sdtv_mode=2
sdtv_aspect=1
That sets it to PAL 50Hz 576i 4:3.
I'm from Russia

Re: A/V connection problem

Posted: Fri Jun 29, 2018 1:48 pm
by drgeoff
Russia choose to follow France and use SECAM. However most TVs that can decode SECAM also decode PAL.

In any case, it is extremely rare that the wrong* setting of sdtv_mode in config.txt will of itself be the reason for nothing appearing on a TV screen.

(* Even 525/625)

Re: A/V connection problem

Posted: Fri Jun 29, 2018 1:50 pm
by fruitoftheloom
serozhax wrote:
Fri Jun 29, 2018 7:57 am
Hi friends!
I have the Raspberry PI 3 B+.
I can't connect it whith TV via A/V output. There isn't a picture on TV.
I bought cable for MP3 player and little modified it like on schema on internet. Multimeter test is OK.
Maybe I should edit some setings on device?
Help me please.

Cable issue ???

https://www.raspberrypi-spy.co.uk/2014/ ... ideo-jack/

Re: A/V connection problem

Posted: Fri Jun 29, 2018 2:02 pm
by pksato
Hi,
Or need to force composite output disabling HDMI.

Code: Select all

hdmi_ignore_hotplug=1
From wikipedia Russia use Secam as ATV color system. But, LG TV also is compatible with PAL.

Re: A/V connection problem

Posted: Fri Jun 29, 2018 2:03 pm
by drgeoff
1. Is the RPi actually booting?

2. Ensure nothing is plugged in to the RPi's HDMI socket when powering up.

3. What OS is on the card? Has NOOBS been used?

Re: A/V connection problem

Posted: Fri Jun 29, 2018 2:27 pm
by serozhax
drgeoff wrote:
Fri Jun 29, 2018 2:03 pm
1. Is the RPi actually booting?

2. Ensure nothing is plugged in to the RPi's HDMI socket when powering up.

3. What OS is on the card? Has NOOBS been used?
1. I have updated system today.
2. Nothing is plugged in to the RPi's HDMI socket.
3. OS Raspbian. Installed without NOOBS.

Maybe there is cable issue... But I checked it for many times...
1 - Video
2 - Ground
3 - Right Audio
4 - Left Audio

Re: A/V connection problem

Posted: Fri Jun 29, 2018 2:39 pm
by serozhax
pksato wrote:
Fri Jun 29, 2018 2:02 pm

From wikipedia Russia use Secam as ATV color system. But, LG TV also is compatible with PAL.
How to set it up? SECAM instead PAL.

Re: A/V connection problem

Posted: Fri Jun 29, 2018 2:46 pm
by drgeoff
serozhax wrote:
Fri Jun 29, 2018 2:39 pm
pksato wrote:
Fri Jun 29, 2018 2:02 pm

From wikipedia Russia use Secam as ATV color system. But, LG TV also is compatible with PAL.
How to set it up? SECAM instead PAL.
TVs can often automatically switch between PAL and SECAM.

But even if the PAL/SECAM setting is not correct you would get a black and white display.

You did not confirm that the RPi is booting.

Re: A/V connection problem

Posted: Fri Jun 29, 2018 2:55 pm
by serozhax
pksato wrote:
Fri Jun 29, 2018 2:02 pm

Code: Select all

hdmi_ignore_hotplug=1
IT WORKS!!!! Thank you!!!

P.S. If i want connect HDMI must I change this setting?

Re: A/V connection problem

Posted: Fri Jun 29, 2018 5:26 pm
by pksato
serozhax wrote:
Fri Jun 29, 2018 2:55 pm
pksato wrote:
Fri Jun 29, 2018 2:02 pm

Code: Select all

hdmi_ignore_hotplug=1
IT WORKS!!!! Thank you!!!

P.S. If i want connect HDMI must I change this setting?
Yes, need to set to 0 or comment or remove the line.

Re: A/V connection problem

Posted: Fri Jun 29, 2018 9:47 pm
by klricks
serozhax wrote:
Fri Jun 29, 2018 2:55 pm
pksato wrote:
Fri Jun 29, 2018 2:02 pm

Code: Select all

hdmi_ignore_hotplug=1
IT WORKS!!!! Thank you!!!

P.S. If i want connect HDMI must I change this setting?
When using the default settings of Raspbian (Not NOOBS), the RPi will automatically use HDMI if connected at boot. If no HDMI is connected then the RPi will automatically switch to composite (AV) on boot.
You only need to change the setting for PAL:

Code: Select all

sdtv_mode=2